Comodo kills my connection

So 2 weeks ago I ditched Zonealarm and installed Comodo, then power off. Next day i couldn’t get online, it says “Limited or no connectivity”. I tried “repair” but didn’t work, I mess around with many settings but nothing worked. I eventually rang my ISP telling them my internet isn’t working. They helped with troubleshooting but they couldn’t seem to find what was wrong with my comp. So I gave up. Then I remembered that this happened around the time I installed Comodo, so I uninstalled and restart, it worked perfectly! Just to be sure I reinstalled Comodo after that and restart. No connectivity. What happened?

XP Pro, using DSL. I also run Avast! and Spybot, any known conflicts?

Thanks for taking the time to report this bug. This bug report isn’t very useful because it doesn’t describe the bug well. If you have time and can still reproduce the bug, please read sticky topics on this board and add a more useful description to this bug.

Ok, some more info.

XP Pro SP2 32-bit CPU
Running utility apps: Avast! free edition, Spybot
Symptoms: Internet connection lost after install&reboot, returns after uninstall&reboot
Resolution taken: Tried to ‘Repair’ connectivity through the Network Connection, unplug&replug modem and cables
Defense+ & Firewall+ settings: First time it happened, learning mode, second try, safe mode. Didn’t modify any settings before the connection were actually lost.
No crashes/involuntary reboots. Were using an Administrator account.
Connection type is DSL (I don’t know further detail). No traffic at all is registered in “Properties” of my network connection (Sent: 0, Received: 0)

In order to reproduce the bug I need to simply install Comodo normally and reboots

If there is any detail I’m missing please ask.

Ok, thanks, that’s better :-TU. Please tell about your network configuration: wireless? modem in bridged mode or set as router (wired connection)? dynamic or static IP address?..

Set as a router I guess, it’s wired to a line. Dynamic IP I think. It changes every now and then. Also, this is the only PC in this home.

I remember something related. I guess there is no bug here. CF blocks everything by default and i think it blocked some of dhcp traffic, hence you had broken connection. If you install CF next time try to look into firewall logs. It should show svchost.exe (?) blocked connections.

Create appropriate rule(s) for svchost.exe and that should fix issue for you.

will try, but does this mean that everybody using similiar systems experience this?

Didn’t work.
tell me if I did it wrong. I opened the tab for Firewall+ and put svchost.exe on the ‘trusted’ list. Then I restart.

I also put in all ‘windows system application’ as trusted.

What appears in firewall log (screenshot) (“view firewall events”) just after you get broken connection? What are your global rules?

the log is empty (it’s just been installed, so).

There was one global rule that was there by default but I tried removing that and now I don’t remember what it was. It was something like Block Any IP— I thought that was suspicious so I removed it. Rebooted and still no connection.

I’ve uninstalled comodo 3 times now.


I suggest inspecting every rule, and where-ever you find a “Block …” ensure it is “Block and Log …”
Then you should get entries in the log file, which may give a clue on what is being blocked.

Additionally, if you would like to know the context of what is being blocked, assuming you have no Global rules, then create a single “Allow and Log IP In/Out” Global Rule and you should get all the firewall log data you can handle !

If “Allow and Log” is too much, you can preceed that with relevant “Allow …” rules that refrain from Log.