Comodo keeps blocking trusted files! [Solved]

Hi guys sorry to have to complain but for the last couple of days I’ve been pulling my hair out trying to get CIS to recognize the Clevo HotKey Control Center, I’ve pretty much tried every available option with no success.
First up here are the files I’m trying to add:

They’re both located in Program Files(x86)>Hotkey

I’ve tried adding them to the trusted files list, define exclusions for behavior blocker, excluded applications in AV, Firewall App rules, rating scan and I even submitted them as false positives, yet no success, what usually happens is after a reboot, those two files end up back in the unrecognized files list, removed from the define exclusions list, excluded apps, FW app rules and are back in the unknown files list.
I’ve even tried adding it to the Trusted vendors list but get the error msg: “The File Does Not Seem To Be A Valid Signed Executable”.
Is that the problem? I’m hoping you guys can help out with this as I can’t do simple things with the Hot Key app blocked, some of the function keys are rendered useless, can you add this to the whitelist at all?

Mod edit: Added solved to the topic title, Captainsticks.

OK funnily enough I seem to have pinpointed the problem, I went through every procedure again, deleting my options and rebooting to see if I could figure out how to get CIS to allow Control Center through.
Anyway long story short and slightly embarrassing on my end of things, I went back into Behavior Blocker>Define Exclusions For Behavior Blocker, TICKED both programs and selected OK at the bottom of that window and then OK back in the main window of Behavior Blocker, I don’t think I originally hit OK in the previous window, as it obviously didn’t save my settings, LMAO, feel like a ■■■■■■ now but yeah, it seems to be solved, so for all you ppl freaking out and not been able to figure something out, it pays to ALWAYS select the “OK” button on everything in CIS :stuck_out_tongue:

Hi bzrwon,
Good to hear that you got it sorted. :-TU
The following wish maybe of interest to you.
Would you like to have an Apply And Refresh button to the advance settings window?

Kind regards.

Yeah I think that would be a good idea, mainly for your avg user, that’s not as technically inclined as others, as I’m an IT enthusiast and currently studying in the field at uni, I’m not too bad at getting around the full capabilities of your product, as I stated previously my biggest problem is rushing through things and not double checking the little, obvious, things, like actually selecting OK, LOL but yeah I think that would be a nice feature to add to the next build, I’m looking fwd it! :slight_smile: