Comodo is reporting Comodo Application Agent not running!!

Hi,
Today I discovered a yellow exclamation mark for Comodo Firewall. On opening the interface it says that “Comodo Application Agent is not running”

I have run the diagnostics tool and that found some problems at first and rebooted (this has happened several times but never cured the problem) and now the DT finds no errors at all.

The FIrewall, Defense and Sandbox are all in Safe mode.

A scan (nearly 2 hours) of ESET Online scanner and an AVAST scan has shown nothing strange and only SAS showed up some cookies!!

Comodo Firewall : 5.10.228257.2253
Anti-Virus : AVAST PRO 7
AntiSpy : SuperAntispyware 5.5.1016 / MBAM 1.65.0.1400 / SpywareBlaster 4.6

OS: Windows 7 64bit, 6GB RAM, Pent i7

Any ideas?

Thanks

Can you please verify the services and see if ‘Comodo Internet Security Helper’ is set to Automatic and is started

Hi,
From the Task Manager it is running and even on the MSCONFIG. Not sure where to see if it is Automatic

Can you right click on your network icon (next to the clock) and chose ‘Open Network and Sharing Center’
Change Adapter settings, and select your adapter, right mouse → properties and see if ‘Comodo Internet Security Firewall Driver’ is present?

Hi,
Yes it’s there and ticked.
Do you think a re-install is called for?

Did you run the run diagnostics?

As in the first post, yes. The first few times it found a problem and rebooted the computer. The last few times it doesn’t find anything!!

Just to update.

I did a new install. I will post back here to say how things are going. At the moment everything is up and running normally but I have only just installed again.

Thanks once again.

Thanks and please let us know if it happens again…

It has happened again!! :o

I turned off the computer several hours ago and have just turned it on again. The Comodo Firewall has the yellow exclamation mark again.

I have run the Diagnostics which said it found a problem (never says what it found so maybe Comodo can put this into a program update?).

Rebooted the computer but still yellow. However, while booting the computer the very first time, it did crash.

At this moment of time everything looks OK but when I do the Diagnostics check it say that something is wrong and that I may have to restart the computer.

Is there a log I can check to see what’s happening?

OK the situation is now this.

I have turned the computer on, run diagnostics and obtain the message that it has found problems. I click OK to fix them and it says that I may need to reboot. After, I run the diagnostics again and nothing is found!! After rebooting, I run the diagnostics again and it says that it has found problems again!!

Any ideas or should I un-install which “RevoUninstaller”, reboot, run CCleaner to clean the registry and re-install again?

Thanks

Since it is 64 bit Revo will not be able to install it. I would advise that you reinstall it by following the advice I give in this topic. Essentially, make sure you run the uninstaller tool at the correct time.

Please let me know if you have any questions.

Thanks.

Hi Chiron,

I followed the instructions to the letter in that topic about uninstalling. Rebooted twice to be on the safe side and then re-installed with a fresh copy of the cfw installer.
Everything looks like it’s running OK except that when I run the diagnostics test it still shows up something wrong. If I DON’T reboot and run the Diagnostics again it says everything is OK but if I reboot and run it I’m told there is a problem.

Should I worry about this? Could it even be a problem with the diagnostics tool? I mean, unless somebody sees a problem, who runs it?

If the diagnostics tool finds an error you have an option to save a log/report, can you please save that rename to .txt and upload it here.
I think something is removing files CIS needs

Hi Ronny,

Thanks for your reply. Sorry to say but NO there isn’t an option to save a log file not unless it is somewhere in one of the Comodo menus. If so where is this option?

The window that is displayed after the scan only has the message that something has been found and “Yes” and “No”

Thanks

Oh yes, forgot that option is only available if it can’t fix the issue.
What other real-time security software do you have running and might that cause issues removing files that Comodo needs?

Also running a disk check might be a good idea.

Hi,
I’m running AVAST PRO Anti-virus and MBAM with running protection. MBAM doesn’t have the website protection on. As for SUperAntiSpyware this is just a back up and ON DEMAND not running.

A Check Disk scan has shown nothing.

Can you disable those real-time parts for a while, might disconnect your network to prevent infection, to test if that causes issues?
Do logs of Avast or MBAM show traces of it finding something?

OK I will disable the AVAST and MBAM and rerun the diagnostics.

NO the logs show nothing. In fact at first I did a scan with ESET online scanner as I thought it was a virus but nothing showed up. Only a few cookies with MBAM.

I’ll disable and rerun and post here.

I disabled all protection: AVAST, MBAM and (sorry I forgot to say in a recent post but it’s in the first) SpywareBlaster.

I did the diagnostics three times and rebooted each time. The same results i.e. Run diagnostics first time it finds a problem, Click OK, run diagnostics second time and nothing found. If I reboot and then run diagnostics it says that there is a problem…and this is the loop.

Visually I can’t see any problems!!! “All systems are active and running”!!!