Comodo is freezing my comp

Well, Comodo has worked perfectly so far, but then when I play wc3, with allowing port 6112 TCP in/out and allowing the program Warcraft3 FrozenThrone.exe to use the port 6112 TCP in/out. It works fine, but when I try to join a custom game or create my own, (custom games are hosted by people outside of Blizzard/ itself, so they are individually hosted games) my computer actually freezes, to an extent. I can SOMETIMES get the start bar after like ten minutes and even logging off does not git rid of the warcraft 3 page across my screen. I can’t even use Task manager becuase I cannot see it over the warcraft 3 page. This means taht I have to manually restart my computer. How the hell does Comodo mess with my comp, and make it lag so badly? E-6600, 2gb’s 667mhz ram…nothing has lagged me so far, except for comodo. This is REALLY annoying cuz i have to set comodo to “allow all” to play wc3. Please help me with this problem, and I have been contemplating using a different firewall because this problem is so pointless.

DMZ when playing games?

What is DMZ? And clarifying the issue, when I try to join or make custom games on (warcraft 3), and my comodo setting is anything but “allow all”, my computer will essentially freeze. The warcraft 3 screen is locked and I cannot close the application at all (also VERY VERY laggy and slow). Logging off does not even work. Why does comodo do this? I listed my comp specs because it shows that they are very good, how does comodo jam it up soooo much? I also let the games port through everything I could find.

If WC3 works when playing on BattleNet but hangs when playing a custom game, do the custom games use a different port?

If they do, you will need to create a second rule to allow the different port number.

Hope this helps,
Ewen :slight_smile:

P.S. Thanks Paul for removing the swearing.


obsenely sorry for the swearing, just really annoyed. And no, custom games use port 6112. Technically you do not have to allow it TCP IN to join games, just to host games.

Hi, I am not doubting you here, but most games used on this port need TCP In\out rules and need to be allowed. If you don’t allow TCP in, you can block communication. If you look at many gaming rules, it will say the 6112-range should be open, not just IN\OUT specified. Allow 6112-whatever, make sure open and set the rule priority by moving it up in the list may work.


Here is my network moniter rule:


I also have this application rule:

-ALLOW TCP/UDP in/out when destination port is 6112 and destination IP is any.

I have put the priority of the network moniter rule to the top and have yet to try it out (hate having to manually restart computer). Some other topics have been created similar to this, but what is a remote port thing? It does not seem to be on my version (newest one) of comodo…

A remote port is for a remote pc(remote host) you connect to using outbound while they have inbound rules. You specify a port to the remote computer so you can communicate.

Unfortunately unless I google for a better definition, this is from the top of my head and if you want more specific I can get you an exact definition.


Yeah, that is great, but how come my comodo does not mention them? Also back to the original question (seemed to have hijacked my own thread a bit) how come I cannot join/host games in warcraft 3 without it crashing my comp (essentially)?

You may have to specify a range 688? to 6999? should check on this. Also, are you behind a router? The reason I would see you getting freezeups as much like when I started my first gaming, my rules were wrong, my pc would freeze it can simply be a system hang from this and believe me, many many people have had this happen. I won’t rule out other issues as of yet but this is typical. Also, did you go to TASKS and set zone rules, this may help as well and answer your question about allowing a trusted pc on the web or network. :wink:



If you export the logs and post them here we can see what CPF is blocking adn why. This will go a long towards being able to work out how to get things running smoothly.

Ewen :slight_smile:

If you can generate a crash dump, then you should go to Comodo Support, register on their system & create a ticket (sending them the crash dump zipped). If you do this, please remember to post any feedback you get. Thanks.

Good idea Ewen. :slight_smile: Another six months i’ll remember to ask for this. (:TNG)


LOL - it was my third posting and I only just remembered. LOL\

Ok, no port ranges need to be specified! (urge to swear) My router is CONFIGURED by ME to allow PORT 6112 TCP IN/OUT. That is all there is to it. No extra ports no router blocking. Also my other computer on the network can host/join games perfectly (uses norton) with the SAME RULES I am using on comodo (different format of course cuz dif program). No reports or logs are created, or if they are, they get deleted at restart right? If so then that is just stupid, I can’t even log off and log back on, the wc3 screen still covers it, and lags my comp like hell. I told you the rules I used. Something specific to comodo is blocking it. I really just don’t get it though, why does comodo mess it up and other firewalls don’t? My logs are also spammed with BitComet “access violations”, not really that bothersome though. Please try and post stuff that actually contributes to the thread (u guys are the fricking mods, its supposed to be ME thats posting pointless stuff…). I really don’t want to have to do the whole ticket thing, such an idiotic problem, like does comodo think that I am being TCP flooded? Would that be a possible solution? If so why does it like lockdown my comp eternally until restart?

Please try and help, again don’t have any logs other then spammed BitComet ones.

Hmmmm, this could be but unfortunately I have no useful information and would be pointless of me to answer. Sorry I can’t help you, perhaps you should go here and submit a support ticket

DMZ the router when playing your games.

I’ve also got the same problem as the OP. I am on my home Lan with 4 other pc’s. I decided to try comodo firewall, however whenever i try to play warcraft 3 custom games (create them), my pc just hangs and i cant really do much afterwards. I’m able to open up task manager and restart from there, but unable to close the non-responding warcraft application. The other pc’s have mcafee firewall, and zone alarm free version which allow me to play the game error/problem-less.

I’ve created a rule to allow the warcraft application and also created a network rule to allow port 6112. I read in another thread something about creating a temporary rule to allow everything and place it as rule 0. I did that, and still no luck. I’m starting to wonder if it is an application conflict. Maybe admin/the developers need to look into this.

If theres a solution already, please link to it >.<

Edit: i previously had the trial version of outpost pro v4 on this pc and i could play the game(create games etc) witout any problems.

I suspect that a freeze might not what it appears to be. If you’re running a full screen game, then it’s possible that CPF has generated a pop-up (in the background, behind the game) which you cannot see. The result, would perhaps be similar to what you are describing. Next time this happens, can you try ALT-tabbing to see in you change the focus (and hopefully produce the hidden pop-up). To aid the ALT-tabbing, I recommend that you keep an explorer window open when you run WC3. This will give you something to “tab to” if there is no CPF pop-up. If this allows you to return to desktop, this will at least give you more scope for investigation & see what’s going on (or not, as the case may be). You’ll also know that your system is not frozen… just WC3.

Was there anything relevant to WC3 in CPFs logs? I suspect not, since you were forced to perform a reboot.

Vengence: I don’t think this is likely to relevant to your issue, since you can generate a crash dump & as a result, I suspect your issue is something else entirely. Did you manage to send a crash dump to support? I’m sure this would help Egemen (CPF Dev) identify the problem.