Comodo is blocking Outlook

Hello,

Comodo firewall has been working fine on this PC for a long time until this afternoon. I tried to go to outlook and I got a page telling me I couldn’t connect. I get teh following message in Chrome:

Warning: Unsafe Website Blocked!
outlook.live.com
This website has been blocked temporarily because of the following reason(s):
HTTPS Site: Blocked site uses S-HTTP encryption. You may have received a browser security message before loading this unencrypted warning page.
Phishing: Site may be criminally fraudulent attempting to collect your personal information by masquerading as a legitimate site
Go back to safety (Recommended)
This website has been reported as unsafe by various users and we do NOT recommend you to continue browsing.

I get the same in IE. Even if I turn off the firewall I still get these messages. Everything was working fine until this afternoon. No one was on the PC so it’s not like someone messed with the settings.

  1. How do I fix this?

  2. If I can’t fix it hwo do I uninstall so no traces are left and conflicting with windows? OS is windows 7.

Thanks in advance.

EDIT 1: I am able to connect to outlook via chromes incognito mode. But I can’t connect via any other way.

Hi and welcome KINGOFTHENEWS,
This sounds more likely to be a Comodo Secure DNS issue, not a Firewall issue.

To disable Comodo Secure DNS select the appropriate link below and in the final step of the instructions select ‘Obtain DNS server address automatically’.
Windows XP - Manually Enabling or Disabling Comodo Secure DNS
Windows 7 / Vista - Manually Enabling or Disabling Comodo Secure DNS Service

Kind regards.