Comodo is blocking Natwest online

For the last few months the Natwest banking website can take up to 5 - 10 attempts to log into. The first page loads fine no problems then the login when you put your details times out all the time. I’ve tried a virtual machine with XP rather than my usual Windows 7 PC and it the same thing happens. After googling around a bit I found a few other posts relating to other Comodo users having the same problem with the Natwest website. It loads fine but the login screen keeps timing out. I don’t want to uninstall Comodo because I like it any ideas how to fix this problem?

Have you tried temporarily disabling CIS and then trying to access the login page for the purpose of testing?
Edit: I just thought of something, did you accept the Comodo Secure DNS when installing CIS? In that way you can set your DNS settings to DHCP or some other DNS you want.

Are you using Comodo Secure DNS?

Yes I had to uninstall it and put AVG on which I’m not too happy about but I got straight onto the Nawest site So it defiantly was CIS yes I think I’m using the secure DNS server is there a way not to use it? AVG slows my boot time right down I want to put Comodo back on now!!

Below is a quote from captainsticks which has links which describe how to change it.

Remember that during the installation of CIS you will be asked if you want to install Secure DNS, it will be ticked in by default so you have to un-tick it.

Edit: Though since you uninstalled CIS without changing the DNS settings and the site started working normally, I am wondering if it’s really the DNS which brings the problem though I wonder what else in CIS could slow a certain website down :-\

Right that makes sense yes I can’t seem to find a clear answer for it. I tried disabling the program all the elements anti virus, firewall etc. but it still blocked it anyway I also tried using a Virtual machine that has AVG on it and it still seemed to block it even though it was not on the same PC I suppose the internet still comes through the same place so if the DNS sever was active it would still block it anyway. I tried using the direct address also and the DNS server gave an alert and said it was a Phishing site!! so it’s obviously a big false positive. I’ve only been using Comodo for about 4 or 5 months so I am not an expert user, I really do like it however I might try putting it back on, it’s a lot of messing around though!

Do you have any browser extensions installed which could interfere with the site.?

I know from personal experience when using comodo dragon i could not get into the adobe flash player and some other sites until i disabled what captainsticks suggested.

Sorry i cant think of anything else which can help.

thanks for all the replies well I’ve just put Comodo back on without the DNS server and BINGO! it works so it must have been that. I tried all the different browsers I had before and made sure no other programs were interfering with my setting so I’m almost certain it was the DNS server this is the second time I’ve installed Comodo and after you mentioned the DNS server I have a clear idea of what I’m doing now as soon as I installed it I unticked that box and the box that wanted me to change the homepage I uninstalled Geek Buddy as I have never used it and turned off the message centre so I did it pretty quick this time. I will let you guys know if it does it again I really think Comodo need to look into this the Natwest website must be used by millions of people every day so I can’t be the only one. To be honest I’m not entirely sure what the DNS server does apart from making it a but more secure using the Comodo one but I don’t think I need it. Thanks for all your help guys!!


Glad it’s working for you.

The DNS is what translates a domain name like to an IP-address, what Secure DNS do is block the sites which are believed to be phising sites or malware or such, so they won’t resolve the right IP-address which means you won’t connect to the malware server. The actual technical way this works I don’t know, it is possible that there will be false-positives which will block legit sites, you can report these in the Secure DNS part of the forum found here: Comodo Forum
I don’t know if perhaps the site is blocked or simply Secure DNS doesn’t have any records of it or something, perhaps it’s unable to resolve the address? I wouldn’t know, just speculating here.

Thanks that made sense! I think I will report it it’s one of the biggest banks in the UK so they need to get it sorted but I’ll be leaving off the DNS server for now I think. On a different note the boot time with Comodo is at least half what AVG is!

Thanks for the advice and the workaround. Has this issue not been resolved yet?

I’m confused why Comodo’s DNS continues to block one of the biggest banks in the UK

Is it possible for you to PM to me a screen shot of the error / message you receive?

Natwest front page shows but when you click on log in the page trys to load then it just says internet explorer cannot display the webpage.
You can try it front page try & log in

This appears to be a Internet Explorer security requirement issue, this is resolvable by adding to Internet Explorers trusted sites list.
Found under the ‘Security’ tab of the ‘Internet options’.

Kind regards.

I will try that but it seems funny when I use Comodo secure DNS I cant access Natwest, but when I use DNS server Address Automatically it’s ok

Just a final update on this issue I added the to Firefox & IceDragon still no joy, so I am now using Norton DNS this allows me to do my banking with no problem.
Thanks for your help.

Since it appears to be an issue with Secure DNS please consider submitting NatWest in Report Blocked Sites You Believe Are Safe Here to get it unblocked.

Thanks I did submit it like I said it blocks Natwest even after adding it to the browser so now I’m using Norton DNS & Firefox to access my banking the comodo IceDragon browser blocks natwest too even without comodo DNS

Just to be on the safe side did you flush DNS cache after changing to Norton DNS servers? If not please do so and let us know if that made a difference or not.

Does this problem also happen with other browsers?