Comodo is blocking accessibiliity featurs

I have turned on the accessibility options from Windows control panel. And then I have chosen the “Toggle Key” option…to have the system make a sound when the caplock or numlock keys are struck. It works great is I don’t let Comodo start. As soon a Comodo boots up, the accessibility features are disabled. I don’t know why this is so…I don’t think I can determine which files are required to use the windows accessibilty features at all.

In general, if I a file is blocked (I chose to “not allow” for example). How do I change this setting, since I can’t find a list of all the processes that asked me whether to permit or not permit an application to do something.). I would like the option of reversing some bad decisions, and also, and in partiicular, I need this computer to allow use of the aforementioned accessibility features…so I definitely need to undo the settings for those. (Which now apparently are blocked…though i don’t know why).

Any help with 1) allowing me to use accessibility and 2) changing a previous decision regarding any application would be greatly appreciated. I never had this problem in Zone Alarm…and may be forced to reconsider it if this becomes too cumbersome.

Thank you,

Hi Chick, welcome.

To view a list of applications/process controls: GUI > Defense+ > Advanced > Computer Security Policy

I would recommend either Clean PC Mode or Training Mode while you boot up so it’ll automate the creation of the necessary Defense+ rules for you and allow it or them. You can then change it back to your desired Defense+ mode. All these can be toggled by right-clicking the CIS system tray icon and going to Defense+ Security Level.


It has been in Clean PC mode all along. So…I am guessing I changed something afterwards. If I go to training mode and boot…then it should work ok…I believe this is what you are telling me. Then I can go back to clean PC mode.


Forgot to mention, I can see the list of applications in the computer security policy, but some of them and other windows system applications are somewhat of gobblygook to me. I don’t know which is related to the accessibility problem. The file names are not intuitive. I suppose I could remove them one at a time…then see if accessibility works(?).

Again. thank you.


I tried your suggestion and rebooted the Defense+ in training mode. And it didn’t change anything. I then disabled Defense+, rebooted, and also…no change. I then went to the firewall and rebooted it in Training mode and the problem still persisted. The only time the problem is resolved is when I completely disable the firewall (not Defense+).
So…it is my novice opinion that the problem resides somewhere in the firewall settings. I am wonderring what the next logical step is in this case. I don’t see any windows app files in the network security policy under the application ruiles. Only familiar programs. Under the Predefined Firewall Policies, > Application Network Control, it says: “Block all incoming and Outgoing Requests” I assume for all blocked applications. But as I said, in the firewall applications there aren’t any blocked applications listed (except under Comodo Global).

Again…only disabling the firewall (not defense+) allows the use of the accessibility feature(s). I would like guidance as to how to systematically deal with this. Should I reset Comodo to original settings…remove all the learned apps, etc? And if so. how?

Also…and this is unrelated…there are always files for me to review. Sometimes hundreds, sometimes thousands. Always one at a time (You can’t select a block of files, only one file or ALL files) Many I recognize (or the source vendor is listed) but others look like either system files or something esoteric that I can not recognize. I submit them to Comodo for analysis and invariably most come back with the status of ?UNKNOWN. What’s one supposed to do about these?

Thanks very much for the help. I gotta solve this pretty soon. I need to get back to work.

You can ignore these if you want. Or, if you want better security, change the D+ mode to Safe Mode (then you won’t get anything in the My Pending Files section).

Right click on the CIS tray icon (then see the attached pic for more info)

[attachment deleted by admin]

I will try your suggestion and move D+ to Safe Mode…and see how that goes. I am guessing there will be more interruptions. But worth a try.

Thank you.

PS Still gotta figure out the firewalll settings to allow accessibility to work.

Now that is strange. I also thought it was Defense+ blocking, not the Firewall component. Take a look at the Events/Log entries and see what’s being blocked and feel free to upload it.

If you would rather just reset the settings to the defaults, you can either right-click the CIS system tray icon and change the Configuration.

Alternatively, access the GUI’s Miscellaneous screen and click on Manage Configurations > Import - Select the one you prefer or selected when you installed CIS. Once done, don’t forget to change the current Configuration that you imported. If you never exported your config, then skip all this.

Other than what Jeremy pointed out about Safe Mode not bugging you with Pending Files, Clean PC Mode could actually reduce the number of unnecessary alerts. It really depends how long you’ve “trained” CIS to recognize your files as safe. Basically, if you think you’ve explored and used all your programs already, you can switch to Safe Mode. I tend to switch back and forth between these 2 modes.

Here are the firewall apps and global log images and the defense+ events:

[attachment deleted by admin]

I don’t see any particular problems with your firewalls rules.

In the Events screen, click on the More button at the bottom to open the “real” logs. See if you recognize any familiar applications that were blocked.