Comodo IS 5 does not let Windows 7 SP1 install.

I found after hours of trying that Comodo IS 5 stops the install of Windows 7 Service Pack 1. I tried first turning off defence+ and later firewall but that did not help I had to quit Comodo totally to get it installed.

Does this match your problems?

I solved it by downloading SP1, when that was done then I disabled the AV realtime with no internet connection.

I hope my solution will work for you.

Valentin N


No not really. When installing SP1 it will take hours before the green bar ends but it will not end or reboot the machine. After manually shutting down the computer it starts up normally but nothing is installed.

[at]Valentin N

I have installed SP1 by shutting down Comodo totally but maybe your way does the job also. I wrote this so people will know that Comodo has a problem at this moment with W7SP1.

Comodo is not the only one; just google and you will see others.

I am sorry to hear that you’re having problems

Valentin N

Hi Eljo. MS recommend temporary disabling AV products with caution, if SP1 is having problems. It states some AV may prevent or slow down its installation. Don’t forget to re-enable after. Kind regards

Service pack 1 went in on my machine without a single glitch. Comodo was perfectly happy with it. I realize that this doesn’t help, necessarily, but a good service pack installation can be done with Comodo enabled. It also went in just as cleanly on my NIS2011 machine.

I didn’t run into troubles with CIS v5 but with another problem that I had to solve first.

The following is just for reference for other users.

Try running System Update Readiness tool and see if there are inconsistencies in Windows that prevent you from a successful update to SP1.

Also running sfc /scannow from the command prompt may help to find and fix inconsistencies in Windows.

In my case the problem was caused by having used an older version of Driver Sweeper. The Phyxion forum has a sticky topic about it: .

This worked fine for me also!