COMODO Internet Security high CPU usage

I am still having problems with CIS taking up cpu as I reported here:

After booting up with no extra cpu load CIS started doing it again after about 1/2 hour or so of being idle. I am afraid I am going to have to to get rid of Comodo rather than put up with this stuff all the time.

Did the uninstall, rebooted - no CPU usage stuff. Used the remove tool and rebooted, still no high cpu stuff. Reinstalled CIS with AV, rebooted (the shutdown hung up) and still no CPU usage stuff until about 1/2 hour or so of being idle when the CPU load from CIS began again and ran for about another 20 minutes or so.

Can you please list your Operating System and Security Software here please?

I’ll try to get another moderator or developer to help you out for the time being.


I have XP SP3, SUPERAntiSpyware Free and Malwarebytes’ Anti-Malware Free. No other security apps or av’s other than CIS.

Try the following.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

I did not find any leftover drivers from previous security/av software.

Are there other program installed that interact with netwerk connection like Netlimiter or alikes? Try temporarily disabling them.

I did not find anything like this. I did, however, have a BSOD this morning due to high cpu usage during bootup.