Comodo Internet Security hangs computer with firewall popup alert [M380]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: No
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Firewall asks for permission to allow or disallow programs to connect. It freezes in the time of appearance. You can click any answer (allow, block, etc…) but the command doesn’t got acknowledged. The popup windows freezes, and hangs the computer too. You can for exapmle open a CMD window, but cannot run a shutdown command.
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?: Read the FAQ
  • Any software except CIS/OS involved? If so - name, & exact version: …maybe?!..
  • Any other information, eg your guess at the cause, how U tried to fix it etc: No gues. Try of fix is shutdown the computer through Start - Shutdown (not working everytime, on every computer), or just have to turn off the computer by force (unplug from main, or pushing the power button until turning off)
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
  • Can’t do that. This problem is rare but very high priority.
    UPDATE: Attached a usual process list by KillSwitch, and the config file wich used always after I install CIS.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: Hardware independent problem. Software: Win7 Ultimate x64 ENG, CIS 6.0 , CIS 6.1, and MANY more software. Hamachi VPN, TrueCrypt 7.1a, RealVNC Server 5, Merak Mail server 7, Serv-U FTP server 5, Apache Web server 2.2.9, etc, etc…

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: AV, Firewall, HIPS
  • Have U made any other changes to the default config? (egs here.): YES!
  • Have U updated (without uninstall) from a CIS 5?: NO.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: NO.
    [li]if so, have U tried a standard config - if not please do: No, and will not do that. It has to work in this way. UPDATE: I can’t take out this computer on the net with deafult config for days / weeks until the problem occures…
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Win7 Ultimate x64 SP1 ENG, UAC Disabled, Account: administrator, no VM.
  • Other security/s’box software a) currently installed b) installed since OS: a= NO Other Security Software b= No other security software were installed. Clean Win7 with CIS 6.0 OR 6.1 The problem occurs on BOTH version!

Can’t attach the config file, and the process list CSV file… The forum doesn’t allows it.
UPDATE: Mouse1 told me to ZIP the files, so upload was successful.

One more info…
This computer is rarely restarted. If it helps.

[attachment deleted by admin]

It might be related to the other network issue…

It might not.
It is an old problem with version 6.0 AND 6.1 too.
There is no slowdown, no internet blocking, no lan issue… it hangs the computer, if it is waiting for some input from the user, but no input form… Waiting, and blocks other processes being processed, because it waits for something… Something we don’t know, because there is no display about that.
And if I press ALLOW (with ticked Remember option), after the freeze and restart, the rule is not in the rule list.

That sounds like some other alert is in queue for this one causing a lock, might be difficult to catch tough as it’s not stably reproducible.

Same issue here. I just did a fresh install of CIS from the download on the website not 2 hours ago. It worked fine. Ran scans, setup firewall rules, etc. Then after downloading a program update, the computer locks up solid if I respond in any way to any firewall alert. OS is Win8 and I previously had BitDefender installed (which was of course removed before installing Comodo) if that helps any. Note: when I say it locks the system up solid I mean it. Can’t run Task Manager or anything. Mouse works. Ctrl-Alt-Del works (but again if I click the link to Task Manager nothing happens even if I let the system sit). Restart hangs, shutdown hangs, etc. Only option is to power down and cold boot. If I ignore the firewall pop-ups (as I’m doing as I type this) the system runs just fine. Note: this is a new computer build so other than running BitDefender for a few days (and hating the firewall limitations BTW… kudos to Comodo) I doubt any software on my end is causing the problem. I am running Classic Shell, but again CIS ran fine until the update.

Hardware specs:

CPU: Intel Core i7-3930k (oc’d to 4.4 GHz)
Mobo: ASUS Rampage IV Extreme
RAM: 32 GiB G. Skill Trident DDR3 2400
Video: GeForce GTX 680
… etc.


After posting the above I tried something. I waited for about 10 minutes for all the firewall alerts to appear (without touching them as doing so had been causing lock-ups 100% of the time over the last 20 boots), then I launched the Metro… excuse me… Modern UI and launched CIS from there rather than the System Tray with Classic Shell. Then I was able to respond to all firewall alerts with no lock-up. However, I doubt Classic Shell itself is to blame since the OP said he is running Win7. Perhaps just waiting 15+ minutes after boot before responding to any firewall alerts is a workaround. Still appears to be a serious bug.

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

  • Your watch activity active process list. You should be able to access this before the computer locks, or by setting it as your default task manager on the options menu, then doing Cntrl - Alt - Del withit locked
  • You diagnostics file. You should be able to access this before the computer locks
  • Details of the changes you made to your config, or an exported config file
  • Information on whether the problem occurs with a default config, for problem diagnosis purposes
  • Other security/s’box software a) currently installed b) installed since OS:

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


To the OP and anyone else who may be interested, I have more info on this bug. It occurred to me again. This time the system had been running for quite a while already. The dialog box that caused the hangup was for WSClient.dll access on port 80 to Oddly, I can continue using programs that were already open (like my web browser). I just can’t open anything new, restart, open Task Manager, etc. after choosing to either block or allow this access (unsure if un-checking “Remember my answer” would make a difference). Also, the rule doesn’t get applied because after a cold boot it will eventually come up with the same prompt for the same process. I am running the firewall in “custom” config rather than “safe” if that makes any difference. For those who don’t know, this system process is related to the Windows Store and is part of Windows 8 and since the OP said he is running Win7 I’m guessing the process causing his hang-up is different. Just something else to look into. For now, I am going to reboot and manually create a rule for this DLL before the pop-up occurs to see if that is a workaround. Will update if I learn anything more.

I don’t want to start a new thread since it seems like the exact same bug the OP reported but if needed I can get you the running tasks info the next time this hang-up occurs (can’t now since I can’t open Task Manager or Comodo or anything else until I cold boot). However, I should point out that since he and I are running different OSes, and as we both reported this only started happening after the latest update, it is highly unlikely that any other software is the cause.

Update: And you don’t have to just click Allow or Deny. Once one of these computer-hanging pop-ups appears clicking on ANYTHING in ANY Comodo dialog (even trying to open the Comodo Task Manager) causes the issue, making it impossible to provide the requested information for a bug report. Basically the bug is: after latest update CIS firewall dialogs can cause computer to hang.

Turning off HIPS so far seems to help, but since it can take many hours for the bug to reappear I can’t be certain.

PM reminder sent

Would you like me to post a formatted bug report on mine even though it is the same problem? Can’t give you the running tasks when the error occurs since as the OP and I have both said you can’t open Task Manager (Comodo or M$) with this bug. Also of note, if you are lucky enough to be able to open Comodo Task Manager before one of these system-locking pop-ups appears it is blank. Shows no tasks at all.

Still thinking the problem is HIPS-related since it appears that normal firewall alerts may not cause the lock-up. I didn’t notice this at first since it isn’t always clear which alerts are HIPS and which aren’t.

Same issue here. :-\



It would be great if you could, and ensure that the information I list above is in it. An Watch Activity process list taken before the event occurs is still helpful, as it shows what software you are running. By “Comodo Taks Manager is blank” do you mean Killswitch. (Confusing naming I know).

If you could check with HIPS off to see if this occurs that would be valuable.

Many thanks


Yeah, I caught that naming issue right after I posted that. Made me feel pretty dumb since I’m a programmer myself. I have Killswitch running constantly now and am waiting for the hang-up to re-occur. As I pointed out it doesn’t happen with every Comodo pop-up so all I can do is wait. Soon as it happens I will post the whole thing. To this thread? Or should I start another?

Same thread if you would not mind

Many thanks


PM reminder to DeJUan and Thales sent

This could be related to the bug I reported here:

My bug is characterised by a message in windows event log saying that cmdagene.exe has crashed.

Original Post updated yesterday.

Ta, sorry

Btw. I think we are still missing the diagnostics file? If I have missed it my apologies in advance.

Pm reminder sent

No diagnostic file has been attached.
How can I create one?

If you find the ‘?’ in the top right hand corner of the main GUI, you’ll find the link to diagnostics.

(More generally the red links in the format post tell you how to do everything - or pretty much everything!)

Many thanks for doing this