Comodo Internet Security 8.2.0.5027 hotfix build is released!

My guess would be all browsers but I don’t know for sure . Sergey, could you fill us in?

In this link: http://cdn.download.comodo.com/cis/download/installs/4000/standalone/cispremium_installer.exe is the same installer like in : http://download.comodo.com/cis/download/installs/4075/standalone/cispremium_installer.exe ??? What means 4000, 4075 ?

I’ve tested the new browser protection it is for any installed browser. One problem if you use 2 browsers that use the same profile like Firefox and Waterfox does then every time you use Waterfox it change certain firefox profile settings and you have to tell Comodo to allow for it every time. What they need is to have it remember your answer when ask for a certain program so you aren’t bug about the same question all the time. Maybe that can be a request for the next version of CIS .

very nice release. I have completely removed the old CIS and removed all the folder and freshly installed CIS 8.2.0.5027. But still the problem persists. CIS is not starting when starting the computer. Comodo comes up with a message that it will check for faults but not finding anything. At the end, I had to manually start it. Then it starts without any issue. Precisely for the same reason I uninstalled the old version of CIS. Is any one experiencing this issue any solution? Thanks
OS: Microsoft Windows 7 - 6.1.7601 Service Pack 1 x64.
Nellai

They both provide the latest version v8.2.0.502. I don’t know why the cdn is set up like that though.

What process is not starting? Cis.exe, cmdagent.exe, cistray.exe or cavwp.exe? Can you check with Task Manager?

Before upgrading to this version I never had these weird behaviours (see attachments; “Ignorato”=ignored).
What could they be?
Also the warning of the firewall disappeared (therefore denying it) just after 120 seconds, altough I have “Set new on-screen alert time out to” disabled!

[attachment deleted by admin]

The Sandbox i set to ignore any Windows Metro Apps and it logs when logs when the rule trigger, you can go to Auto-Sandbox Rules and Edit the Metro apps Rule, then go to Options and look for “Log this action when its performed” and uncheck it.

Go to the COMODO main window and press task in the top right corner, then firewall task and check if Manage Networks is ether in Trusted or blocked network, i get this System alert when Manage Networks docent have a rule to follow (e.g none of the options is checked), and it triggers this “system” alert

the Firewall alert stay there for 120sec by default
and you can check “Set new on-screen alert time out to =XXX” option if you want to customize how long the alert should stay, e.g 1 - 999sec

One of the default sandbox rule is to ignare metro app. Please check if you have that rule enable.
Maybe the upgrade reset your setting to default (this may apply for the firewall popup too)

Note that I did not do a clean install.

Ok, the rule to ignore Metro Apps was added by this upgrade, problem solved.

In Manage Networks I have it on Trusted. Before this upgrade I never had such a warning.

Also the option “Set new on-screen alert time out to” is still disabled like I want it, but that window disappeared like it was set enabled! I then forced an HIPS warning and despite the option on HIPS disabled, it behaves like it’s enabled; now I enabled it, press OK, disabled, press OK, but in “Configuration Changes” in CIS Logs I don’t see anything; forced a warn and it still behaves like it’s enabled!

The Alert windows stay there for 120sec by default, and if you check/enable
“Set new on-screen alert time out to” (e.g custom time) you can change how long you want the window to be there, but not more then 999sec

Set new on-screen alert time out to: Determines how long the Firewall shows an alert for without any user intervention. By default, the timeout is set at 120 seconds. You may adjust this setting to your own preference.

Dunno, sry

Hm, ok strange, make sure you have a System Rule in Comodo/firewall/application rules
but if you dont you can go to Manage Networks then click on Block Network then click on Trusted Network and Comodo should create a new System rule in Application Rules.
Firewall application rules docent have a System Rule and it can triggers a “system” firewall alert

if that doesn’t work then i dont know sry

I think you are wrong.
With that option disabled it should leave the warning indefinitely.

EDIT: in the attachment it’s shown my settings for that weird System firewall warn.

[attachment deleted by admin]

yea it looks strange, IP In from Russia to.
Dont know why you get this alert, hopefully some one more knowledgeable about COMODO can come and help.

The firewall alert shows incoming traffic at port 137. It means that that port is open in your router. On what type of connection are you by the way?

At the beginning after booting up the system I only saw CisTray.exe and cmdagent.exe running. An error message appear automatically which reads “COMODO Security Agent could not be started. Would you like to run the diagnostics tool to fix this error?”. If I say yes it runs Comodo Diagnostics and checking for errors. At the end it did not find anything. “Diagnostics did not find any errors”. After closing i see only cmdagent.exe is running.
So I guess there is no antivirus or firewall running at this time. I had to manually open the CIS from the shortcut I kept I desktop exclusively for this purpose. Now I see everything from CIS running afterwards including the desktop widget.
So this is causing frustration every time I had to start CIS manually. This is like this from the past versions as well. I updated to the latest CIS as given in the beginning of this thread.
Thanks.
Nellai

On my router I have some ports opened but not that one, altough i also have UPNP enabled (and I can’t see if that port was open on that time, but shouldn’t be weird if UPNP opens such a port?).
I don’t understand your question, what types of connection exist?! I’m on wired if that’s what you wanted.

About that 120 seconds duration of alerts: anyone else with that option disabled still see the alert disappear?

This looks odd at first sight. First cmdagent.exe runs and quickly after that the error shows up. Could you next time check to see if cmdagent.exe is running or not when you get the alert?

Would you like to run the diagnostics tool to fix this error?". If I say yes it runs Comodo Diagnostics and checking for errors. At the end it did not find anything. "Diagnostics did not find any errors". After closing i see only cmdagent.exe is running. So I guess there is no antivirus or firewall running at this time. I had to manually open the CIS from the shortcut I kept I desktop exclusively for this purpose. Now I see everything from CIS running afterwards including the desktop widget. So this is causing frustration every time I had to start CIS manually. This is like this from the past versions as well. I updated to the latest CIS as given in the beginning of this thread. Thanks. Nellai
When cmdagent.exe is running you're protected even when the client programs cis.exe, cavwp.exe and cistray.exe are not running.

You could set Windows to always restart the Comodo Internet Security Helper Service to always restart when it crashes. That way you don’t have to do that. You can find the service under Control Panel → Administrative Tools → Services. See attached image for further clarification.

[attachment deleted by admin]

Hi Dustyn,
It protects Comodos browsers, also Chrome, Firefox and Internet Explorer.
Other browsers are intended to be added in the future.

I would think browsers sharing profiles with any of the above maybe partially protected as well.

Kind regards.

Believe me it protects any shared profiles. But will continue to bug you anytime you use the shared profile you should be able to tell CIS to remember your answer on any product so you don’t have keep allowing the same program over and over again. I mean on the browser settings protection.

It is odd it is open though.

You could use PortMapper to see what ports are open on your router and to close them. It’s a nice tool which uses upnp. It requires Java.

I would keep an eye out to see if the port opens again. And just to be sure you could scan your computer for possible malware.

I don't understand your question, what types of connection exist?! I'm on wired if that's what you wanted.
That's what I wanted to know. With wireless connections mobile phone providers may connect multiple users behind one IP address (like your router would with your LAN). In that case the open port would be upstream and not with you.

How do I disable this feature? I use Firefox, and have recently noticed that my Flash plugin will now be randomly disabled instead of “ask to activate” like it always has been, this is annoying because when I come across a video I want to watch like on Twitch, the video never loads and I figure it’s this feature causing this problem, since it’s the only thing that has changed only my system since this problem starting popping up.