COMODO Internet Security 8.2.0.4474 BETA works only on Windows 10 ?

Hy to all. COMODO Internet Security 8.2.0.4474 BETA works only on Windows 10 , not in Windows 8.1?

It even works on WinXP ;D

Hi digi340 and Xeno,
Working fine here on both Win 7 32-Bit and Win 8.1 64-Bit.

Kind regards.

On Windows 8.1 x86 not work (failled to install network driver).Previous version work so fine on Windows 8.1 x86.

Hi digi340,

Uninstall Comodo Drivers from the Ethernet properties as shown in attached screenshot. It is not listed in the screenshot but you will find one. Once done, you should be able to install Comodo again.

[attachment deleted by admin]

Now i install Comodo 8.2.0.4474 Beta on Windows 8.1 x64 but same error - Comodo Driver is not present on Ethernet properties.Back to previous version and all work fine.Why?

Hi digi340,

I am clueless now. Did you try uninstalling CIS and then used any removal tool to clear remnants? May be that will help.

Please try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.

I saw this situation before. Please try thiese tips:

  1. Unninstall CIS;
  2. Reboot the pc;
  3. Clean registry and files with Piriform CCleaner;
  4. Reboot the pc;
  5. Go to control panel, devices management and remove your network adapter and the driver;
  6. Reboot the pc;
  7. You windows, after reboot, will automaticly install the network driver and all will be good again;
  8. Right click CIS installer (any version) and run as administrator and install it;
  9. Stop the initial update and scan;
  10. Reboot the pc for the last time.

Be cool and have fun…

ps.: If not working than sadly you will have to restore your computer to a point before the first attemp on installing new cis version, or format c: and install all over again… But I beleave that my tips will solve the problem to you…

Same result .Back to Comodo 8.1.0.4426 and install succesfuly.On Windows 8.1 x86 or x64 on my 2 pcs not appear on Ehernet Comodo network driver.With Comodo 8.1.0.4426 all work fine.Thanks anyway.

Hi digi340,

Another thing you can try is extract binaries (cis_setup_x64.msi or cis_setup_x86.msi) from installer and install them same. For me in Windows10, installer fails. Extracted binary successfully installs. Hope this helps.

Extract binaries with 7 zip work?

Should work. I use Bandizip.

I discover the problem : device association services must set to “automatic”, devices install services must set to “manual”, device setup manager must set to “manual”.On my pc’s was set all “disabled”. After install disable permanently viruscope, but after few minutes automatic set to enabled.