COMODO Internet Security 6.0.252829.2560 Bug Reports

Please post all bug reports & BSOD’s here and make sure to include:

  1. Issue. A 1-2 line statement of the problem - you expand it in section 6.
  2. Diagnostics report as attachment to your post
    Click on Help(Question Mark icon) in the main menu, choose Support->Diagnostics. When diagnostics scan is complete, click on “Create Report…” and save the report. This report is essential for us to quickly identify the configuration you have.

If diagnostics report file size is large, please use www.ccloud.com to UPLOAD and SHARE it. You can paste ccloud.com link from this share. You can upload this report to any other place and share the link.

Developers will absolutely give NO attention if this item is missing in a post.

  1. The full product and its version e.g. COMOOD Firewall 6.0.252829.2560
  2. Your Operating System (32 or 64 bit) and Service Pack revision
  3. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?
  4. Other Security and Utility Software Installed
  5. Step by step description to reproduce the issue
    This step is crucial for us as well. The most valuable report is the one with precise reproduction steps.

This format will be strictly moderated. If your messages do not convey this format, they are not going to be taken into account.

[Edited by mouse, after consulting Ronny, to include summary 13/10/2012]

Let’s follow the bug format please guys… and only bug format posts to be posted here.

  1. Diagnostics report as attachment to your post
  2. The full product and its version e.g. COMOOD Firewall 6.0.252829.2560
  3. Your Operating System (32 or 64 bit) and Service Pack revision
  4. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?
  5. Other Security and Utility Software Installed
  6. Step by step description to reproduce the issue

Cheers
Josh

Summary of issue: Not sure if its a bug, but I figure that clicking on purge in “trusted files” should purge all of the invalid files without having to repeat the process.

  1. Diagnostics report: see attached
  2. Full Comodo product and version: CIS 6.0.252829.2560
  3. Operating System: Windows XP SP3 32-bit (running on VM player version 4.0.2 build-591240)
  4. Configuration:
    Configuration: Proactive
    Firewall: Enabled (safe mode)
    Defense+ HIPS: Enabled (safe mode)
    Defense+ Behav Blocker: Enabled (partially limited)
    AV: realtime scan enabled
  5. Other installed software:
    Security: Nothing running realtime. Malwarebytes, Hitman Pro, TDSSKiller on demand.
    Utility: CCleaner and Cleanup!
  6. Step by step description to reproduce the issue: open CIS advanced settings > Trusted files. Click purge, then “okay”. Close CIS. Re-open CIS advanced settings > trusted files. The “purged” files were still there. When I tried re-purging several more times, a few files were purged with each attempt, until eventually all the invalid entries were deleted (note: no new files appeared on the purge list during this process).

[attachment deleted by admin]

Friendly reminder to all forum members:

All reports should be in the correct format (see first post in thread for format):

  1. Diagnostics report: see attached
  2. Full Comodo product and version: CIS 6.0.252829.2560
  3. Operating System: Windows 7 SP1 64 bit
  4. Configuration:
    Configuration: Internet Security
    Firewall: Enabled (safe mode)
    Defense+ HIPS: Enabled (safe mode)
    Defense+ Behav Blocker: Enabled (partially limited)
    AV: realtime scan enabled
  5. Other installed software:
    Security: Nothing running realtime. Malwarebytes.
    Utility: CCleaner
  6. Step by step description to reproduce the issue: I have dual monitors stacked vertically 1280x 1024 res. with the primary monitor being the one on the bottom. I open Kiosk (have silverlight and CD installed) I can get to the “Metro” tablet UI and the classic UI using the yellow arrow at the top. The issue is that neither of those UIs display a “start” button or any way to exit the Kiosk. I have to ctrl+alt+del and log off the computer in order to exit the kiosk. I also tested it by changing the settings of the monitors and making them link side to side instead of the other configuration and it works fine I have the “start” button and can exit the Kiosk.

[attachment deleted by admin]

When a file got detected either in a scan or by the realtime, there is no add to trusted like there use to be, was this over looked?.
But in the selected scan, in Action if you click Add to trusted the program says “Clean” but still adds to trusted.

Edit: For some files even if you go Add trusted to all some still go to quarantine.

Diagnostic Report: Attachments and it said no problems found.
The full product and its version: Comodo Internet Security Premium Beta- 6.0.252829.2560
Your Operating System (32 or 64 bit) and Service Pack revision: Windows 7 Ultimate 64bit
List all the configuration changes you did. Fresh Install after clicking Fix because it needed a restart
Other Security and Utility Software Installed: N/A
Step by step description to reproduce the issue: Right click scanned a file detected by the AV and when you click the drop down for the single file, there is only Clean, ignore once and add to excluded. No add to trusted (I rather trusted files over excluded files) But if you click Actions drop down its in there but if you select it the file now says Clean instead of Ignore.

[attachment deleted by admin]

Summary of issue: UI bug both in user interface with English & Chinese Simplified on Windows 7 32-bit Chinese Simplified OS.

1. Diagnostics report: File attached

2. Full Comodo product and version: CIS 6.0.252829.2560

3. Operating System: Windows 7 SP1 32-bit

4. Configuration:
Configuration: Proactive
Firewall: Enabled (safe mode)
Defense+ HIPS: Enabled (safe mode)
Defense+ Behavior Blocker: Enabled (partially limited)
AV: realtime scan enabled

5. Other installed software:
No other security software.

6. Step by step description to reproduce the issue:
Case 1:
The name of .exe file contains Chinese characters. In the Behavior Blocker popup window all the Chinese characters of the filename shows as ??. See the attached figure “UI bug1.png”.

Case 2:
a) Open CIS advanced settings > general setting > language, select the Chinese Simplified(中文(简体)-By COMODO), then click the “OK” button.
b) Right click CIS system tray ico > Exit.
c) Restart CIS.
d) Run an unrecognized .exe file. On the Application Isolated popup window “sandboxed as partially limited” does NOT show correctly. See the attached figure “UI bug2.png”.

[attachment deleted by admin]

Summary of issue: “View Logs” link doesn’t work

  1. Diagnostics report: File attached

  2. Full Comodo product and version:
    CIS 6.0.252829.2560

  3. Operating System:
    Windows 7 SP1 Home Premium 32-bit in VMware Player 5.0

  4. Configuration:
    Default Internet Security

  5. Other installed software:
    No other security software.

  6. Step by step description to reproduce the issue:
    Run Update from main GUI icon. After it is finished, “View Logs” link doesn’t work. There is no cursor change above, it does not respond to pressing and does not open log window.
    Tasks-General Tasks-View Logs works fine.

[attachment deleted by admin]

  1. DIagnostics report :
    http://www.freefilehosting.net/cisreportv60252829256020121010-122411
  2. COMOOD Internet Security Premium Beta 6.0.252829.2560
  3. Windows XP SP3 32 bits
  4. Default configuration for Proactive Mode
  5. None

Bug 1

Open Firefox and leave opened.
Open Firefox using right click contextual menu option : Run In Comodo Sandbox and leave opened.

Check using Advanced Tasks/Watch Activity to see if the two instances are shown correctly. On my system one of them is missing - the virtualized one.

Bug 2

Replicated Bug 1 steps a couple of times switching the opening order of the two instances. After 2-3 tries non-virtualized Firefox lost all opened tabs (overwritten by virtualized Firefox tab settings ?! - not sure).

Bug 3 - Edit 1

Open Firefox and leave opened.
Open Firefox using right click contextual menu option : Run In Comodo Sandbox and leave opened.
The virtualized instance will not have window border highlited. If there is no other non-virtualized instance opened the highlited window border is present.

1. Diagnostics report: File attached

http://www.freefilehosting.net/cisreportv60252829256020121010-115814

2. Full Comodo product and version: CIS 6.0.252829.2560

3. Operating System: Windows 7 SP1 64-bit

4. Other installed software:
Security: Nothing running realtime. Malwarebytes, Hitman Pro on demand.
Utility: CCleaner and Auslogics Disk Defrag

5.Step by step description to reproduce the issue
After installing Comodo =>>>
http://nsa32.casimages.com/img/2012/10/10/121010121457373080.png

“Cant init Agent”

[attachment deleted by admin]

the same as you windows xp service pack 3 32bit
it’s dont start after run i go to the program files and run it from cmdagent it says comodo application agent not running

Summary of issue: GUI text bugs

  1. Diagnostics report: File attached

  2. Full Comodo product and version:
    CIS 6.0.252829.2560

  3. Operating System:
    Windows 7 SP1 Home Premium 32-bit in VMware Player 5.0

  4. Configuration:
    Default Internet Security

  5. Other installed software:
    No other security software.

  6. Step by step description to reproduce the issue:
    1.jpg: firewall, defense+, sandbox and antivirus should start with capital letters since these are names of the modules (Firewall, Defense+, Sandbox and Antivirus)
    2.jpg: Av should be AV
    3.jpg: android should start with capital letter (Android)
    4.jpg: computers’s should be computer’s cause the description is about single computer
    5.jpg: Mb(s) should be MB cause it doesn’t mean anything. Mb is megabit. MB is also used for plural.
    6.jpg: make space between traffic and left bracket
    7.jpg: make space between Isolated and left bracket
    8.jpg: undoes should be reverts. Disregard should be Ignore. Sounds better. The whole path of detected file is not visible. You should make text wrapping.
    malware1.jpg: What does Malware[at]#0 and ApplicUnwnt[at]#0 mean? Instead of 0 there should be some random number.
    malware2.jpg: The whole path of detected files is not visible. You should make text wrapping. Just like in CIS 5.x.

[attachment deleted by admin]

  1. Diagnostics report as attachment to your post
  2. The full product and its version e.g. COMOOD Firewall 6.0.252829.2560
    CIS 6.0.252829.2560
  3. Your Operating System (32 or 64 bit) and Service Pack revision
    Win 7 x64 SP1
  4. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?
    Proactive security
  5. Other Security and Utility Software Installed
    None
  6. Step by step description to reproduce the issue
    Web Browser ruleset is missing from the list.

[attachment deleted by admin]

1. Diagnostics report as attachment to your post Done.

2. The full product and its version e.g. COMOOD Firewall 6.0.252829.2560 CIS Premium Beta 6.0.252829.2560

3. Your Operating System (32 or 64 bit) and Service Pack revision Windows 8 Enterprise-N 64bit.

4. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference? It’s pretty much default, I don’t see how any of the changes I’ve made would cause this problem.

5. Other Security and Utility Software Installed No, except Windows Defender which comes with W8 by default and it’s disabled.

6. Step by step description to reproduce the issue Drag and drop a file to either scan it or sandbox it, it doesn’t work. Cursor changes, see attached image.

[attachment deleted by admin]

Diagnostic Report - See Attached

Product Version - 6.0.252829.2560, CISP Beta Suite

Operating System - Genuine XP SP3 32 Bits Eng

Configuration - Defaults

Other Softwares - No other RealTime security softwares, MBAM & HitmanPro OnDemand, CTM 2.6

Issue Discussion - During malware test on the above mentioned real system (no VMWare, etc) I observed that-

Some malware were not cleaned i.e CIS mentioned quarantine but they were still in the location (Desktop) - RealTime Scan. Manual Scan i.e RightClick Scan was able to clean those malware. Browser used was IE 8.

Sometimes AV Alerts, AutoSandbox Alerts & Elevated Privilege Rights Popups appeared behind the open windows.

And when 2 popups were there i.e one popup & on top of it another popup, sometimes clicking on the top popup the other popup also disappeared.

[attachment deleted by admin]

1. Diagnostics report as attachment to your post

Done.

2. The full product and its version

CIS Premium Beta 6.0.252829.2560

3. Your Operating System (32 or 64 bit) and Service Pack revision

Windows 8 x64 9200 Pro (RTM)

4. List all the configuration changes you did.

Antivirus and firewall notifications- on.

5. Other Security and Utility Software Installed

No, except Windows Defender which comes with W8 by default and it’s disabled.

6. Issue

Virtual Kiosk can`t load.

7. Step by step description to reproduce the issue.

Install- update- scan- reboot (all of that by pressing “fix” button). No way. Reboot. No way. Reboot twice. Again no way :-TD

[attachment deleted by admin]

1. Diagnostics report attached
2. The full product and its version e.g. COMOOD Firewall 6.0.252829.2560
3. Your Operating System (32 or 64 bit) and Service Pack revision: Windows XP SP3 x32
4. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?
Custom “Ask Me” configuration, added regedit entry for full virtual
5. Other Security and Utility Software Installed
None
6. Step by step description to reproduce the issue
Opened virtual kiosk, tried to open two random folders and jpg file, kiosk frooze, hard restart was necessary
Geekbuddy ad on system restart or CIS restart does not go away even when checkbox was put on do not show this anymore…

EDIT: all fixed by itself somehow, all OK… I did restart the last time and now is OK…

[attachment deleted by admin]

Summary of issue: I have a sample but have no idea whether it’s a bug or not, please confirm it.

1. Diagnostics report: File attached

2. Full Comodo product and version: CIS 6.0.252829.2560

3. Operating System: Windows 7 SP1 32-bit

4. Configuration:
Configuration: Proactive
Firewall: Enabled (safe mode)
Defense+ HIPS: Enabled (safe mode)
Defense+ Behavior Blocker: Enabled (partially limited)
AV: realtime scan enabled

5. Other installed software:
No other security software.

6. Step by step description to reproduce the issue:
a). Double click GGService.exe.
b). GGService.exe is isolated as partially limited.
c). Open KillSwitch, but the “Restriction” column of GGService.exe process is “None”. See the attached figure.

sample link: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

[attachment deleted by admin]

Summary of issue: No French translation

  1. Diagnostics report:
  2. Full Comodo product and version: CIS 6.0.252829.2560
  3. Operating System: Windows XP SP3 32-bit
  4. Configuration:
    Configuration: Internet Security
    Firewall: Enabled (safe mode)
    Defense+ HIPS: Enabled (safe mode)
    Defense+ Behav Blocker: Enabled (partially limited)
    AV: realtime scan enabled
  5. Other installed software:
    Security: Nothing running realtime.
    Utility:
  6. Step by step description to reproduce the issue: CIS 6 is installed in French but 98% is not translated. See attach file.

[attachment deleted by admin]

Hi lyonel,

“Our devs are now really working ■■■■■■■ v.6 of which Beta version will be issued only in English.”

So please wait until all translations will be finished.