Comodo Internet Security 2024 v12.3.2.8124 BETA

Yes.

Clean profile.

I have to reset the computer and enter the security mode of OS to disable the HIPS module.

There seems to be no dump file, the only thing related that I could find in event viewer was EnhancedStorage-EhStorTcgDrv during the time when it was caused. When trying to reproduce, it works just fine? I’m presuming windows fixed its own mistakes in repair and the reason no fix on the VM is because the storage is virtualized. It’s still odd this only is applied in the beta version of Comodo and not the main…

When you say reproduce do you mean you uninstalled CIS and reinstalled it?

Can you check the integrity of both Windows installations with the following commands (run them from the command prompt as administrator):
chkdsk /f
sfc /scannow
DISM /Online /Cleanup-Image /RestoreHealth

If if fixed things try installing CIS again and see what happens.

What happens when you switch to Proactive Security profile? Does it freeze again?

CIS was removed by startup repair, I installed it again and it worked just fine. On the VM however trying anything for chkdsk, sfc, dism, it says it fixed it and yet it still continues to blue screen. I’ve tried it on a different machine and it seems to work fine. The only issue I can see this being is the storage drive or virtualization for comodo on my system that is fixable by startup repair on the host system.

It was recently announced on here that they’re aiming for a stable release this month so look for that in the next 6 months to a year.

1 Like

Yes. It also reproduces in the proactive security profile.

The problem reproduces in the VM. Comodo may be interested in the memory dump (assuming one is created). Could you create a bug report in Bug Reports, Beta Corner - CIS - Comodo Forum ?

Can you think of a program that could interfere with CIS? Like another security program that runs alongside CIS or other programs with drivers that interact with network or disk? If so try uninstalling and see if that makes a difference. There is something on your system that trips up CIS.

I will reinstall and test further.

unablre to uninstall beta, unable to install over current installed beta (installer complaints that older version must be removed but no trace on windows install manager nor in revo uninstaller )…

also comodo uninstaller tool shows no progress (only first caution alert and them nothing happens)…

assuming that my windows is trashed now :face_exhaling:

Use ciscleanuptool Old v3.0.0.41.

1 Like

Where are the promised bug fixes?
There is even a bug on the 8124 announcement first post…

What version of the cleanup tool were you using?

Could anybody who is using a VPN please test CIS to see which VPN protocols and adapters it filters? It now seems to also filter TUN adapter and Wireguard.

I am using Proton VPN and was using the Open VPN TCP protocol using TAP adapter coz CIS would only filter TAP adapter and not the TUN adapter.

I was playing a bit with it and found CIS is now able of filtering OpenVPN protocol on both TAP and TUN adapters as well as Wireguard.

Can anybody confirm? Or is my testing flawed?

Edit. I went back to 8104 and expected to see CIS only filter network traffic with OpenVPN and TAP adapter but my findings are the same as in the above. Scratches head.

2 Likes

Why doesn’t C.O.M.O.D.O_RT provide an answer to your VPN question?
He could take it to the team and keep you posted.

He didn’t post anything for more then a month now. Did he give up?

Hi Citizen_K, :vulcan_salute:

I use NordVPN.

Do you have a PowerShell command to test and verify this or any specific software?

One in particular here? (for example) : Vulnerability scanners – SecTools Top Network Security Tools

" We are delighted to share the final BETA version of Comodo Internet Security 2024. Please feel free to download and start testing the new version (12.3.2.8124) from here . You may also upgrade the existing version to the new Beta version via the “Update” option. "

Unfortunately I have tried for the past two days and the program does not update it states the program is Up to date. Has the release been posted onto the Update Server as wish to see if the update works as it should ?

Hi Dolphin66,

All the new features that have been announced, (to the top of this page), are on hold

Patience…