Comodo IceDragon does not appear in CPM...


Comodo IceDragon does not appear in my installed programs in CPM. It does not appear in the install/uninstall field on Win7 either. Does anyone know how come?

And seen that I prefer to use Comodo Dragon how can I remove IceDragon then?

Hi galeguinho,
Did you install IceDragon as a portable version?
Check in Help, About IceDragon (Screenshot).
If yes, just find the installation folder location and delete the folder.

[attachment deleted by admin]

Hi captainsticks,

No, the version I installed is not a portable one. On the “About IceDragon” screen, it only shows “”. No “portable version” phrase in brackets follows the version number…

So, shall I still uninstall it the way you wrote above?

Besides, the screen does not show me “IceDragon is up to date (” but “check for updates” and then “checking for updates” but no change appears then. I guess, it is a bug which has to do with updates… By the way, I had a smiliar problem with updates with Dragon. But since the actual version, it seems that this bug has been resolved in Dragon…

Well, I tried to uninstall IceDragon by trying to delete the Program File “IceDragon” under “Comodo” file on Win7. But I was asked if I was the owner and if I had 100% authority for doing that! So, fortunately I succeeded in removing completely IceDragon by using… Comodo System Utilities!!! In fact, in the latter there is a part called “Force the cleaning/removing”. So I used it for completely uninstaling IceDragon. It worked very well…

But does it make sense to have to open and use CSU because CPM does not find the requested program (eg. IceDragon) and is not able to remove it?! The answer is NO! Therefore, on a former topic, I asked if Comodo Products developers could not include CPM in CSU simply because CSU has more functions! Or at least try to invert this “forcing” task by transfering it from CSU to CPM!.. It would be much more logical and efficient, wouldn’t it?.. :wink:

Unfortunately, IceDragon doesn’t seem to be very ‘standard user’ (non-administrative account) friendly. I’m sure if you use an administrative account when dealing with ID, things will work as expected.

[attachment deleted by admin]

No this will only remove the folder and will leave registry settings etc behind for the installed version.

You could try running the downloaded installer file and select uninstall (Screenshot).
You also will have a repair option.
Comodo IceDragon

[attachment deleted by admin]

@ Captainsticks :

You are right : I went to the exe file and clicked on “repair”. Then IceDragon reappeared in CPM. In the latter I uninstalled it. And IceDragon seems to be completely gone. Thanks!

Good to hear all appears to be OK. :slight_smile:
Edit: This appeared to be a CID issue more so than a CPM issue, so I have moved this to Help – CID.