Comodo IceDragon 20 is unusable on Windows 8 Pro x64

I just upgraded to Comodo IceDragon 20 on my Windows 8 Pro 64-bit machine, and IceDragon is now basically unusable. When I choose Options the entire browser freezes, produces no output, and refuses to accept any mouse input (even Window resize or etc). I think what may be happening is that the Options window is displayed but hidden and unfocused, because it tried to ask to become default browser a few times (I think), and after I kept killing it and restarting it, I eventually found the window. But then again, I’m not sure because I’ve also gotten the tab recovery screen. Anyways, I’ve uninstalled and reinstalled 3 times, 2 of which I completely removed the profile.

I have this problem too.

I have the same problem. Even when i am using Windows XP SP3 full updated.
When i noticed well the browser hangs on the add-ons.
I even uninstalled Icedragon and installed fresh and clean.
So, i uninstalled it again now.

Please try to disable the hardware acceleration from “about:config” internal page.
The preference name is “layers.acceleration.disabled”. Change the value from ‘false’ to ‘true’.
Thank you.

Thanks for the fast answer.
For me this change of setting works and i can open the settings now.
And there are no freezes so far.

Same problem to me, too. It’s solved deactivating hardware acceleration. Looks like something is going on with it on Windows 8 x64.

Thank you so much! That did it. I had to go to work right after I posted, so I tried Comodo IceDragon 20 on my XP SP3 machine at the office, and it never had any problems (probably because I’m using an ancient graphics card there). Then I’ve been out all day, and got home and tried it, and it works great. THANKS!