Comodo Hogging My P.C at startup!

OK so the last couple of days, i’ve noticed the computer crunching a lot, a real lot when I first log in. It does this for about a minute, then does slower crunching for the next 3-5 mins.

So I thought what could be causing this, and set about disabling all my programs at startup one by one. However the last program to be disabled solved the problem, funnily enough it was cmdagent.exe!! (Note: Disabling cfp from msconfig did not solve the problem, I had to manually disable cmdagent.exe from services.msc)

Can anybody help me and tell me why it is causing my P.C to crunch so much at startup, I have no other programs starting up! Task Manager does not show cmdagent.exe as using a lot of CPU or Mem Usage during the problem, but it is doing so as disabling it solves the problem which contradicts this data.

Specs: 512MB RAM, Win XP Home SP 3, Packard Bell.

I didn’t notice this problem before, but it gives me a headache when the P.C crunches so much, so until I find a workaround, no Comodo :frowning:

Also note I tried disbaling Anti Virus but it stiill hapens, and by crunching I mean a crunching noise, with the red light on my tower showing it’s working. This light would contantly be on during the the problem where Comodo is doing who knows what.

Hey there JJ2K,

Yes this can be caused by cmdagent, some people also have a problem that some of their tray icon’s do not show up. This is caused by cmdagent doing a sort of “caching scan” after the AV Database has been updated.

I have noticed that almost after every DB update the next “restart” is degraded in performance, cmdagent is “rebuilding” the cache and therefore slowing down the system. If you wait till it’s finished and restart again then it should be much faster.

Can you check to see if the second reboot is faster (after you let cmdagent finish it’s background scan) ?

Thanks for the reply Ronny,

It was happening after every boot, and a re-install seems to have solved the problem for now.

The only things I really did was tweak my services and install Adobe CS4 which I can’t really see causing this problem.

What does Comodo actually do when the computer first boots up, it auto updates the virus database, anything else?

Well technically it’s not updating the database at startup, it check’s that a little later.

CIS will only do a sort of “pre scan” to cache stuff after a AV database update on next reboot.
So if it has redone it’s cache and you would have no AV updates for 3 day’s it won’t rescan on reboot(s).
If the AV database is updated after that it will flush the previous “cache” and will start rebuilding that at the next reboot.

This event, where cmdagent was hogging resources, was quite ordinary for me too … then I found there were instances where some other things did the same … like for example Spybot … man … that hogs resources when doing a scan. Actually, it’s not so uncommon … even doing a virus scan hogs resources, logically.

Best solution I found that seemed to influence them all, was add more memory. I plugged another gig in so now I have one point five gigs … makes an impressive difference. Doesn’t stop the hogging at all - but really makes the time the hogging lasts, much, much less significant … & yes, I have XP home sp3 too, on old hardware (35mb video card, for example).

I hated how cmdagent was doing this to me … & talked with others (Cnet actually) & they pointed out it’s common … but so are all the other potential hogs … memory is the best bet, they said … or a much faster machine overall. I chose the cheaper option, logically.

With the prices as they are these current days, that would probably help you a lot …not only for this little bug of course … but also for gaming or anything else … logically.


I have the same problems… I really think the devs must figure out a better caching method to catch bad stuff in memory… Maybe when boclean is being integrated in to CIS/CAVS the pre- caching can be left away…

As an update this problem happened again and I had to reinstall yet again to get rid of it.

It’s not normal, basically what happens is I can boot up the P.C and even if I dont log in or if i do the computer will crunch away doing who knows what for a good 2-3 minutes before i can use it. (2-3 minutes is a very long time btw)

On reinstall Comodo does not do this and I can use my pc straight away after about 10 seconds.

If this problem happens yet again i will bring the topic back up so we can iron out the problem once and for all.

I have the same problem and it is basically killing my disk and cpu… disk usage is very high when booting… makes the pc unusable for about 2-3 minutes…

Does this also happen when setting the real-time AV to disabled ?
and are you running stateful or on-access when this happens ?

av is set to stateful and I do not want to disable the av, because I need to be protected by the antivirus… if this does not happen when I disable the av, then the problem lies in the av component, this should be fixed… it makes no sense having an av with real time protection set to disabled,because it is hogging the pc…

I was not saying that you should leave it disabled all the time i was just wondering if the symptom would disappear when the AV was set to disabled, just for testing/troubleshooting purposes. Not for everyday use.

yeah, I understand why you suggested it, still my statement counts: the av component must not hog the pc when it is set to stateful or a level higher or lower… when booting the pc, this has to be fixed. Also I do not scan with the av, because it is making my pc very very slow… very high disk usage and random cpu spikes and slow progress when scanning…

That is all very true but testing only will bring us further and it won’t hurt as you still have D+ to protect you.

Hi all!

I’m having this same problem with an older machine, XP-Pro SP3.

I had no problems when Comodo was first installed, and I added other protection as Spyware Guard, AVG Free, Spyware Blaster, Spybot Search/Destroy, Malware Bytes & Super-Antispyware. Still no problems, computer was only as 3%-5% slower with all that.

Then Comodo refused to recognize or allow AVG to work, so I tried to force it to allow AVG but a message says AVG’s Security Certificate not verified! Won’t allow AVG or let me add it to approved or safe programs. It also blocked every other security/anti-spyware program, but I got it to allow most of them.

Then about 1 month ago I got a Comodo message that an update was available, ‘Do you want to install this update?’ This is apparently for a version update? I have only gotten these version updates 2 or 3 times in the last 6 months or so. This is not just an automatic database update.

Since that major update sometime in May [and only since then] I have had this problem continuously, and often have the computer lock up, or programs failing to respond, or shutdown problems. Never had this problem before that update, whatever it was. This problem seems to be related to some component in or something done by that update.

I just checked the version of that update and see:


I assume the .509 at the end of that indicates May '09 version? That’s about when my computer started screwing up…

Thanks all!

Please try a clean install of 3.9 as not all updates from 3.8 were successful. Sorry to be the bringer of bad news.

It is also recommended not to import an old configuration from 3.8 or earlier as 3.9 brings a new rule storage format that makes the saving of rules after changing faster.

Doesn’t sound like something I want to do! The reason I changed to Comodo in the first place is that other security programs I used started out fine, worked great, then eventually ■■■■■■■ me up on later ‘updates’, like Zone Alarm and CA! Those programs became unuseable and so did my computer. So, here we go again??

I’m not all that computer savvy so that’s a major pain. There’s a whole lot of extra hassles and hours of time setting up Comodo once it’s installed. I was just getting the original to a point where it worked like I wanted it to, once I started to figure it out. Many hours spent getting it dialed in, now it’s all for nothing?

Sorry to say it but it seems to me that somehow, some way, Comodo or any of the others ought to see this stuff coming. That is, design it right in the first place BEFORE OFFERING IT AS AN UPDATE!!!

I’m sure I’m not alone in saying that I assumed I could trust Comodo not to mess up my computer, so I’m not reall happy with this. At the very least I would expect a warning: ‘This is a BETA program and we have no idea if it will work or not, use at your own risk’. So it seems that Comodo Free is the BETA platform and we users do the guinea pig testing, and if it works the updates then go to paid users too? No, not real happy about that at all.

I’m having a very similar problem as the original poster since installing CIS 3.9.95478.509.

Windows XP Home, SP3, 1 Gig ram, HP desktop

Removed previous version of Comodo Internet Security (CIS) 3.8.65951.477 (was not using antivirus, only firewall and Defense Plus). Removal of previous version consisted of Add/Remove Programs uninstall, manually searching/removing files/folders, multiple garbage removal programs, multiple registry cleaners.

Also removed previous antivirus, Avira, hoping to use CIS full package.

Installed fresh CIS 3.9.95478.509 (installed all…antivirus, firewall, Defense Plus). After fresh install, I noticed I couldn’t do much of anything shortly after a restart or cold start. Would clear up shortly afterwards. This behavior had never happened before.

Problem - Restart, or cold start, the computer. Wait until desktop shows up and Windows Task Manager shows all initializations are completed. Once completed, System Idle goes to 97-99, all is well. Wait about 30 to 45 seconds (it varies) and ‘cmdagent’ process goes crazy for about 25 seconds.

Looking with Process Explorer during restarts, I noticed a scheduling string would go nuts at the same time also. This led me to the ‘Task Scheduler’ service.

Disabling the ‘Task Scheduler’ service makes the problem go away.

I played around with various Auto and Disabled combinations of the services ‘Task Scheduler’ and ‘Comodo Internet Security Helper Service’. Results as follows…

a. CIS and Scheduler service to Auto - Have problem.
b. CIS disabled and Scheduler to Auto - no problem after startup.
c. CIS disabled and Scheduler disabled - no problem after startup.
d. CIS to Auto, Scheduler disabled - no problem after startup.

With CIS and Scheduler services back to ‘Automatic’ (creates the problem), I played with various settings inside CIS. Everything that said ‘automatic’, I deselected or disabled. I turned off Defense +, put antivirus slider to ‘disabled’, set firewall to ‘disabled’. Deselected various other settings.

Nothing fixes it so far. The ‘cmdagent’ still goes nuts for a little bit shortly after a restart with CIS and Scheduler services set to ‘Auto’, locking me out for a bit.

I’ll try the uninstall method suggested in another post (talks about hunting down and removing legacy keys from the registry…I can’t find it at the moment…) in a day or two, then re-install and post back the results.

Any ideas on why ‘cmdagent’ and the Windows scheduling service aren’t playing well together?

I haven’t uninstalled/reinstalled yet, but I was playing around and narrowed it down to the antivirus portion of CIS giving me the problem.

I used the ‘Add/Remove’ products portion in the Installation Wizard and selected loading either the antivirus or the firewall by themselves. The firewall installed by itself doesn’t cause a problem. The antivirus installed by itself causes the cmdagent activity problem.

Anyway, just wanted to pass that along.

Ok, I uninstalled CIS 3.9 (Add/Remove Programs, various third-party garbage and registry cleaners, manual searches, and instructions in this forum about removing legacy and other registry entries) and installed CIS 3.10.

The cmdagent burst activity is still there, but only about half as long now. Was about 25 seconds of interruption, now it’s about 12. I still don’t understand why the antivirus portion of CIS and the task scheduler program interact so hard and negatively. One of life’s mysteries, I suppose.

Once the unwanted, one-time, startup burst is finished, CIS works just fine. I like, and trust, Comodo. Overall, it’s still, in my opinion, a top-notch product. I’ll play around with this for a few more days, then will probably uninstall/reinstall CIS without the antivirus and substitute another one.

In all probability, the problem is probably with my machine and not CIS. One indicator is that only a couple of people are reporting the problem, though I see quite a few (over 800) views of this topic.

Anyway, just wanted to update whoever is interested.