comodo have weak self defense

Hi

Im using program so i can boost cpu each app separately.Norton antivirus dont let me boost cos protected against be tampered.I tried boost comodo firewall and succeed.It means warms and another exploits can successfully stop firewall o even crash.
Any suggestions about that

Greetings!

What Defense+ mode are you using (also what version)?
Did you get any alerts from Defense+?

Cheers,
Ragwing

Defense+ mode was disabled ,firewall version is 3016295.
Non alerts from defense

If Defense+ was disabled, the self protection was also disabled. Try with Defense+ enabled and see if you get any alerts. If you don’t get any with Defense+ enabled, then the self protection doesn’t work.

Cheers,
Ragwing

Hi

I too think that comodo firewall has a weak self defense. I had been using comodo 2.4 with regular updates but I had the following experiences:

  1. A patch (claiming to be a ■■■■■ for some software) when run was able to turn off comodo firewall which would not turn on (the turn on option was disabled) even after several attempts at reinstalling (after uninstalling) comodo firewall.

  2. For about a week or so I had been noticing that the Windows Security Center would complain on start up that Comodo Firewall Pro was not working properly. Perhaps some malware was delaying the start up of Comodo firewall… After some time the comodo’s icon would pop up in the system tray and the security center balloon would disappear.

  3. Today itself I installed the latest version of comodo firewall (3.0.16.295) with the default/recommended settings and to my dismay i am finding a message in the System Status section of the SUMMARY page of the application which reads:
    “The Defense+ is not working properly! Please run the diagnostics utility to fix the problem.”
    The diagnostics utility when run reports:
    “The diagnostics utility did not find any problems with your installation.”

I have also tried reinstallation of the application but in vain.

Does all ths imply that COMODO Firewall which is supposed to provide protection to against malware is itself helpless against those malware ? Or, maybe the malware creators are attacking COMODO too much seriously! (:WIN)

You don’t happen to still have it so that I could take a look at it? Or possible remember where you downloaded it from.

Cheers,
Ragwing

I am interested too!

Oh by the way, I just want to add, that if you still have it, please PM me (and aigle) instead of posting the link here, as we don’t allow links to malware :wink:

Cheers,
Ragwing

I installed CFP 2.4 on my virtual XP. Then I installed Tally and ran the patch. It seems like it worked fine, without doing anything with CFP 2.4.

Cheers,
Ragwing

Hi

Thank you so much Ragwing (and aigle) for the promptness shown by you. :■■■■
That’s strange that it did not do any harm on your PC!

I want to add some details which I missed in my earlier post/PM:

  1. I was also using BOClean 4.25 along with the Comodo Firewall 2.4. BOClean did warn me regarding the threat posed by the patch but I chose to ignore it as I needed the software.

  2. DEP is not supported in my PC.

  3. The patch was able to turn off Comodo Firewall permanently. The turn on/off radio buttons were disabled. I was unable to restore the firewall to a working condition even after several attempts at uninstalling, restarting the PC and subsequent reinstalling, restarting PC, etc., etc.

Alarmed at this I started a virus scan using Avast Home Edition (as far as I can recall, it found 7 malware – I do not exactly remember the type of malware reported). After this I scanned the computer using AVG 7.5 (Free) and a mind boggling 163 files were reported to be “corrupted” (I think this was the term used in the results), and the files included scores of Windows system files viz., rundll32.exe, winhlp32.exe, ping.exe, etc.

Realizing that my PC (having local drives: C: and D:) had suffered some irrecoverable attack, my hardware consultant copied the important data to the D: drive, and formatted the C: drive. All the software including Comodo Firewall 2.4 and BOClean 4.25 were installed again, and everything seemed to be working fine for 2-3 months until….

  1. …(until) I installed the Comodo firewall(3.0.16.295) on February 9. It was then that I noticed in the System Status section of the Summary Tab of the application:
    “Defense+ is not working properly! Please run the diagnostics utility to fix the problem.” as pointed out by me in my previous post. The problem remains the same even after running the diagnostics utility or reinstalling the application.

Another thing that I have noticed in the Defense+ page is that “There are no items to show” in the “View Defense+ Events” and “View Active Process List” sections.

How do you help me now!!

Thanks in advance,
Jassubhai

I am using CFP v 3. I installed the software and then the patch. Got few prompts from CFP but nothing happened to CFP.
All OK.

Hi

Thanks again.

It’s very good that nothing happened to your CPF or your PC!

But I am at loss to understand why is Defense+ not working properly in my CFP 3 (I installed CFP 3.0.16.295 and it has been upgraded to 3.0.17.304 now).

Does anyone have an idea how to come out of this situation ?

Regards,
Jassubhai

Hi

I wanted to add that the patch I PMed to you might not be the same that wreaked havoc on my computer (although there is very little possibility of this being the case). I had deleted the copy of the patch that had actually caused the damage then and there only. But when asked for it by you I searched the website from where I had
downloaded the patch, and found a file which seemed to me to be the same one as it was almost of the same size (10.5 KB) as that wicked one ( (:AGY))! I downloaded the file and sent it to you as I didn’t have the courage to play with the file again!

Thanks
Jassubhai

I like comodo and it was seeming to stop things well for me but for some reason now that I upgraded to ver.3.17 I am getting reports from my virus scaner saying it stopped DCOM Exploit attack and I have never had this problem before I am glad that atleast my virus scaner is stopping these things but I wish it was my firewall doing the work