Comodo has killed my net connection

Hey, I’m sure I’ve done something incredibly basic incorrectly, but I installed Comodo, and now nothing can access the internet.

The network connections are fine, everything is working.

If I disable everything within the Comodo software itself it makes no difference, but closing down the application completely (totally terminating the process) restores everything again, so obviously it’s a problem with the firewall itself.

I suspect it was me foolishly blocking Windows’ svchost.exe and services.exe the first time I installed the software. I tried to find a way to unblock them, but couldn’t see anything.

I tried to uninstalled, and reinstall the application, and then told it not to block these processes, but that hasn’t made any difference at all.

Anyway, I’d appreciate some guidance. I skimmed through the topics already made but couldn’t see anything the same as my problem.

Thanks in advance.

Hi Revelation_Space, (:WAV)

Welcome to the forum…

Firstly before the moderators come in to help, can u list the following;

The version of Comodo Firewall Pro Installed

  • Your Internet connection type (dial-up/cable/Direct connection/LAN etc)
  • Operating system and Service Pack Level
  • How you are logging in to the OS (Admin, User)
  • Other Security applications installed (AV, AS, HIPS etc)

Olso can u say if any of the security applications were running when u downloaded CFP.

Many Thanks

Hiya… do you have your Network IP Addresses set up as a Trusted Zone?? Goto Security >>> Tasks and then Add/remove trusted zone and then Define new Trusted Network.

I also found that comodo was blocking my DNS address Outgoing. If this is the case you need to add a rule allowing ICMP OUtgoing to that specific IP Address (usually it’s ICMP where port is unreachable)

Furthermore I found that Comodo was blocking my SSDP ( I had to add an rule for that too.