Comodo has a bug when I unlocked my workstation [NBZ]

This should summarise the issue. May be best to write it after drafting the issue report. A good title makes sure the right mods and the right devs look at the report

The bug/issue

  1. What you did:
    When I unlocked my workstation, my screen flashed the desktop then the screen went blank.

  2. What actually happened or you actually saw:
    The mouse pointer was visible ever 2 seconds and I can move it around to select anything - I just couldn’t see what I was selecting.

  3. What you expected to happen or see:
    Log back into my computer and continue to work unimpeded

  4. How you tried to fix it & what happened:
    After attempting to get my screen back, I decided to reboot using Windows Logo+R, type shutdown -r. I chose not to use any other switches such as a timer.

  5. If its an application compatibility problem have you tried the application fixes here?:
    It is not an application compatibility problem

  6. Details & exact version of any application (execpt CIS) involved with download link:
    Comodo System Cleaner v 3.0.172695.53 and Comodo Time Machine v 2.8.155286.178

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Windows 7 locked workstation with System Cleaner Auto-clean feature on

  8. Any other information (eg your guess regarding the cause, with reasons):
    The Auto-clean feature needs to be done on system exit rather than during the current windows session.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: None
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
    I wasn’t able to get a copy of the current logs at the time. There is the dump file which I sent to cfpbugs at
  3. A CIS config report or file.
    I sent it to cfpbugs
  4. Crash or freeze dump file:
    None. It didn’t crash the system. However, I was able to run a DIAGNOSTIC on CIS and
    it recovered fine.

Your set-up

  1. CIS version, AV database version & configuration used:
    version 5.3.181415.1237; AV 7929
  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
    I don’t think this is necessary since the diagnostic check fixed CIS. I haven’t had the issue
    again because I turned off the Auto-clean feature of System Cleaner
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have you tried a standard config (without losing settings - if not please do)?:
    Again, I think it was related to the system being unlocked during a System Clean session. CIS
    was also trying to check files at the same time. A perfect storm.
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
  5. Defense+, Sandbox, Firewall & AV security levels: D+= CLEAN PC MODE, Sandbox=ENABLE , Firewall =SAFE MODE , AV = STATEFUL
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7, No Service Pack, 64-bits, UAC Admin Approval Mode.
  7. Other security and utility software installed:
  8. Virtual machine used (Please do NOT use Virtual box):

If you need anything further please let me know.

I’ve never had CIS send the bug report successfully. I always have to end up sending it manually. The address is:


The file, if produced, is and it’s located in the CisDumps folder inside the Comodo directory C:\Documents and Settings\All Users%AppData% (WinXP). Do a search to find CisDumps on your system.

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Absolutely. I should have done that in the first place. I’ll put something together later. See my PM for more information.

We really would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format. You can copy and paste the format from this topic.

Thank you


Okay. I’ve updated my post.

I have to tell you that I feel like Peter in “Office Space” where eight bosses told him that he missed the TPS report cover. Even his friends complained!.

I only got two moderators. However, just like “One Knee equals two feet” in football, two moderators are equal to eight bosses complaining about TPS reports.


Thank you for your bug report in the required format.

Moved to verified.

Thank you