comodo fw v3 has never worked for me and i really need a firewall

alright heres the deal, ever since ive moved to a x64 machine, and have tried comodo firewall x64 i cannot get it to run properly, the farthest ive ever gotten is the installation part, when that finishes, my wifi trys to connect and my computer crashes, how do i fix this so my wifi can connect properly without crashing?

thanks

To troubleshoot this properly, a bunch more detail would be nice, but first, did you have the WiFi turned on and running when you installed CFP? CFP detects networks and sets up WiFi connections so that they work, but it has to be there to be detected. (I’m running an AMD x64 with WinXP and a wireless LAN router and it was properly set up by the CFP install). Another possible source of trouble is other software being used, especially anti-malware software. These programs can interfere with the installation.

yes i did have my wifi hooked up while installing, also all background programs were closed so idk wut the problem is, im running on a AMD x64 with Windows XP aswell, i just dont get why this isnt working for me but everyone else her sets it up fine? ive set up many other firewalls but didn’t like them so i took them out, but they all installed fine, so what am, i missing here?

thanks

There are a couple of known problems that could be responsible. One is systems that have an eSATA drive. It is a bit difficult to guess about your system since there are so many possible variations.

here let me give you my specs

OS: Windows XP x64
Mobo: Asus M2N32-SLI Deluxe
Video Card: Nvidia Geforce 7800 GT
Processor: AMD Athlon X2 6000 3.0 mhz
Ram: CORSAIR XMS2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel
HDD: 320gb western digital sata 7200rpm, 500gb sata western digital 7200 rpm

idk if this will help or be needed but my wifi reciever is a realtek rtl8187, and when i conenct with this my system reboots every time once cpf 3 is installed