Comodo FW not starting Automatically due to cfpres.dll error (v3.0.14.276)

CPF Version:
Firewall Security Level: Train with Safe Mode
Defense+ Security Level: Train with Safe Mode

OS: Windows XP Pro with SP2 (Updated to the latest Patches)

System memory: 3 GB


CPF is not starting automatically anymore as Windows Start, instead it is displaying error messages as follows. As “OK” is pressed in the First Error Message Window, the Second Error Message window appears. As the OK is pressed in the second Error Message Window, Comodo displays a Message that "You have Found A bug and opens up another window to send that Bug Report automatically.

I have start CPF manually from Start> All Programs> Comodo.

NOTE: Even though CPF is not starting automatically and displaying error messages as above, Windows Security Center is not informing that there is no Firewall running. The windows Firewall has been disabled from the very beginning as I installed CPF.

Background of the Problem:

Due to some problem (I am not sure why, but not related to CPF) I received an Error Message that Windows Explorer has encountered a problem and needs to close. Hitting the "OK’ button froze the running application Firefox Browser) including the desktop. After waiting considerable time, I launched Task Manager using CTRL+ALT+DEL and killed the application DrWatson and the application and the Desktop were back to life (I learned this from experience) . But as I restarted the PC after sometime, CPF started to give this trouble. Please note that similar situation arose while I was using the version 2 of CPF, but CPF never created anyproblem liek this.

Steps I have taken:

I have sent the bug report twice. Tis problem started with version 3. I never had this problem with the previous series 2 version. I have tested the beta release of the present version, and this problem was not faced. But the stable version before the last beta, had this problem.

I have also ran Diagnostic Utility available in the Miscellaneous section. But that did not point out to any discrepancies about my present installation.

I can uninstall and then reinstall CPF as that will fix it. But it can occur again as it has occurred once. I have seen that with the last but latest stable version. Furthermore, I have to reconfigure the FW again for all the applications again. (:SAD)

Is there any permanent solution?

Please help.

Thank you.

Sorry, forgot to mention-

Other Real Time Security Programs running during Installation and Operation

  • NOD32 AV
  • WinPatrol
  • Spybot Search&Destroy Teatimer

:-\ seems you have some major probs going on, if it was just CFP or another program not automatically loading its icons in the systemtray then i would say try StartRight ← a program to correct that and many other probs related to that.

but Windows explorer is crashing for you and giving you error messages and other stuff too? :-\ so I have a suggestion, maybe one or more of your windows original system files has been overwritten by a program with its own one that causes problems. so if you have your original Windows CD, then you can try this and see if it helps sort your system out.

sfc /scannow have found a website to explain what that does

best way to do that though is open up a command prompt box in windows and from C:\ type it there, so should look like this C:\sfc / scannow it will overwrite all windows system files with the original MS ones from the windows CD. see if that sorts out explorer and anything else related to windows then if you only have a few probs left like the CFP one not starting automatically and throwing up an error box then you could post back for advice and see what to do next

Hi src2206

CFP will probably not install properly with S&D Teatimer running. You will have to uninstall CFP ( I usually do it in safe mode) and then disable all of your security apps before installing CFP. When programs like your AV and Teatimer are running they are deep in the guts of your OS and when CFP tries to install they scream and holler and put up all kinds of barriers to the installation, consequently you get the error messages. Teatimer and Defense+ do not work well together either because they both try to stop the execution of new processes so they try to stop each other. To use Defense+ you will have to disable Teatimer.

Hope this helps as well


Thanks for your replies,

Hello John

I believe I should have clarified a little bit more:

While installing CPF, I had disabled both my AV and TeaTimer.

CPF was working fine without any problem, and even now after I manually start it, it works flawlessly. But it can not start with windows and gives the error as posted in the above screen shots.

So is there any way to solve it?

I hope these clarifications will help you to pinpoint the problem.

Hello Ron_75

Thanks for your concern. Basically this problem generally does not happen, I think I had taxed the system too much and hence the DrWatson started debugging. Honestly I can not find any use of DrWatson for myself and I wish I could disable it (Its a home PC). And I have found whenever DrWatson starts this type of problem starts. I only wish Linux had the same level of ease of operation as Windows, then I would have given up this confounded OS for good. >:(

Thanks again…and eagerly waiting. :?:

Hi src2206,

I just read your post and from what your saying, CFP doesn’t start up automatically with windows, basically the icon for it doesn’t get loaded and you get an error box saying there is a problem?

I think you should try StartRight (only vista is not supported by it), best to goto this post for the link to it, so you can read about a bit of a nuisance so atleast you are aware of and never have to figure out and worry about :wink:

The reason I suggest trying out StartRight, is because one of the programs I had was Sandboxie and its icon wouldn’t load automatically and i would get an error box, but i could start it up manually sometimes. StartRight fixed all that for me, if i read right its a startup problem your having with windows, maybe because you’ve got a dozen programs starting up by now and also maybe because a service you have automatically loading. well StartRight can take over the starting up of programs for you and it will fix all that.

give it a go and see what happens. the program doesn’t get installed. you just download it and move it to the permanent folder you want it to be in. and click on the program to run it, from then on it will take control over all your startup programs without delaying any of them instead it will make them load up faster without windows trying and tripping over itself lol.

see if that works for you, if it does good :slight_smile:

Hello Ron_75

Thank you for taking time to help me out. :slight_smile:

Let me say it again that CPF is not starting at all; so obviously the tray icon is not loading up, and please note that Diagnostic did not point out any problem.

Apart from CPF I have other security programs running during the boot. From the link that you have provided, it appears that the software takes over the whole Start Up management. Now if I ever decided to uninstall it, my experience tells me that there may be problems afterwards. Furthermore, because of its very nature, the boot time should increase and it will tax the resources to some extent.

Though I am not averse to using any third party tool solve it, but I would like to get it resolved without using any third party application. If there is no solution available from Comodo team, I would surely try the software you have kindly pointed out.

Thank you again.

Hi src2206,

have a look in control panel/Adminstrative tools/Services the service “COMODO Firewall Pro Helper Service” should be set to automatic, have a look to make sure it is. also the service “Terminal Services” if you have that one if its on automatic then set it to manual, reason i’ve read a couple of posts that it causes some kind of delay with CFP starting up.

also if you have these two services “SSDP Discovery Service” and “Universal Plug and Play Device Host” I have read that them two causes many ppl problems with programs that automatically start up during Windows loading, them last two its suppose to be a bug within windows that Microsoft knows about but haven’t fixed, most people say to disable them last two services, in my case I haven’t because I use them. only thing i found that worked for me and sorted out various programs loading during winxp without any problem was StartRight, without me having to turn off any services that i use and want.

(StartRight won’t increase the boot time, I found in my case its actually sped it up a bit since it doesn’t force all programs to load in one go so it taxes my system lesser than before I had it.
It loads each program one by one without any delays, one could give it delays between each program but I haven’t found any need to do that.)

best thing is to check them services in the services window also another thing but I doubt you need to check, is you could check in CFP Firewall/Miscellaneous/Settings that “Automatically start the application with windows” is ticked.

apart from all that, I do not know what else to suggest, it would seem in all likely hood that one or more program is having a conflict during loading up with CFP during when windows boots up and with windows, windows tries to load everything up in one go which exacerbates the problem



P.S if you have any minidump files in C:\windows\minidumps folder zip them and upload them to this post of yours and I will have a look at them and see if they say if any program or part of a program is causing the startup problem. it was how ages ago i was able to figure out that one of my startup programs that i would have never have guessed was causing my system so much problems when I installed CFP during startup from intermittent crashes, to freezes to you name it.

so any minidump files you have would be useful to look at and seeing if some program is causing problems during startup after you installed CFP 3

Hello Ron

Thank you so very much for your assistance. Please give some time to check out every thing as you pointed out (as I am presently out of station and the PC in question is at my home). I shall also try locate any minidump file if available.

BTW, is these files (minidumps) created automatically whenever any Windows problem occurs or I need to change some settings or enable some options?

Sincere regards…

no problem :slight_smile:

I don’t know in what circumstances minidump files are created, was an admin on this forum who made me aware that when a BSOD happens then a minidump file is created that lists what happened and caused the crash to happen. but all the same its worth checking in C:\windows\minidump folder to see if any such files have been created during CFP installed on your computer.

I would have been able to look at the minidump files myself by uploading them to this site i came across when i was interested in what my minidump files said when my PC was crashing that site converts it into readable english and says what caused a crash. I’ve just realised that this site no longer loads :-\ when someone made a post about it and asked if it loads anymore for me because it isn’t loading for them and timesout. might be down, I hope it is just down and not permanently :-\ because I cannot find any other site that reads minidump files

if you have any minidump files then an admin would have to look at them since they would use a debugging tool, probably Microsoft’s debugging tool. something I don’t know how to use and never have :-\

Today I was running into similar troubles.

I was playing with my system, installed a SW named Secunia PSI, which alerts about critical updates of the SW products I have on my PC. Based on the scan-results I made some updates (e.g. installing new Java-Version, running Norton Remover Tool to kick out unused entries of a previous Norton installation, etc).

After a re-boot CFP did not load because of problems with firewall.ico and cfpres.dll.

I re-installed CFP, but without result. I also found, that the learning function of defense+ was not working proberly.

Next I disabled the autostart of Secunia and CFP autostart was working again.

Finaly I re-installed Secunia, enabled autostart and - (what a miracle) both CFP and Secunia are working as designed.

I really don’t know the exact reason for this incident but for sure, something was broken within the autostart procedure. But I could repair it by dis- and enableing the autostart of the affected programs.

Thanks thersandros for sharing your experience. But my problem is related to “ini” file rather than “ico” file as your case.

Still I would surely try out your process and post a feedback here.


I’d try disabling Tea Timer…

I have allowed CPF to be started as Windows Start in Teatimer with “Remember my Answer” option selected.
So I do not think TeaTime is causing the problem. Moreover its over two years that I have been using Teatimer with CPF and never I faced any problem.

Ok, I tried thersandros’ process, but it is not solving the problem permanently. It is starting few times without a hitch, then again the problem is resurfacing. :frowning:

BTW, even the CPF is not starting (that is no icon in the System Tray), cmdagent is active and hence Windows Security Center is not raising any issue related to “No Firewall Available”.

Maybe this will help:;msg117625#msg117625

Thanks…but it did not help. :frowning:
The first error changed and it was now due to a gif file…

Well I devised a workaround. I export the settings of the firewall just before uninstalling and then do a re installation and import back the old settings.

Have you tried adding cfp.exe to your startup group, since it mainly the GUI and cmdagent starts OK?

I checked out msconfig…cfp.exe was listed in the list and it was checked, thus enabled :slight_smile: