Comodo Freezes Windows XP SP3 during startup

Just installed Comodo CIS onto a machine running Windows XP SP3. Installs just fine, but when I reboot, during the next startup, the screen will go black and the machine will lock up.

I have tried disabling the Comodo Helper service, and disabling the actual startup command in the registry, but it still locks up on startup with a black screen.

Windows allows me to login, but the lockup happens during the loading of the startup applications, as tray icons start appearing, and the Comodo shield does not appear before the lockup.

Booting into Safe Mode is OK. I tried opening Comodo, which worked. I set Defense, AntiVirus, and Firewall ALL to disabled. This did not fix the problem either on the next normal reboot.

The only thing that fixes this problem is to uninstall Comodo in Safe Mode.

Anyone know how I can get Comodo running normally? Any help is appreciated because I really like Comodo on my other machines.


Evening “gburghockey”

My name is Jacob Kilgore,
I’m one of the Moderators here at Comodo Forums
I would like to try to solve your Issue as Quick as Possible

First, Have you tried uninstalling CIS & Restarting Then Running A Registry Scan With CSC? Then Installing CIS?

Second, Do you have any other security software or any other “Programs” that may interfere with CIS?

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator

Thanks for the quick reply. I uninstalled and tried Comodo CSC as you suggested, run the “Power Clean” and wiped out everything that it found. Re-installed CIS and still the same problem.

I kept tinkering and here is some more clues :

  1. Disabled ALL automatic startup programs in registry and startup folder, so there should be little or no interference from other programs…still the same problem when trying to boot normally.

  2. Same as above PLUS I disabled CIS from starting automatically, AND disabled CIS service…still locks up with blank screen.

  3. Still boots OK to Safe Mode

  4. Also, boots OK to “Safe Mode with Networking”, and CIS auto starts and runs OK.

Any more ideas would be appreciated.


Bump… this happened here too… ( I only tried version 3.5.57… trying the lastest now) Athlon64 processor, if processer brand might be any clue (remembering that darn stop error on sp3 that only happened on some amds)

Please make sure that in the Defense+ Settings “Block all unknown requests if application is closed” is UNCHECKED. Also please put Defense+ in Training Mode for the first couple of boot ups. This should resolve any starup issues you have.


I think what happened in my case was a fight between Avast!'s uninstall and Comodo’s install… I waited on rebooting after avast’s uninstall until I had installed Comodo. After reinstalling avast (with comodo still installed) I was able to boot sucessfully, and then reuninstall Avast

Is the problem solve or still conflict with SP3 service pack?
anyone who have “No problem” & work fine now

There’s no conflict with SP3 and as far as we are aware, the problem was Avast and Conflicting install/uninstall.


I’m using the latest version of Comodo and running Windows XP SP3 and I have never encountered such a problem.

Someone outlined that the problem may be due to conflicts with another security program and I think perhaps that’s the reason?

When I had installed Comodo on my machine it was after a reformat and I installed all my programs and drivers and then the last thing I installed was Comodo minus its antivirus since I use another program for that.

After a clean uninstall of comodo, and uninstall of Avast+Zonealarm (rebooting after each) … I verified it boots without any security products. Yet, when I attempted to reinstall Comodo, it still froze at the exact same point ( the bars scrolled across the screen forever )

Anyone who can confirm the comodo work out with SP3.

Thx for all reply…support Comodo - Lifetime ;D ;D

Comodo has worked with SP3 ever since SP3 was released. There are no known conflicts or issues. It also works fully with Vista SP1. It’s not yet compatible with Windows 7 but they’re working on it.


No conflicts with XP SP3 as far as I can tell.

Even though it is not being developed for Win 7 yet it already works on Win 7. Run the installer in Vista compatibility mode and put cfpupdat.exe Vista compatible and be good to go.

I’m having the same problem described in this post.

I’m using:

  • Windows XP SP3 with latest hotfixes
  • Pentium 4. 3.06GHz. No HT
  • ATI mobility Radeon 9600
  • 1GB RAM

I have used CIS 3.8 on this notebook before with no problems. A fresh install of XP was performed, installing current drivers and only essential work related software. So far things that changed since all worked ok are:

  • installation of latest XP patches (post SP3 + NET framework 3)
  • mobility radeon drivers 9.3 (I used 5.12 on this old machine)
  • Daemon Tools 4.30 Lite
  • ESET NOD Antivirus 4.0.424

When all used to work, CIS was updated from a previous version to the latest 3.8 instead of doing a fresh install.

To resolve the issue I tried:

  • CIS installation choosing only the firewall component and with Defense! inactive (firewall only)

  • disabling ESET Antivirus real time protection

  • unsintalling ESET Antivirus

  • removing Daemon Tools and SPTD component

    Any clues on this issue would be appreciated.

Whenever I go to install Comodo(click on the program in my received files) it freezes my system for a couple seconds. I never really understood why it does this.
The computer I am using at the moment has SP3 on it. I am wondering if maybe SP3 might have a couple issues with it if your system has low RAM. This computer only has about 320MB RAM.

Since a lot of people are responding here. I am going to suggest some things in general.

When CIS freezes upon boot. Do the logs of Windows register this; it may say it is waiting for some service or event? If so what does it tell. The logs can be found under Control Panel → Administrative Tools → Event Viewer.

For people who want to try a clean install in the process there is a useful script that can be run after uninstalling CIS/CFP and rebooting. Get it here: Comodo Forum ,

Sorry for the late reply.

These are the last entries of the system event log, prior to the freeze.

1.The Application Layer Gateway Service service was successfully sent a start control.
2.The Application Layer Gateway Service service entered the running state.
3.The Computer Browser service entered the stopped state.
4.The Terminal Services service was successfully sent a start control.
5.The Terminal Services service entered the running state.

Tried a clean install using CIS 3.9 AND disabling terminal services and the same happens with the following log (again only the last entries):

1.The Computer Browser service entered the stopped state
2.The Application Layer Gateway Service service was successfully sent a start control.
3.The Application Layer Gateway Service service entered the running state.

On this computer I have autologin enabled, but so is in the other that functions perfectly. I can see the small login window disappear upon boot and then only a black screen with mouse cursor active. The computer stays that way for minutes and after a long time a spontaneous reboot usually happens (not sure if always).

I will try to see if I’ve still got CIS 3.5 to rule out other issues. The machine used to work with that version from clean install. Any ideas on how to resolve this are welcome.

I’m seeing something similar too.
WinXP SP3 running on virtualbox no extra software installed besides the virtualbox additions.
It’s a clean XP install meant to test suspicious software and installs of anti-virus and firewalls as is this case. I was using the previous version of cis on my desktop (xp sp3) until it stopped updating itself and decided to test this new one on a virtual machine before committing any change to the real machine.

Install goes well (firewall + anti-virus) but the machine hangs during boot, just as the boot animation starts.

I have tried to uninstall the virtualbox additions and rebooting before installing CIS but the result is the same.

Resetting the machine and selecting “Last Good Known Configuration” allows the machine to boot, CIS loads but doesn’t say all systems are up and running.

Running the diagnosis reports that there is a problem and that the machine needs to reboot to complete the fix, which leads to another hang as soon as the boot animation starts. There is no error or warning on the logs relating to this problem.