Comodo freezes on startup after installation of Microsoft update KB3001554

Yesterday Microsoft has released a security update with id KB3001554 for Windows 7. I installed this update yesterday and it didn’t require a system reboot so I kept on using my PC.

This morning I had to do a reboot of my system because of a crashed application and after Windows booted all my normal programs seemed to startup except that none of the internet enabled apps could connect to the internet. After checking my taskbar apps I noticed that Comodo Internet Security hadn’t started (or at least its icon wasn’t present). I then tried to start it via the desktop icon and this caused my windows to partially freeze (explorer became unresponsive) I wasn’t even able to start task manager to try and kill the explorer process (not via the taskbar or via the Ctrl-Alt-Delete method).

I did another reset of my system and tried to boot up again only to run into the same problem.

After this I rebooted into safe mode and deinstalled the KB3001554 update. After booting back into normal mode my system responded as it should and CIS was started.

So there seems to be some sort of issue between CIS and this patch.

This seems a bit strange because Microsoft states that this patch is for “September 2014 update for DVD playback in Windows 7 SP1”.

Has anybody else experienced similar problems after installing this MS patch?

I’m using Windows 7 x64 FYI.

the same here.

win 7 x64 sp1 pro updated (pt-br) + cis 7 (latest with db updated).

after removing the update (in security mode) cis is working again.

did another test, installed the update, rebooted the machine and all working here. the problem is not related to the update. maybe something on your setup?

I haven’t tried a second install attempt (haven’t had time yet). For now I’ve put the update on the ignore list.

I did find other people who had problems with their system after this update was installed and who’s problems went away after deinstalling it again:
Windows 7 SP1: DVD-Playback-Update (KB3001554) | Borns IT- und Windows-Blog (last entry in comments, is in German though)

So it seems that I’m not the only one experiencing problems with this patch.

thats strange…

I am typing from a freshly installed Win 7 SP1 x64 with CIS 8 beta and did not run into this problem. I installed CIS after all the updates were done.

Something is apparently up with that update. It would be worth reporting it to Microsoft.

I’m glad that you reported this. I am seeing svchost sending packets to UDP 1900 that I don’t remember ever seeing before. At first, I thought that I just never noticed it, but in light of your report, I now think that this is new. It looks like it happens when Microsoft is scanning for needed updates. I think your problem will occur again the next time you get updates. I didn’t have a problem (maybe tomorrow morning I will). Unfortunately, I can’t say if your problem is because you are allowing or blocking the port. My firewall security is a little messy at this time. I have a firewall rule to allow it, but my IP address blocking program is blocking it.
To be more specific, the svchost task is SSDP Discovery.

You’re watching regular traffic when SSDP Discovery is enabled. You can disable it under Services (Control Panel → Administrative Tools).