Comodo Firewall / VirtualKiosk hangs up on loading (+DUMP) [M280] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes. Reproducable everytime I click on the Virtual Kiosk icon. The loading screen shows, the circle spins and nothing happens. For hours.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: The first times it worked alright, loaded the Kiosk within 5 seconds. Now it is broken.
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc: I believe last time I ran the Kiosk, I was forced to shut down my computer, after that it was just stuck at the loading screen. Sandboxing programs (without Kiosk) works fine.
    If I force a Windows Shutdown or User Logout, the system is halted because Kiosk is still running. The Kiosk screen appears with an error message (see picture: error.png). After another error message, the Kiosk appears with icons, taskbar but without wallpaper.
    Going to Kiosk Options and switching from classic mode to tablet view makes the Kiosk fully accessible (shows wallpaper) and it works. However, the button “tab back to windows” does nothing, and “Exit Kiosk” results in a blank screen with my desktop wallpaper. I cannot do anything but use CTRL+ALT+Delete to open the system screen, but launching the Windows Taskmanager doesn’t happen, no program is put in front of it. It appears the Kiosk is still running and overlapping almost every Windows screen.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.0.264710.2708 - Firewall Security Active

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Enabled are: D+/HIPS (safe mode) + Enhanced Protection Mode
    BBlocker (Autosandbox: Partially Limited) + Detect: Installers,Heuristic command-line analysis,Shellcode Injection
    Firewall (Safe Mode)
  • Have U made any other changes to the default config? (egs here.):
    Yes. I only enabled D+HIPS (safe mode)
  • Have U updated (without uninstall) from a CIS 5?:
    No update possible, since latest version was downloaded.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Yes. Reinstall didn’t fix this issue.
    [/li]- Have U imported a config from a previous version of CIS:
    No. First time use of Comodo, hence no previous version existed.
    [li]if so, have U tried a standard config - if not please do:
    I have loaded the Firewall profile, issue still persists.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 SP1 64bit, UAC disabled, Administrator account. No V.Machine used.
  • Other security/s’box software a) currently installed b) installed since OS: a= Avira Free Antivirus, Spybot Search&Destroy b= Avira Free Antivirus, Spybot Search&Destroy

Attachment: Dump File (60d active):

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

A.8 Your ‘Watch Actvity’ Process list
A.8 A dump file of the two VirtKiosk.exe processes, taken when they are hung
B.1 Your CIS configuration
B.2 Please clarify if enabled and at what level
B.3 Have U made any other changes to the default config?:
B.4 Have U updated (without uninstall) from a CIS 5?:
B.5 Have U imported a config from a previous version of CIS:
B.6 OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used
B.7b Other security/s’box software b) installed since OS:

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


Have updated the parts. I copied it from a template and thought some default parts have already been answered :stuck_out_tongue:

Hope this helps to track down the issue.

Thanks very much indeed


A couple of things to try:

  • resetting the sandbox (uninstall won’t necessarily do this)
  • this FAQ: here. It’s for version 5, but the principles still apply.

If you can tell me the outcome of these then I’ll know how to log it.

Best wishes


Will give it tracking number when you report back. Meanwhile forwarding to format verified.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Derp. I haven’t noticed that function yet. It fixed the issue immediately.

OK will log that under Kiosk Hangs resolved by reset!

Still a reportable issue, so that’s fine

Best wishes


No other report quite the same so you get your own bug number (280)

Thanks for a good quality report


You’re welcome :slight_smile:

I like to return the status to “unresolved”. The “reset Sandbox” fixed the issue only temporarily,
after a restart the bug behaviour returns to described as above.

I have not marked it resolved for that reason. :slight_smile:

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

The issue does no longer occur, it seems to be fixed.