Comodo Firewall Version BETA Released

We are making following three non-english BETA versions live today:
1)Chinese (Simplified)
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 1.25 MB)
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 10.0 MB)

2)Chinese (Traditional)
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 1.26 MB)
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 10.0 MB)

Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 1.32 MB)
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 10.0 MB)

In addition to that our usual English alone setup is also available:
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year(Size : 9.30 MB)

Issues Fixed:

  1. Chinese Simplified setup was using Chinese Traditional images and text on images was bold so was not readable.
  2. Pre Comodo Firewall service alerts used to be displayed, like one involving svchost.exe, services.exe etc, now it should not display.
  3. Folder locking issue can be tested.

Non-English languages BETA Release Roadmap:

28-Nov-06 : French and Hungarian
30-Nov-06 : Portuguese (Brazilian & Continental)
05-Dec-06 : Spanish (LA)
07-Dec-06 : Spanish (España)
12-Dec-06 : Dutch
14-Dec-06 : Swedish
19-Dec-06 : Turkish

Please uninstall previous BETA version and install afresh to test.

Thank you all translators for contributing to translation work.


[EDITED on 28-Nov-06]
As per roadmap we were supposed to release French and Hungarian version of Comodo Firewall today.
We are postponing it for 30th Nov, 2006 and will release them together with Portuguese (Brazilian and Continental)

Thanks for co-operation

[EDITED on 30-Nov-06]
Please visit following url, we have added French, Hungarian and Portuguese (Brazilian) support as per roadmap.
Portuguese (Continental) will have to wait till 05 Dec, 2006.,4206.0.html

So please add latest comments on above topic.

Installing now!!!

Now installed, I can confirm from early test’s that my folder locking problem which was easily duplicated has now been fixed.

Great work umesh

Comodo Firewall Version BETA
Comodo AVS Beta

on the same date!!!

wow, great!

Oh… a new firewall again? Just to install it. :wink:
Swedish not until 14 dec… nooo… ;D

Lucky me, that I checked forum before clean instal.

Oh, good to hear about the releases :)!

Is this normal (not quite sure, why it isn’t a denied component, only)? Started IE after clean beta install, then fw asked about the dll files. If I deny any of the dll files, it’ll deny the iexplore.exe itself. And (same question applied): local ip is shown as I and my gf connect with a router but we got own internal ip addresses (192.168…). There’s only one zone, the SUMMARY shows the zone with my internal IP address.

Example attached.

[attachment deleted by admin]

Yes. This is a new detection feature with new CPF. Now it will alert you about BHO and LSP dlls. They are also a sort of hook DLLs mapped into every process connecting to the internet. So from now on, CPF will show you the alerts about them too.

What you need to do is to click on Show Libraries button and see if this DLL belongs to a trusted company.

In your case, pnrpnsp.dll is a LSP belonging to Microsoft Corporation and a safe one. so you can remember and approve.


I got those LSP popups too…
CF is getting better and better…;D
One question is, since this is a beta, there is uninstall and new install involved. Do you plan to release a “stable” release with multilingual with “normal” update for users that don’t use beta?

…or a version of CPF beta that will autoupdate like the new CAVS

CF is not going to remain in BETA state for too long as evident from release roadmap.
As we are changing binaries also, so with every new version we have to make sure all languages use the same base binaries. In future if we do not change binaries, we will not suggest you to uninstall and re-install.

To provide updates for BETA is extra efforts for us and as i mentioned it is going to be in beta for a while only, so please bear with us.

Uninstallation and instllation is fast, isn’t it :slight_smile:

I suggest uninstall and do not restart system and install new setup, should not be any issue, just to avoid double re-start.

So please bear with us for that.


Installed both beta’s for CF and CAV…so far everything is playing nice together. :BNC


When I boot up I have a batch file to check if my broadband connection is up. It pings one of my DNS IP addresses. If it is successful it exits, if not it tells me there is no connection in the Command Prompt window.

However, CPF intercepts this (it didn’t in the previous versions) and immediately ping.exe crashes with the following:
The instruction at “0x775212c3” referenced memory at “0x0008b000”. The memory could not be “written”.
If I click on OK (I don’t want to debug) I then get:
The instruction at “0x1001281e” referenced memory at “0x00b0015c”, The memory could not be “read”.

If I allow the connection in CPF, the script finishes. But there is no Set Rule tick box.

Any further ping commands, say in CMD.EXE to any destination (my LAN or internet), CPF asks me to Permit or Deny. It does not allow me to set a rule, there is nothing there in the dialog to tick.

An ideas? I tried setting an Application rule for ping with no parent, TCP/UDP Out to any IP and Any Port but that didn’t make any difference.

Later… what did is if I set the application rule for ping.exe to “Allow all activities for this application” then CPF doesn’t ask. Is that right? Should I have to do that?

My system is Windows 2000 SP4. I uninstalled previous version, installed this beta, reset computer, then disabled cmdagent and cpf, rebooted, deleted Comodo registry entries, merged my backup .reg file, made cmdagent automatic and rebooted again.

Other than this, all seems OK.


Thats the way I have been doing Beta updates since you started them. Never had a problem doing it this way.

But how do you then copy back the backup .reg file settings? Or do you start again from scratch?


To be honest, I just start from scratch. I find beta time a good time to clear out my old rules and start afresh. But obviously I realise this method is not suitable for every one here, especially if you have taken time to create a complex set of rules.

Another problem I’m afraid.

I sometimes use a program called MailMaint to access my POP3 mail boxes. It displays the contents and allows me to do maintenance and sort out problem emails etc.

Any way with this beta I get crashes when I ask it to open a mailbox, first a dialog:
MailMaint - Unhandled Application Error
Fatal Error - POP2 component not Ready

In the status bar:
Error -ERR ESocketException: Error 0 in function Connect

I see in CPF Activity that it is attempting to open a localhost connection: ports 1038-10110 TCP In/Out
I have rules for MailMaint to connect to DNS and the mail server ports 25 and 110 as you would expect.

Now on my laptop where I haven’t installed CPF beta MailMaint works as expected.

On a couple of occasions in my testing when I exited CPF MailMaint worked OK but this isn’t always repeatable.

I’m not sure what’s happening here. I do know that this is definitely a beta problem.
Sorry :frowning:


When you have rebooted your PC, you right click the firewall sys tray icon, and exit.
Open task manager (Ctrl+Alt+Delete) and close the cmdagent.exe
Now you can put back your registry settings (rules).
I now restart. I haven’t tried it yet, but you could maybe just click CPF icon and run cmdagent.exe

Sometimes you need to check “skip loopback … TCP” in security/advanced/misc for some programs, to get them working as expected. If you have a web server, FTP server or something like this. It’s worth trying, even if it doesn’t sound logic sometimes. Users that use a proxy should be a bit careful with this, but otherwise it’s not a major problem.

Yes, thanks. I realised after I’d posted that was the reason I wasn’t asked about the localhost connection as I had that already ticked. I’ll amend my original message to take that into account as it really isn’t relevant to the crashing.

Not happy with this beta, shame as I needed the blocked folders bug fix.


Yes that makes sense. Thanks.
But which leads to the interesting question: How is it I can end the cmdagent process in Task Manager but not stop it in Services? Is this a security risk?

I also noticed that in the Miscellaneous dialog if you untick “Protect own registry keys…” that may allow the registry backup to be merged without exiting CPF?