Comodo Firewall Version BETA Released

[EDITED ON 23-Nov-06]
We have put a new version of BETA ( which has Chinese (Simplified), Chinese (Traditional) and Russian languages support.
Please visit following link:,4068.0.html

In efforts to make Comodo Firewall reach global, with this BETA release we are starting to add support to non-English languages. Today we are releasing only with Chinese (Simplified) version.

On daily basis we will be adding more languages in BETA section, following url specify that we will be releasing BETA in another one week in total 11 languages.,3239.0.html

Once these are done we can look for other lnaguages support also.

Following three setups are live:

B)Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year

C)Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year

Setup ‘A’ means English language alone, as it has been the case. In case user has that installed he can download Chinese (Simplified) addon in the form of setup ‘C’ and thus can have Chinese Simplified language support added. Similarly in future per language there will be ‘Addon’ setup which can be installed on top of English installation.

If user is interested in installing Chinese (Simplified), he can install setup ‘B’ which will install English+Chinese (Simplified) in one shot, so you do not need Addon setup.

So in future per language we will have two setups:
i) CF_Setup_English_.exe
i) CF_Addon_.exe

Features Added in

  1. Mulilanguage capabilities
  2. Defense against buffer overflows( experimental)

Known Issues

  1. On system re-start you may get firewall alerts for applications which started before Comodo Firewall service could be up. We have identified the issues and in next setup it will be fixed.

  2. Firewall Help is still in English, we have got it translated for some languages and we are working on this direction to have Help available in each interface language.

  3. Executable descriptions will always be in English. Now we have executable database of over 18,500 executable files. And it is very difficult to get them translated.

  4. For ‘B’ and ‘C’ type setups, language of installation will be in English. We need to get some translation done for installer also and therefore we can have installer also in the same language.

  5. There is a language icon on top tool bar in Comodo Firewall, it lists down all the installed languages, you can select the language from that but changes will take place when you restart firewall application. We are working on it to make it change on the fly.

  6. While testing for Buffer Overflow, there may be some false positive. Please do inform us if you encounter any.

Looking forward from everyone to give it a try and let us know the feedback.

Thanking all the translators who have put lots of efforts in translation.


For those interested, yes it does require you to uninstall your current version.

My first reaction is not to promising.

I’ve booted many times and it keeps asking me to allow SYSTEM and SVCHOST. Never had this with any previous versions.

I also have applications that now take what seems forever to start executing.

Uninstalled the beta and the apps that were slow to open/execute now run fine. Think I will go back to the stable release and let you guys sort things out in the beta.

And it seems to me that my system under the beta was just not as responsive as it now is with the stable release of CPF.

And yes I know it’s a beta version so you need not give me that argument.

I think there is a mistake, the chinese version isn’t simplified chinese but traditional chinese.

Additional, the chinese character appeared on message windows too small to see clearly.

it consumed a lot of RAM…slowing my pc to almost crawl…the developer should considers that not all usewrs have 1GB of RAMS… (:TNG)

Early days. But, so far… sweet.

I’ve not seen any of the problems described above. No SERVICES/SVCHOST pop-ups as yet & the in-core memory usage also looks fine at a maximum of 28.7MB (currently 24.2MB).

In fact, I have very little to say about as it is very much like on my system. Nice one Egemen. 8)

Pretty mutch the same here, except I do get the SERVICES/SVCHOST pop-ups when rebooting. As I nearly allways hibernate anyway it not a problem. Memory currently at 18.8MB.

I still have the issue with CPF locking directories, (see here,2304.0.html) stoping me renaming or deleting them after I have run a program from there. Maybe a future release. Nothing else to report though at this stage.

Have you tried to use Unlocker as a workaround until they fix it?
It works great for me, and you can find it here
You should be able to rename or delete the folders. Just right click and “unlock”.

I have one gripe. When you move a rule up or down in the network list you have to let it refresh twice (you can see it flicker twice) before you can move it another place in the list or it loses focus and you have to reselect it again. I have over 30 rules (yes I’m trying to break it) and this gets very frustrating and time comsuming when moving rules around.

Before I get flamed, I am doing this on purpose to try and find flaws in the interface workings. Normally I would just create the rule on the line where I want it then leave it alone.

Basically, I am trying to tear it up. Man I love to tear stuff up!!! :BNC


Put an “Apply” button so I can move everything around then apply the changes. If I try to close the interface without saving the changes then prompt me to either save or not.

AOwl, I do use unlocker, but it does not work in these instances, it allways states no lock found. Unlocker only looks for locked files, not folders. However I also use OpenedFilesView which has an option to show locked folders. It shows cmdagent.exe being the process locking the folder. Forcing the process to unlock closes cmdagent.exe to shut down, requiring a reboot to get running again.

1) Mulilanguage capabilities 2) Defense against buffer overflows( experimental)
Is there a detailed changelog? If these two are the only two changes, I see absolutely no sense testing BETA for me, moreover, with no bugs fixed (especially this ANNOYING cmdagent behaviour).

When I right click a folder I get a choice of deleting, renaming, moving and so on…
Yes the folder, and not the files. I don’t have your problem with cmdagent locking the files, but It happens that files/folders get locked sometimes and Unlocker has always solved the problem for me. You say that it can’t solve your problem and i believe you, but you can’t say that it can’t unlock folders in general, because it can…

Sorry AOwl, I stand corrected about unlocker not normally freeing folders. I find the problem manifests its self after running a program that accesses the net. Afterwards I am unable to delete or rename the folder due to cmdagent locking it. The options are displayed in the explorer context menu, but fail with the normal “unable to …access is denied”

It wasn’t directed to you only… It was kind of informative to other users that hadn’t tried it yet.
I’m not surprised that it can’t stop cmdagent since it defends itself against getting stopped by malware.
It’s positive in one way… :wink:
CPF has a problem with “hanging on to” apps (folders?) for a long time, even if you have closed them a while ago, and creates strange pop ups because of that.
It also have a problem that it doesn’t just stop the parent if you deny, it stops the program as well.
Hopefully this will be resolved, and it might resolve your problem as well.

I have trouble downloading programs while using Internet Explorer 7. I had a Windows pop-up that said something about the Data Execution Prevention (DEP) stopped a process from happening. Maybe it thought a virus was attacking the machine. I have the Comodo Firewall buffer overflow detection strength on normal. I haven’t had the time to test my machine just yet.

I noticed a slight delay when I type in stuff on web pages. My windows tray will disappear for a couple of seconds and later reappear. Same goes for the Windows Explorer (Windows Program Manager).

I hope this helps.



Here’s an Log entry that I’ve not seen from CFW before…

Date/Time :2006-11-19 20:35:30 Severity :Low Reporter :Application Monitor Description: Application: D:\Opera\Opera.exe Parent: C:\WINDOWS\explorer.exe Protocol: TCP Out Destination: 193.nnn.nnn.nnn::http(80)

Date/Time :2006-11-19 20:35:28
Severity :Low
Reporter :Application Monitor
Application: D:\Opera\Opera.exe
Parent: C:\WINDOWS\explorer.exe
Protocol: UDP Out
Destination: 193.nnn.nnn.nnn::dns(53)

I was running Opera around that time and I did get pop-ups because CFW hadn’t seen Opera before (scan for known apps still only searches the C partition on my system)… but, a couple of blank pop-ups? I certainly don’t remember that!

Edit: Oops posted in the wrong topic. Sorry. :-[

When I change to chinese language,

I can’t add rule.

What if you disable DEP or add IE to the list?
Start → Run… → sysdm.cpl → Special tab → click on the first button, then last tab

I think I had a problem with Socketshield because it kept doing it after I uninstalled the firewall. The Socketshield icon would disappear from the system tray and I had the DEP warning.

i’m having problems after booting, keep showing the dialog regarding system and svchost, click on allow and remember, but keep showing up after every boot
it shows safe and can’t remember settings

??? (:SAD)

Hi isaac

I installed SocketShield but I couldn’t replicate what you are seeing. As far I can tell, SS doesn’t have a service or use svchost. Can you post an a screen shot of the pop-up you are getting. Remember to mask out any private details. Thanks.