Comodo Firewall v6 isn't updating(error:0x80070005)


I’m having issues of updating Comodo Firewall. It seems there is a new program version and when it asks me if I want to install the downloaded updates, it gives me an error - Access Denied(the attached file).

And in the logs section there is also this: (the 2nd attached file)

Please excuse me if I am posting this in the wrong section, I am new here. Thanks in advance.

[attachment deleted by admin]

Please copy and paste the exact version number you currently have.

Also, does running the diagnostics help?

Yes I just now and it didn’t find any problems. The version is: 6.1.276867.2813

I have also tried to update it while the HIPS was deactivated and it worked, though it didn’t updated the program itself, just some usual update, but when it’s activated I got the problem that you see in those 2 pictures. So I am guessing the issue might be related to the HIPS.

I’ve had the CIS installed before, but I switched to the Firewall only because I wanted to try a combination and I did remove all of the Comodo leftovers before I switched to the Firewall, using the tools that you have provided. But if some leftovers did remain, maybe it’s because of that, I don’t know…

Okay, this is actually the most up-to-date version.

So the situation you are experiencing is that if the HIPS is activated the update check will fail, however, if the HIPS is deactivated the update check will succeed. Is that correct?

This could be due to some issue in the install, but before we worry about that could you please post screenshots of the rules created both for the Firewall and the HIPS? Also, what level do you have the Firewall set to? Did you disable the BB?

Yes, that is correct. While the HIPS is deactivated, the updating process is doing just fine(as a normal update). But when it’s turned on, it says that there’s a new program version and when it downloads the updates it asks me if I should install them, when I give it a go (I remember seeing once that it goes till 80% and it stops) and it gives me an error afterwards.

And no, I haven’t disabled the BB, it has always been enabled and it hadn’t give me any errors in the past.

Anyway, here are the pictures(the attached files). I am not sure if I gave you the exact rules which you’ve required me to do, but when I checked up on the rest, I didn’t see any reason that they could be behind this.

[attachment deleted by admin]

Could you post a scrreenshot of the HIPS rules? You posted a screenshot of the Rulesets of the HIPS instead.

Yeah that’s why I wasn’t sure if you wanted those or the others. By the way when I try to update it and when it gives me the error to install the updates after that(as you can see in the first 2 pictures) it still says that it has been updated. Maybe only the HIPS isn’t getting updated since when it’s disabled, the program updates just fine(though without saying that it has a new program version and it wants to install it, just a regular update) but when it’s enabled => a new program version and the error that it can’t install the downloaded updates.

And as Chiron already said that this is the latest version, I don’t see why it says there’s a new one and it wants to install it.

Anyway, here are the pics(attached files).

[attachment deleted by admin]

Can you check the version number of cmdvirth.exe in the CIS installation folder?

Please run Diagnostics and see what it reports. If it reports a problem let it create a report and attach it to your post.

The version is: 6.1.275152.2801

I’ve tried to reinstall it to see if it’s really due to a failed installation(which turned out to be exactly that) and now everything’s fine. Some remaining files of the Comodo weren’t deleted and that was causing the problem.

By the way, before I reinstalled the Firewall, I couldn’t use the default uninstaller, it was giving me an error(probably because of the remaining files, I don’t know) and I had to use the Revo Uninstaller to remove the files manually + your removal tools and one of them " CIS+Removal+Tool+2013 " has messed up with my Wi-Fi drivers and guess what, after I installed the Firewall(just to check if it was due to a failed installation) and my Wi-Fi drivers got fixed, lol… really weird.

So, even if it had reported a problem, it would have been due to the failed installation by the remaining files that couldn’t be deleted.

Anyway, I’ll do a clean reinstall of my Windows and then move back to CIS by starting fresh. Thank you both for your help though. :slight_smile: