Comodo Firewall v3 & Nintendo WiFi USB connector

Has anyone managed to get Comodo v3 firewall to work with the Nintendo WiFi USB yet ??

I know about the thread at https://forums.comodo.com/empty-t15810.0.html but there seems to be no further update

I can get my Wii & NDS to work using their USB device, but only if I turn the Firewall security to ‘Disabled’

I believe I have set up the required setting on firewall correctly. (I’ve included them below) - but WHY won’t it work if I have the firewall set to ‘Safe mode’.

— What I’ve done ------

  1. Double left click taskbar icon to open

  2. Firewall > Common Tasks > My Port Sets > Add > [Add new port set] > Gave it a name like ‘Nintendo WiFi Ports’

  3. Highlighted the ‘Add ports here’ under the new set > [Add] > ‘Add new port’

  4. Made sure ‘single port’ is selected & added one of the ‘ports’ needed according to Nintendo
    (these are 80,443,28910,29900,29901,29920)

  5. repeated 4) above for EACH port address

  6. clicked on [Apply] to leave the ‘My Ports’ setup

  7. On main page clicked [Advanced] > Network Security Policy & scrolled down to ‘NintendoWFCReg.exe’ entry
    (I had already ‘allowed’ this program when it tried to access internet the first time)
    8 ) Clicked on [Edit]

  8. Made sure ‘Use a Custom Policy’ is selected

  9. Clicked on [Add] then created the rules set out in
    https://forums.comodo.com/frequently_asked_questions_faq_for_comodo_firewall/nintendo_wifi_connection_tutorial_wii_ds-t4429.0.html (which DID work for v2 firewall)

EXCEPT that in step 2a instead of adding the ports seperated by commas,(if I remember right v2 does it this way) I instead selected the ‘A set of ports’ & then selected the port set I created in steps 1) - 6) above

And it STILL doesn’t work. I have even looked under ‘Firewall’ > Common tasks > My Network zones & there’s a network that has ‘Any’ underit - which seems to be for the ‘Nintendo wifi’ (the other network I have is a ‘loopback zone’)

Any idea if I’ve done something wrong ?? or missed something out.
If ANYONE has manged to get Comodo to work - could they add a 'step-by-step- guide on what they did

Do you need to share your connection? See I have a 2Wire Gateway DSL modem and all I did was plug my XBox 360 ethernet wire into a separate port of my modem. I have 4 ethernet connections and up to 4 wireless connections. My pc that runs Comodo is plugged into a completely different port then my 360.

The answer is ‘No, Don’t need to share’ - What I forgot to mention is that I get my Broadband through Virgin Cable TV set-top box, so don’t have anything like a router, wireless or wired (Cable box is plugged straight into PC LAN port) & there’s only 1 PC in the home, and no other wireless laptops etc

However since I posted the thread I believe I may have discovered the reason - although I’m not sure if what I’ve done has left my PC open for hacking.

I cleared out my Firewall Log files & then tried [ONLY] my DS to connect & found that ‘svhost.exe’ was being blocked on:-

Source Address: 192.168.2.1
Destination Address: 192.168.1.1
Source Port: (various)
Destination port: 53

So added a rule to ‘Application security policy’ for svhost.exe of
‘Allow UDP In From 192.168.2.1 to IP 192.168.1.1 Where Source Port is Any and Destination port is 53’
I have moved this to above the already existing rule of
‘Block And Log IP In From Any to IP Any Where Protocol is Any’

Done the same ‘test’ for my Wii & got another set of IP addresses, created another rule for that as well & now both Wii & NDS now connects to the internet with no problem


I have tried out PCFlanks (http://www.pcflank.com/ tests) and Shields up (GRC | ShieldsUP! — Internet Vulnerability Profiling  ) to check my PC for any ‘security holes’. The results of tests are:-

Shields Up:-
File Sharing > ‘Passed’
Common Ports > ‘Passed’
Service Ports > ‘Passed’

PCFlanks:-
Quick Test > Passed on all but ‘Browser Privacy Test’
Stealth test > ‘Passed’
Browser Test > ‘Failed’ on both Cookies & Referrer Tests
Trojan Test > ‘Passed’
Advanced Port Scanner > ‘Passed’ on both ‘TCP Standard’ & ‘TCP SYN’ scans
Exploits Test > ‘Passed’

So even with the new rules in - it seems like I’m still protected from ‘most’ hacking attempts (I’m not too fussed about ‘Browser Cookies & referrers’