comodo firewall v3.0.13.268 x32 CMDAGENT.EXE 100% CPU Load

How did you get to that check/ uncheck box? Please be detailed as i may reinstall v3 and give it a try.


Look at the image. You know what they say … a picture is worth a thousand words ;D

Defense+ → Advanced → Defense+ Settings-> Monitor Settings


that are great news!

could it really be that you saved my weekend.
i’ll try it asap.

ok, seems like you got it moocow! (:CLP)

i enabled d+, disabled the registrykey protection, restart…


system is up and running - and is reliable!

now we just have to find out if its the protection by its self or a key that is monitored under “defense+” → “My Protected Registry Keys” i guess

greetings from germany! :BNC

I’m glad that it worked for you aswell :slight_smile:

Now it’s up to the developers to check what part of the registry key protection that is causing the high CPU load.

WOW great news !!! ;D

lol the version 2 of the firewall updated today to :slight_smile:

i will wait a few more time because the firewall is allways asking me things :stuck_out_tongue:

well i admit is because the strong protection of the firewall…

sorry for my bad english

best regards

Yes, I can confirm that this works. I had a very similar problem here, and after following your instructions, my system no longer hanged but started-up very smoothly (perhaps even faster!) Thank you very much, moocow! I am very grateful that I can still have Comodo installed on my system. Thank you again.

Indeed. I have a feeling that this option was not meant to be disabled. So it would be appreciated if the developers have look at it.

Hi Guys,

It seems the problem is somehow related to modified themes and protected registry key access triggered by this.

I will be trying with the Inspira Pack to see if i can reproduce the behavior.

Can you guys try to find the problematic registry key in “My Protected Keys” section ?

You can test it like this :

  • Enable the registry protection if disabled and then delete the entries in My Protected Keys one by one to see if issue is resolved. When the issue is resolved after deletion, the deleted key must be the problematic one that is being accessed.

This would help us to identify the problem better.

cmdagent.exe is simply a file scanner. Something must be being scanned over and over again…

Thx for the cooperation,

Cephari, great news! :slight_smile:

egemen, Sure, I could test it. However, is there a way to save a backup of the settings?
(Don’t really want to remove all of my protected registry keys and not be able to protect them again…)

By the way, this is not only cause by inspirat, it seems to be triggered by other packs aswell (like the Tango shell patcher).

I’ve just installed comodo firewall 3.0 and i’m facing the same issue: cmdagend.exe uses 100% of CPU.

But some test i’ve noticed that the ONLY option in Defence+ settings that makes this happen is “WINDOWS / WINEVENTS HOOKS” in “activities to monitor”.
Now i have that option unchecked and ALL others checked and i have no problem of cpu load.

What’s the problem with the “windows/winevents hooks” options? What does it mean?
How can i fix it?
Maybe next release will fix it?

Comodo v3.0.13.268 32-bit, WinXP Pro SP2, Nod32 v3.0.563.0

Read through this topic and slept on things and thought and thought.

Attempted this AM a reinstall of V3 and still to no avail.

This time, however I had made/ set a system restore to get back to where I was at a closer time frame in case of a problem and sure enough!-- Still a problem in installation so I will opt to wait out the bug.

Too confusing for me even to try and find the above listed (un-check the protected registry key as i could not figure out what or where that is) adjustment since this install did not even get to that point, as my system merely froze up during installation, that is zero CPU usage of V3 and my system just stayed and seemed frozen. I halted the process, actually clicked ‘end process’ and reboot restoring to my previous working state of computer.

do hope you find the bug and make the fix. please ask for any info as i wish to assist if at all possible.

am a grateful user of Comodo, but this ‘upgrade’ causes me concern.


COMODO doesn’t seem to like “StateChangeDiag.exe” either (whether it is trusted or not).

When I tried to run it, it bumps cmdagent.exe to 100% CPU usage, too. The above fix of disabling the “Protected Registry Keys” worked for the Bricopack tho’.


Looking at this topic, I was thinking that it is a shame to completely remove registry protection. If you know which programs are accessing the registry, you can give that program registry access rights. Click Defense+>Advanced>Computer Security Policies> (locate the entry for the program or click “Add” and find it by browsing)>Edit>(ensure that “Use a Custom Policy” is selected)>Access Rights> click “Allow” for “Protected Registry Keys” and “Protected Files/Folders”. This will work the same as unchecking protection for registry keys entirely, for the programs enabled this way. If there are others that are not working, they will show up in the “View Defense+ Events” page (you may have to click “More” to see the event of interest).

I guess they don’t have any D+ log related to this issue. Maybe it is something that happens before cfp can log events.

Can you guys check if this is the same issue? It seems to me the this uxtheme.dll patching is causing this issue.


:Beerit worked moocow! thanks alot :slight_smile:

problem solved !!!
thank you :■■■■

I do have a patched uxtheme.dll, and I also have “Super Turbo Tango Patcher” (which is a shell patcher that changes all the icons and bitmaps to look like Tango).
The uxtheme.dll didn’t come from any pack. It’s from a stand-alone installer (UXTheme Multi-Patcher 5.5).

Is the problem narrowed down to uxtheme.dll or could it also be due to changing my icons (which sounds very unlikely)?

you can easily revert that patch and tell us

And you can easily ask me nicely.

People sometimes…

Anyway, I’ve reverted the uxtheme.dll to it’s original.
Checked “Protected registry keys” and rebooted again.

The uxtheme is the original now (can’t change themes to anything other than the original XP ones),
however my CPU is at 99% again.

Conclusion: It is not uxtheme.dll that is causing the problem.