Comodo Firewall upsets USB 3 flash drives


Recently i bought a couple of usb flash drives for my needs. While copying to or from them, i encountered several issues, disconnects, drives not recognized.

At first i thought something was wrong with them, but it wasn’t since they worked right in other similar Windows 10 pcs. No issues at all.

So i started to search my Windows 10 pro and my pc. I tried all kind of things, removing usb3 devices, etc etc, nothing solved it.

Then i started to remove programs installed one by one.

And when i removed Comodo firewall, the issue stopped. Everything is working right.

Any ideas? since i really like and use Comodo Firewall only for ages,


It could be something relating to the driver. Check to see if there any unrecognized files in the list and the logs for any related events.

I only use the Firewall and there are no drivers or anything related events or unknown files.

I will have to test more, since the issues are random.

V12.2.2.8012 (Firewall only) Windows 7 Ultimate 64-bit (clean install with all MS-updates)

Just connected my usb3 flash drive for the first time to the system. The one-time installation of the usb3 flash drive drivers went fine.
Then I copied many small files, a 4Gb file and then a 20Gb file to the usb3 flash drive, also no issue, it’s working nicely for me.

Well Windows 7 and Windows 10 are totally different. Totally.

That’s totally true. :slight_smile:
I was just checking if the issue would occur on Windows 7 as well.

Can you be more specific on the issues you observed and what you did to reproduce the issue? Do you use device control to block device classes?