Comodo Firewall stops applications from being executed[V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Always, I just need to enable Firewall and in a few minutes it starts happening!
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: It may start at any time, just after reboot of after hours of use. Rebooting makes it stop for a while, but happens again soon.
    b: Enable Firewall, in Advanced Settings > Firewall > Enable Firewall
    c: For a while it seems to be working fine, then applications start haning to execute. Easiest way to test it is to open a txt file, Notepad won’t show up.
    d: The process that executes the app will also hang. If I open a file from Windows Explorer, WE hangs. If I use Start Menu to execute an app, whole menu hangs until the app is executed. Once the app executes, it comes back working again. None of them (the new process and the process that executes it) crash, they just hang for a few minutes, then both work normnally again.
    e: When the issue starts it takes just a few secs for the app to run, but as time passes it takes more than a minute hanging.
    f: In Task Manager I can see cmdagent.exe taking a whole CPU processing time. I have QuadCore with HT, so it stays in 13% CPU usage.
    g: No software crashed, neither the opening one nor the opener one, and there’s no error message. But as time passes and the issue gets worse, nothing more runs and running apps hangs, I can’t use Explorer.exe and reboot request is ignored or unaccessible. Then I have to reset PC, and as soon as Windows restarts I urge to disable Firewall before it starts again!
    h: When I disable Firewall, everything works fine.
    i: Antivirus and Defense+ work fine with no issue.
    j: It looks like some thread in cmdagent.exe takes an almost-infinite loop, blocking it from doing some verification in apps before they start running, then they enter in a queue that’s processed VERY slowly and goes getting bigger as time passes.
  • If not obvious, what U expected to happen: When I execute an app, I expect it to open immediately, not to stay 10 minutes waiting for it while Windows Explorer or Start Menu stay hanged and unaccessible.
  • If a software compatibility problem have U tried the conflict FAQ?: It happens with any app I try to execute.
  • Any software except CIS/OS involved? If so - name, & exact version: It happens with any app I try to execute.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: It looks like some thread in cmdagent.exe takes an almost-infinite loop, blocking it from doing some verification in apps before they start running, then they enter in a queue that’s processed VERY slowly and goes getting bigger as time passes.
    It’s fixed by disabling Firewall, which may only be possible after reseting PC if I let the issue happen for too long.
    Comodo’s main window works fine, but none of its buttons work to open secondary windows. It takes ages for Advanced Settings window to open, so that I can disable Firewall.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: Comodo Internet Security Premium free, v6.2.285401.2860. Update ran completely.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Defense+ Training Mode
    Antivirus Realtime Scan and Scanning optimizations
    Auto-Sandbox unknown applications as Partially Limited
    When Firewall is enabled, it’s in Training Mode

  • Have U made any other changes to the default config? (egs here.):

  • Have U updated (without uninstall) from a CIS 5?: I had Comodo Firewall installed, I don’t remember version… I don’t remember, but I think I uninstalled it before installing CIS
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No, I configured it manually, and it worked for a few days before issue started happening
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Win7 SP1 Win64, UAC disabled (I think), Administrators group

  • Other security/s’box software a) currently installed b) installed since OS: a= b=
    [li]SpywareBlaster, TrueCrypt, Sandboxie, Spybot S&D

  • Avira Antivir (I don’t remember the version, it was discontinued then I decided to replace Avira for Comodo), Comodo Firewall (I also don’t remember the version)

[attachment deleted by admin]

This is definitely not normal behavior. However, I think it may be fixable on your computer.

Please try reinstalling by following the methods I suggest in this topic and see if that solves the problem. Also, be sure to run the removal programs for all previous security software you used to have installed on the computer.

Let me know how that goes.


PM reminder sent.

I will now move this to the Non-Format Verified board.

Topics in this board are rarely looked at by the devs, and even if they are it is unlikely the devs can fix the bugs reported.

I do not want to forward this to the devs, and have them try to search for a solution, when we have not yet ruled out the possibility of interference from the remnants of other programs and possibly a bad install. Please follow the advice I gave in my first response to your post. Once you have done that, and attached the diagnostics report and the KillSwitch Process List, I can forward this to the devs.

Please contact me if you have any other questions.

Thank you.

Can you please check and see if this is fixed with the newest version (version 6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are mainly not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments), so I can forward this to the devs and get this problem fixed.

Thank you.

PM sent.

Hello guys, sorry for the long delay. I had to travel and couldn’t handle this until now. Thanks a lot for the attention this post received and again sorry for not answering it.

I updated first post with attachments, is anything else missing?

When I get back home I updated Comodo. Same issue happened. I then followed uninstallation tutorial, including scripts inside Safe Mode, and then downloaded newest setup file and installed it back. Still same issue, it is impossible to use PC with firewall enabled :frowning:

Something I forgot to say. When the issue is happening, Comodo’s main window works fine, but none of its buttons work to open secondary windows. It takes ages for Advanced Settings window to open, so that I can disable Firewall.

I’m gonna install Windows 7 in another PC and install Comodo in it, let’s see how it goes.

I’ll move this back to the bug reporting board to be processed. Everything looks good, except you still need to note the other security software currently installed, and those which were installed but are now removed.

This information could be very crucial for understanding this bug.

Thank you.

Really thanks for the attention I’m receiving.

I updated it including softwares I use and don’t even remember :stuck_out_tongue:

I can uninstall SpywareBlaster and Spybot, could they be conflicting with Comodo Firewall?

Please do try temporarily uninstalling them, to ensure that they are not part of the issue. Also, please go to this page and run the removal tool for Avira. Doing all of this will allow us to rule out a few possible scenarios.

Once you have finished with this let me know if the problem continues. If it does then I will forward this to the devs.

Thank you.

I have already followed that tutorial to make sure Avira was totally uninstalled. I believe I used Revo Uninstaller at the time too. I rechecked and found no fire or registry referencing it.

I will uninstall them and see what happens for 2 days.

Thank you. If even after uninstalling them the problem continues please let me know ASAP and I will forward this report to the devs.


ok I have uninstalled SpywareBlaster and Spybot. I will reboot later then enable Firewall again…

It’s been a few hours with Firewall enabled and no issue. It should have started long before.

If this happiness persists it will be certain the cause was related to conflicts to 1 of these apps.

Okay. Please wait about 24 hours, just to be sure. Then, try reinstalling one program. Then wait about 24 hours, and if it’s still fine install the other and see what happens.

Let’s make sure we can determine where the problem comes from.


Thanks. I will wait some more days, just to be really sure :stuck_out_tongue:

But it’s strange. It’s been a lot of time that I dont even open these apps, and old Comodo never had problem. Why new one would?

Still working with no problem detected. I put PC in hibernate e brought back and also all good.

It’s rly related to these 2 apps, I didn’t change any config in Comodo other than enable it back.

If you can figure out which app is conflicting to cause this, it should be very helpful. Please see if you can figure out which it is.


Have you reinstalled one of the two apps? If so, did the problem re-occur?


Not yet sorry. I’ll download latest Spybot and install it.

Thank you, this certainly could be caused by running its HIPS alongside CIS. Please see if that is the case.