comodo firewall still works after termination

Comodo firewall : newest version
OS : Windows 7 ultimate

Even after closing the tray icon and killing two processes related to comodo, it seems comodo firewall is still working.
I couldn’t launch many programs which need internet connection, even after closing the tray icon and killing two processes.
So I thought - ‘what if I uninstall comodo firewall now?’
So I uninstalled comodo firewall. Before reboot, I tested again. This time everything was OK - I was able to launch those programs with no problems.

I observed this phenomenon in two computers. Looks like this is a nature of comodo firewall…

Q1) Is it normal phenomenon ?
Q2) Is it intentional ?
Q3) How can I stop comodo firewall completely (not uninstalling the program) ?

Thank you!

What processes did you stop? Cis.exe and cistray.exe? Then cmdagent.exe (Comodo Internet Security Helper Service) is still running. This is the process that does the protection underneath the surface.

Your problem is likely with the settings. What changes did you make to the default settings? Next time the problem happens post a screenshot of the Firewall and Defense + Events.

Thank you. I will test it again in almost clean window state.
I will repost it more concretely, in 3 days.

The situation is very irregular, and hard to explain because my English isn’t that good… I will record it with cam and write again.
(The two processes I refered above are cmdagent.exe and cavwp.exe, and I installed comodo firewall without chromodo and geek buddy and I disabled HIPS. Otherwise it is default installation. I rebooted after install. )

I uploaded the video on

Comodo is still working when comodo process is off. Moreover, it is working badly(blocking internet or blocking launching). If I turn on comodo process, then everything becomes OK.
I also observed its reverse many times but I didn’t uploaded to youtube yet - when comodo process is turned on, everything is OK, if I shutdown comodo, IE and firefox does not work properly.

Cmdagent.exe is the service that does the protective work. Under it runs inspect packet filter driver. Closing down cmdagent.exe when CIS is running may give unexpected results. It is better not to turn off the firewall by terminating cmdagent.exe.

Sorry but for me, this phenomenon is not particularly related to cmdagent.exe
I uploaded the Second video on youtube.

Comodo still works

  1. after closing tray
  2. after closing tray and terminating cavwp.exe
  3. after closing tray and terminating cavwp.exe and cmdagent.exe

Cmdagent.exe is doing the protective work in the background. The other processes are subsidaries of cmdagent.exe to communicate with Windows or the user.

Why are you trying to close down cmdagent.exe? What is your goal?

Thank you. Of course my goal is not closing down cmdagent.exe.

My goal is practical : “I want to use comodo firewall function most of the time, but sometimes I want to turn off all comodo firewall function. I want to use comodo firewall freely, like a lamp switch.”

The first thing I could do to turn off comodo firewall function was closing comodo tray icon. So I closed the comodo tray icon.
And I executed IE. IE didn’t work. It means comodo is doing something background. So I went further - I terminated cavwp.exe. Then I executed IE. Still IE didn’t work. So I went even further - I terminated cmdagent.exe. But IE didn’t work even this time.

I want to just temporaliy shutdown all comodo function.

You can disable the CIS modules from the systray. Only for Viruscope you need to go into the settings interface to disable.

Thank you very much.

You mean ‘Don’t close tray icon. Instead change settings if you want to disable firewall or hips.’

Sorry but can I ask you one more question ? Maybe the last ;D

You might have seen the videos I uploaded.

Is it (still working after closing tray icon) a normal behavior(=natural aspect) of comodo firewall ?

Yes its normal behavior. You wouldn’t want malware to be able to close your security software so simply.

Thnak you. My computer was normal ;D