Comodo firewall seems to be blocking some components of loginpro [V6][M190]


  1. What you did: First installed the latest comodo loginpro and made sure the option “run at startup” was enabled then i installed comodo firewall and rebooted. Loginpro doesnt not start at boot after comodo firewall is installed. It started just fine prior to installing c firewall.
  2. What actually happened or you actually saw: loginpro no longer runs at boot with c firewall installed.
  3. What you expected to happen or see: loginpro to start at boot as normal.
  4. How you tried to fix it & what happened: tried disabling all components of c firewall; tried adding loginpro to the shellcode injection exclusions but nothing helped.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: Tried many different things but nothing helps.
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): Screenshot attached
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: First install loginpro and have it run at startup, then install comodo firewall with default settings and reboot. Loginpro will no longer start at boot.
  8. Any other information (eg your guess regarding the cause, with reasons): Loginpro’s services seem to be running okay except loginprotrayapp.exe which is the GUI.

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):attached

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: attached
  2. Screenshots illustrating the bug: N/A
  3. Screenshots of related CIS event logs: attached
  4. A CIS config report or file: attached
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Attached


  1. CIS version, AV database version & configuration: screenshot of about page attached
  2. a) Have you updated (without uninstall) from a previous version of CIS: clean install
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): none, default firewall config
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: d+ disabled; bb disabled; firewall safe mode
  6. OS version, service pack, number of bits, UAC setting, & account type: win 7 ultimate x32; UAC disabled; admin
  7. Other security and utility software currently installed: peerblock on demand; loginpro
  8. Other security software previously installed at any time since Windows was last installed: none
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: N/A

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Not fixed in 2708. i have also found CIS silently blocking the services for tversity media server. I have created 2 screenshots, the first ones shows all the servies that start with loginpro (4 services) and tversity (2 services) before CIS is installed. The second shows that only one service from loginpro starts and both the tversity services dont start. Iv noticed when my computer starts up, ill try to open process hacker but nothing will respond. it seems like CIS is still initializing and it keeps anything from loading until its ready. After 5-10 second process hacker will open and ill see tversity’s processes but they will close shortly after, same with loginpro (except the main gui which is loginprotrayapp.exe) it never starts.

[attachment deleted by admin]

My best guess is that the loginpro services are timing out on start.

If you look in the Windows event log you should find an error event 7011 or some such.

If so the most elegant solution is to change the timeout.

Here is a link:

If you don’t want to edit the registry, I think you can make the service re-try.

Also you could look in Kilswitch to see how it’s actually running the service.

Adding to BO exceptions is another possibility - exempts the service from more than just BO checks, so may speed up start.

Best wishes


thanks for your help but unfortunately neither of your suggestions helped. i really hope comodo helps diagnose the problem

Any relevant events in the event log. Should be something regarding failure to start for a service.

NOT fixed in CIS 6.1.275152.2801

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

This is NOT fixed in v6.2.282872.2847

Thank you.

I have updated the tracker.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

im going to close this bug since loginpro is no longer in development