Comodo firewall + router = no incoming connections :(

Hi all, this is my problem:
I have router MSI RG60SE and comodo firewall 3. When i have comodo enabled, my computer does not accept incoming connections (for example utorrent or ftp server). Even if i have firewall in training mode, or i have set utorrent of ftp as trusted application, it doesn’t work. I have forwarded needed ports in router, so if i disable comodo it works fine. Before, when i don’t have router, only firewall, there was no problem with incoming connections when i set application as trusted. Pls help, how can i setup comodo, that it will accept incoming connections for trusted applications? I tried add ip of my router or network to trusted zone, but this doesn’t work. Loopback is allowed too. So i must set comodo to disabled everyone i need incoming connections.
-sry for bad english and thanks for help-

hi mspeedo

1.Pls check your global rules. maybe some rules blocked some ports incoming.
2.Set “stealth ports wizard” to alert me incoming connections stealth my ports on a per-case basis".and try again.
3.Check your global rules. make sure there no rules block router gateway ip incoming.