Comodo firewall pro 3.0.22.249 with sp1

This is my first post on this forum, please excuse me for any mistakes I might possible have done with this post.

My current system:

  • Vista home premium sp1
  • AVG 8.0 FREE
  • Windows firewall
  • Windows defender
  • Verification engine

My problem:
When I installed comodo firewall pro on my machine everything seems to be fine. During the installation I only see a warning from vista that comes when a unsigned driver is beeing installed, but this warning goes away within a second, though i recognize the warning. Comodo continues installing the same way as it always does. This time I have chosen the firewall with defense+ enabled because I learned how to handle with this feature on a other pc of mine. The pc reboots as it always does, but now verry slowly… I see the same icons as usual in the taskbar, but the sidebar will not load and comodo firewall pro doesnt load either. clicking on the desktop icon doesn’t help, the gui just doesn’t show up. I tried several times installing and uninstalling but this problem seems to show up every time i boot up. For now i leave the comodo firewall as it is, but i don’t think there should be any problems because i have read that others haven’t experienced any problems with the firewall and vista service pack 1.

How I installed sp1:
I uninstalled all of my securityprograms:

  • AVG Free 7.5
  • Boclean 4.26
  • CFP 3.0.22.249 (without defense+)

Than I have done a reset of my security center because the information was all wrong. I rebooted and the security center was giving the right information again. After that I installed vista service pack 1 through windows update.
After that I installed AVG FREE 8.0 and BOclean, but boclean didn’t boot up and gave an error message (that is a an other topic). I uninstalled boclean and installed comodo firewall pro wich gave me the problems you see above.

Has someone who is a bit in too these programs and other software a clue of what is wrong with my system? I know a bit of computers and software, actually I am studying it at lot of years, but has anyone a clue?

Thanks! (:SAD)

Are you sure Windows Firewalll is not working together with Comodo?

thanks for your reply,

I am really sure the windows firewall is turned off when i installed comodo firewall pro. That is what i am always doing. And if that is the case i am sure that the windows firewall does not give much trouble together with comodo, rather than a real commercial firewall like norton has. But i am sure no other firewalls where interfering with the comodo firewall when i installed it.

(:LGH)

Follow the sticky for removal instructions here…

Josh

Thanks for your reply 3xist,

I think that is indeed a good idea to try, maybe there were some trouble with removing due al the system changes i made with installing software en reinstalling and resetting etc…

I’ll try that and post what the outcome is.

Well i runned the batchfile, but it said there were no entries to delete, they didn’t exist. So i might had no left overs from the comodo uninstall feature.

I did a reboot an closed down all of my security apps (avg, firewall of windows, windows defender) and some other programs that were running in the background.

I installed the comodo firewall again and have chosen to activate defense+ and let the firewall do a scan of my system. It was clean and i did a reboot. After the reboot i am having the same problem:

  • tray icon is not visible in the taskbar.
  • clicking on the desktop icon doesn’t show up the firewall gui
  • In the proceslist i see 2 times cfp.exe (this wasn’t the case at boot up)
  • I don’t see cmdagent.exe in the proceslist
  • The wizzard “New private network detected” didn’t show up (this should show up at first install)

Before sp1 it worked fine, i didn’t chose defense+ at that time. But it worked. Now i have sp1 and i chose defense+, do you think defense+ is causing the problems?

(:LGH) Thanks!

Update: Well i rightclicked on the icon and said run as administrator and then i saw the comodo interface show up again and it was running smooth as i got used too.

Before sp1 i saw an icon telling me that some applications are blocked at startup, that was the comodo firewall. I just clicked on it and let it run as adinistrator. I was expecting this was going to happen too, but it wasn’t the case.

Can’t the comodo firewall developpers find a way for comodo firewall pro to start smoothly with all the admin rights at startup in vista and vista sp1?

I restarted the pc a couple of times and sometimes i see in the proceslist 3 times cfp.exe I don’t recall this was the case before I had sp1 installed. I also think that cmdagent.exe must be listed in the proceslist when comodo firewall pro is loaded at startup, but I am not sure of that.

Now when i click on the desktop icon and say that the firewall must run as administrator the firewall is running good, but when i shutdown the pc i get an error saying that there is a filesystem error and short after that I see in the taskbar the icon telling that some programs are blocked (i think that is a part of windows defender wich is controlling startup programs with uac) but this icon should appear at start up and not when shutting down! so there are some strange things going on…

Does anyone with vista sp1 and cfp installed recognize the things I listed above? or am I on my own?

:■■■■

I just uninstalled comodo firewall pro, it just gave me too much problems. It is too bad i really liked the firewall.

Yesterday it gave me a balloon message wich said me there was an update for the firewall, when i checked the release notes it was the version i already had. I updated anyway, but when restarted today the comodo firewall didn’t function properly and i had to do a diagnostic and reboot said the firewall so i did, but the problems still existed and the diagnostic didn’t solved the issues. My internetconnection was also down and that was just the drop too uninstall the firewall.

too bad there isn’t much expertise on this forum…

bye all!

I hope you really love Comodo as much as you say, Please try this uninstall procedure: https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_3_info-t17220.0.html and install again.

I hope it keeps you here with the Comodo people.

Everyone that helps out is an expert. Be patient.

I followed every single bit of the removal instructions and there were indeed some left overs, but when i installed cfp again, it still doesn’t loads up at start up by itself, and i don’t see the icon of blocked start up programs either, so i have to rightclick on the desktop icon and say run as administrator and then the firewall icon and gui shows up.

it always blocks loading of the sidebar so i must manually start that too every time i boot up, I think there must come an improved and better cfp version with full support for UAC and SP1 because it is not fun running the firewall this way anymore

And no, i don’t want to turn of uac, it is an extra layer of protection and that is better than a layer less.

Have you tried finding the Comodo Files cfp.exe and cmdagent.exe and setting them to ‘Always run as Administrator’ after I did this everything worked well at start up. Also, check in CFP Miscellaneous/Settings that the firewall is set to start with windows - just in case.

I don’t use the sidebar so not sure about that one - ensure is D+ is not set to ‘block all the unknown requests if the application is closed’. Also, try checking to see if there are any settings in D+ Computer Security Policy that have anything to do with Sidebar and remove the entries you find. Then set D+ in training mode before re-booting.

:SMLR

One of the reasons I will never switch to Vista. Did you read this.

https://forums.comodo.com/help_for_v3/tutorial_on_how_to_make_cfp3_work_nicely_with_vista_and_uac-t20463.0.html

Before reinstalling the firewall, I dived into the program files folder and selected cfp.exe and cmdagent.exe and checked them to run as administrator, just in case i also checked the compatibility mode option as xp servicepack 2. When deleting al the registry entries and defragmentation of the registry and reinstalling the firewall was still checked to run as administrator. The OS somehow didn’t forgot this.

Comodo firewall pro is checked to run at startup and defense + isn’t blocking unknowing request if the application is closed.

for more strange stuff, see the pictures…

(:TNG)

[attachment deleted by admin]

[attachment deleted by admin]

Are the things above recognizable for some comodo members? Or am I on my own?

Question: When will there be a new update for the firewall? With stronger security, better os integration, improved pop-up alerts, new functions like iptracking with a map tracking, gaming mode function, icon colours for block all and disabeled firewall, icon colours for defense + installation mode and normal mode, pause function for a selection like block all, programscanner for known trusted programs so a lot of save programs are allowed automatically, multiple translations onboard, check the security settings of other pc in your homenetwork with comodo firewall pro installed, malwarescanner updates, onboard skins, detailed log information etc

I am SORRY if this is too demanding and if posted this wrongly. I am also happy with the functions the firewall has now if nothing changes.

:THNK| (S)| (V)

Hi there folks!

Does anyone recognizes the strange things shown in the screenshots???

Any helpfull replies are much appreciated…

:-TU| (V)| :THNK

Just in case: the screenshots are listed on page 1 (:NRD)

Your screenshots are indeed strange!

2 cfp.exe processes? Hey… Can you please turn off Windows Defender. Also run a Virus/Malware Scan. I will assist you with the malware scanning if needed. Programs we strongly suggest:
SUPERAntispyware Free
Spybot-S&D

Please scan with those programs, Make sure definitions are up to date.

Possibility an online Scan with Kaspersky is also necessary. Because you have really strange results.

I will watch this topic and look forward to your reply.

Josh

I think that is a good idea to try, I do have the programs on my machine already so that shouldn’t be a problem.
And I also will scan my system with the kaspersky online scanner, i will post what the outcome will be

(V)| (R) | :THNK