Comodo Firewall Pro RC3 Released

Hi Guys,

We are making total 11 languages setups live except Chinese (Simplified and Traditional).

Addons Setups

English_ Setups

English Alone Setup

Following are the changes:

  1. Addition of Spanish (LA & Spain), Swedish and Turkish after corrections.
  2. Fixed BSODs reported in RC2
  3. Fixed the bug causing TCP In popups to be asked



Get the attached error trying to access the download…


[attachment deleted by admin]

Confirmed: CFP_Setup_English_2.4.13.153_RC3.exe file not found server.

Perhaps we’re too quick. LOL

Worked for me…

Oh… not the english version… I downloaded the Swedish version…
Try that one Kail and LM… ;D

Oh, sure! Can you give me the minidump of your “non-nosewool” translation program?


No I can’t… :wink:
But I can give you a link to Babelfish… ;D

There was a spelling error. Now it should work ok guys.

I know what kind of apps that use double extensions are… :wink:

Opinion: The second reboot was faster, so i recommend everyone to reboot twice ;).

  • Some reported cutted texts are fixed.
  • Adapter displayed correctly.
  • HTML export wasn’t fixed (reported at rc2).
  • Found 1 more cutted letter and the network adapter’s subnet mask’s text is cutted off (attached pictures).
  • Found a small GUI problem: if you create a new trusted network, the summary page’s texts have no space (attached picture).
  • Some part of the submit sentence is cutted when you’ve finished the submit (i think everyone else should check this).
  • While i’ve tried to use CreateInstall (a setup creator)'s inner Updater function (clicked on About/Update which called it’s own application) the submit program caused an error. However, the submit program was able to continue it’s work :).

[attachment deleted by admin]

Installed and testing!

The problem I reported here yesterday appears to be a lot better, though I wouldn’t say it’s fully fixed yet, sometimes I have to wait 2-3 seconds after I click “Allow” before the dialog box disappears and the APP being asked about gets access to the network.

Thanks Comodo Team!


There is a slight GUI glitch, on changing XP themes this can happen (this was with RC2, but since it is not mentioned) :
Firewall was running, and I switched between themes (not Microsoft ones, patched uxtheme.dll, but no other application behaved like this…)

[attachment deleted by admin]

The Swedish version hasn’t been corrected as suggested earlier.

There was a 5 sec. delay, but it’s gone right know after a restart of the firewall.
Let’s see if it comes back.

It’s working with the Vista theme I use.
The RC1 version didn’t…

  1. I don’t know if the “3. Fixed the bug causing TCP In popups to be asked” means that the TCP In connections being shown in Activity/Connections was supposed to be fixed, but I am still experiencing that. (see attached screenshot)

  2. There is a discrepancy in the way the connection is being displayed. I’ve highlighted two Outlook connections in the attached ss; the Source IP is my computer. The Destination IP is the Exchange Server. Okay, fine. But CFP is showing this as an “In” connection. If it is going to show it as Inbound, the Source/Destination info should be reversed…

  3. BTW, still getting a delay when interacting with alerts/popups; takes about 3 seconds to be able to check boxes or click on anything, before CFP will allow and respond to the interaction.


[attachment deleted by admin]

Some errors in attached files.

[attachment deleted by admin]

Hey everyone, im new to the forums, so i thought that id make my first post a useful one!

I just downloaded and installed the new RC3 version of CPF. Installation went fine, without a hitch (as usual ;D). Rebooted as required and allowed the system processes to do their thing via the popup alerts.

Browsing through the user interface, i found that the system would freeze for a few seconds when moving to a new page. For example, it would take a few seconds of inactivity for the Application monitor or component monitor to load. The same goes when switching to and from the pages via the buttons at the top of the window.

A quick reboot solved this problem. Nice work guys, but i shouldn’t really have to reboot twice! :wink:

Apart from that very, very minor gripe, you guys have done a great job! Well done!

I love the little animated icon, its good to know that it is working by showing traffic flow. (although the animation looks a little too similar to that used by Sygate (at least i think it was that one, i tried a few before finding CPF), dont you think? Its all good though!

Thanks again for a fantastic piece of software!



I also get these in connections…
For Thunderbird I only have 2 rules in application monitor. Both are out… one for UDP and one for TCP.
See image.

[attachment deleted by admin]

Oh, great, a new RC.

So when will be the official build released? :BNC

RC3 conflict with DrWeb, causes system process high CPU usage .
Here is the snapshot :

[attachment deleted by admin]