Comodo Firewall Pro RC1 Released

Hi guys,

We have just released RC1 which is available for download at :

  • System crashes related to previous BETA have been fixed

Great to hear, I will go ahead and install it now :smiley:

Thanks Egemen. Will start downloading and installing now. :wink:


I have just locked all previous 2.4 beta topics, due to the RC1 being released. However I have left them sticky for now just in case the developers need to use them for reference.

Maybe you could put them all in a “previous beta’s” child board?

I’m gonna try this version out right away.

hi all,

good news.
just downloaded, send feedback when installed.


Installation is done, and I still notice a delay when you click Allow or Deny when Comodo asks you about an application, it is not as bad as before, but still there and noticeable.


installed now. Too soon to say anything, delay on popups a bit too long, but not long enough to worry about. As usual, must wait a bit before anything appears in component monitor,even though some applications have already been started and have been allowed to run. Doesn’t really matter, just a matter of minutes, or reboots, before everything comes back to normal.

I still have delays on both popups and in the gui.
It seems a bit better than the previous version though.

I installed this beta as well and have the same problem which I had with the previous beta. When I restart the system after installing the beta, windows starts (I see the windows logo with animation) and then it halts. I get a BOSD and the system restarts. Then the system recommends that I start windows with the previous working settings. If I choose to start windows normally, I see the BOSD again, followed by restart. So I start windows with the previous working settings and I see that Comodo Firewall isn’t turned on. I tried to exit and restart the application, but it doesn’t help. I also tried to turn the firewall on by clicking in the security section on turn on, but it will not work. I don’t know if this is a bug and if anyone else has this problem, but could anyone help me please or fix it?

I have the same problem and no solution

installation went fine (ran in xp compat mode sp2) until the point where comodo asked to turn off windows firewall

as per screen shot

rest of installation continued with no problems and asked to restart

on restarting it took a while for comodo to initailise upon reporting it needed tgo be reinstalled ive
includeded the xml error reports and the promblem solution report in the zip attched

im going to try CFP_Setup_English_2.4.5.111_BETA again this seemed to work nearly perfectly
but i didnt document anything so ill redinstall it hope the info helps.

[attachment deleted by admin]

would be great if you could send some more details on your OS, and apps running, also I’m sure that the dev team would be happy to receive an upload from your minidump(s). I never had a bsod related to this firewall, no system crash, ever,I mean in connection with cpf.

2.4 is not compatible with Vista. I’m afraid that even an xp/sp2 compatibility mode
wouldn’t help. You’ll have to wait for cpf 3.0 if you want run it on Vista.

  1. A gui bug?
  2. Please Reduce cmdagent memory usage, it’s now uses too much mem (13,352K).

[attachment deleted by admin]

my OS: windows xp media center edition 2005
applications running: comodo antivirus, vista transformation pack 6, ati catalyst control center, google updater
I attached the mini dump file you requested (hope this helps)

[attachment deleted by admin]

Can you write down the BSOD code? To avoid reboot - so you can write it down -, please, follow these steps:

type in: sysdm.cpl
Special tab
There’s a startup and restore Settings button, click on it
Uncheck automatic restart

I can confirm this gui bug.

A thing, i don’t know if it’s caused by previous 126 + Hun addon or by this rc uninstall: windows found a new Multimedia video hardware and it’s controller… I guess it’s my WinFast 2000 Deluxe but i don’t know how the installer could do anything with it. Can this be a bug or this is a major vis major at me?

I miss maxhton’s application control rule (1.5.9 build 30), what i use here. Is that normal?

This is an RC already, why we can’t get new language releases?

Can you please send us a memory dump Windows Generated?


According to this memory dump, ATI Catalyst has crashed the system while RailroadsDemo.e file is being run. If you have other dump files, you can send them too.