Comodo Firewall - prevents Excel 2003 file from loading

After loading Comodo firewall on Vista PC, I cannot load a file into MS Excel 2003 by double clicking. Error message says file does not exist. When I remove Comodo, Exel than will load up by double clicking…Can anyone help?

To solve the problem you need to install CIS again so we can take a look with you. Does the problem happen again after installing CIS again? If it happens try making Excel trusted program in D+.

Can you tell me what CIS is? How can you look to see what is going on. Thanks for response.

CIS is Comodo Internet Suite. Comodo Firewall’s follow up. When installing CIS you can choose what components you want to install.

What version of Comodo Firewall are you using?

TComodo Firewall the version is 3.5.57173.439. You recommend that I uninstall and reinstall?

I already assumed you had CIS uninstalled when you wrote it so I gave cleaning tips for a successful clean install.

But since you apparently reinstalled. What are your D+ settings for Explorer and Excel?

Actually, I did not uninstall, I just disabled via MSconfig. I did not want to be w/o protection…This is the method that I determined that Comodo had caused the Excel issue. I will plan to do this after I understand my other options, but can you tell me how to check D+ settings for Excel? When I check the security under Excel/Tools it is set at medium.

The rules D+ made for Excel can be found under D+ → Advanced → Computer Security Policy.

What do you mean with “When I check the security under Excel/Tools it is set at medium.”? You mean when you look in Excel under Tools in the menu bar?

To answer your last question first. Yes, I used Excel’s Tool tab to find that Security was set at medium…

Regarding D+, I still do not know how to find it…Is it under Windows, Excell, or some place else?

I did finally uninstall Comodo. It was also causing Excel not to find MShelp when I tried to use Help feature…After removing Comodo, it was accessible. (as well as the file load issue)…I would like to reinstall, but I am not sure these issues will go away,

Thanks for your response.

Before installing CIS again you can do a thorough registry to get rid of the last remnants of CIS rules. You can use Comodo System Cleaner:;msg246654#msg246654 .

I think something went wrong with allowing/blocking Excel. With a clean install you can start with a clean slate.

CIS will most likely make rules for Excel. It is more than likely in the safe database; and if it is not there it is a signed executable by Microsoft which is in the My Trusted Software Vendors list.

Also pay attention to D+ alerts for run32.dll process. You can and should allow when the dll is a known file to you. The alert will have a link to see the properties of the file; use that to see if you know the file and when known to you allow.

I have been out of touch for a while…I appreciate all your help on this. I feel uncomfortable modifying registries, etc…I will be enlisting some face to face help…Hopefully I will be back on CIS soon.