Comodo Firewall not starting on windows start up

I can’t figure out where you change this setting. I would like comodo firewall to start automatically when I start windows. Right now I have to start it manually.

Hi domdeez, welcome to the forums.

You seem to be missing the following auto-start entry…

   "C:\Program Files\Comodo\Firewall\CPF.exe" /background

… this is based on a default installation directory & the registry entry in…

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

I can only assume that have an application running that prevents auto-start registry entries from being created. So, you can either disable that app & reinstall, create the entry manually (a shortcut in your StartUp directory will be OK) or find a recent post on the same subject, where someone posted REG file that creates the entry for you (this would only work if you installed CFP in the default location).