Comodo Firewall not remembering Firefox

I’m new to this forum and to comodo. I have latest free version. Everytime and click on mozilla firefox to access internet comodo comes up and asks to “allow” or “deny.” I check the box so that it will remember to allow firefox everytime, but everytime it asks me what I want to do. Is this a bug concerning how it interacts with firefox or just user incompetence.

Neil R

Welcome to the forums, Neil (:WAV)

I’ll shy away from “user incompetence” ~ I think it’s more appropriate to say “ignorance” which can be cured… :wink:

There’s nothing special you need to do to allow FF, other than what you’re doing. Since that’s not working for you, there’s only a few things that can be causing the problem:

  1. Your Alert Frequency (Security/Advanced/Miscellaneous) is set to High or Very High. This will create alerts for each aspect of the connection - IP Protocol, IP Address, Port, Direction, etc. Thus, when you click Allow w/Remember, you will create multiple rules (in Application Monitor).
  2. You have remnants of another firewall still installed, or XP Firewall is still on. Firewalls can be a tricky thing. See this link from Firefox: Firewalls - MozillaZine Knowledge Base I just read thru it this morning, and it has some good general info there.
  3. Firefox updates on you, thus being changed each time you open it. This will prompt an alert from CFP. See mozillazine link as given above.
  4. The installation of CFP has an error, perhaps due to a conflict caused by other security software running while installing CFP.

All that said, I’m betting you’ve got item #1 on your hands. Moving the alert frequency down to Medium will resolve it. Or, just be aware that having the higher alert frequency is going to give a lot of popups, and each will contain different information, as mentioned above.

So, check that out and let me know what you come up with. Then we’ll go from there.

LM

Thanks Little Mac. I changed it from “low” to “very low” and that has helped I think. I’ll report back in a few days to see if it sticks.

Neil R

Neil,

If you were on “Low” (which is the default), you shouldn’t be getting the multiple alerts as I mentioned; they don’t have that much detail at that level.

Will you post a screenshot of your Application Monitor? Open to full screen, scroll to the FF rule(s), then capture the screenshot. Save it as an image file (jpg, png, or gif) and attach to your post under Additional Options. You can edit/mask personal IP addresses if you like; just leave enough to show matching IPs where applicable.

LM