Comodo Firewall not recognized by Windows Security Center (Vista)

Title pretty much says it all. I had Comodo Firewall installed and working fine on my 32-bit Vista SP1 laptop. I upgraded to the latest version ( of Comodo Firewall yesterday, and now Windows Security Center won’t recognize it. It displays a red warning shield in the system tray and informs me that Windows Firewall is turned off. It doesn’t seem to have any idea that Comodo Firewall is even installed, even though it (Comodo) is running and appears to be working properly.

I have spent a lot of time configuring rules for Comodo and I don’t want to wipe the slate clean and start over if I can possibly avoid it. So I have basically two questions:

  1. Is there a way I can force WSC to recognize Comodo again? I’m perfectly OK editing the registry or registering a dll somewhere if that’s what it takes.
  2. Is there a way to preserve all my settings so that I can uninstall Comodo, purge it from my system, then reinstall it and restore the settings?

Obviously, I’d prefer to tweak something on the system and have it suddenly work again, rather than going through the uninstall/reinstall cycle. I’d also like to have some understanding of what went wrong and where in the system it is.

Hi beerslayer,
Try rebuilding your systems WMI repository.

1: In Services, Stop Windows management instrumentation service (WMI).
2: In the system32\wbem\Repository folder, delete all the files.
3: Reboot and the repository will rebuild (Rebuild may take a few moments).

Alternative rebuild method.
Run command prompt as admin (right click)

1: net stop winmgmt

2: cd %windir%\system32\wbem

3: ren repository repository.old

4: net start winmgmt

Note: With this method hit enter after each command.

Reboot and the repository will rebuild (Rebuild may take a few moments).

Kind regards.

captainsticks - thanks for the reply. Unfortunately, that’s one of the first things I tried. Scan revealed no inconsistencies in the repository, and rebuilding it had no apparent effect whatsoever.