Comodo firewall need to be disabled to grab IP


My apologies if the title is misleading.

My internet connection is connected to my router which is a Linksys E3200, everytime I start up my PC, I will need to disable Comodo Firewall and then run IPconfig to grab an IP before turning on the firewall again.

Is there a way to avoid this?

I’ve already added my router’s hostname to the Global Rules under the Network Security Policy, tried using my router’s IP and even the IP address allocated to my PC by the router, still no go.

Is there anything else I need to set or check?


This may be the solution you are looking for: No network connection after using Stealth Ports Wizard (DHCP Broken).

Hi EricJH,

Thanks for your assistance in this. Sadly it doesn’t work. :frowning:

I still need to disable comodo firewall, run the ipconfig /renew command and re-enable comodo firewall again.

The source and destination port on my system is different from what Ronny faced, so what i did was to try with 68 as source and 67 as destination, it didn’t work.

Let’s take a look at the rule for svchost.exe. Can you show me a screenshot of the firewall Application Rules to see what rule is made for svchost.exe?

The logs show that in this case outgoing traffic to the DHCP server (destination port UDP 67) is getting blocked.

Hi Eric!!

Here’s the screenshot as requested.

Try changing the svchost.exe policy to Outgoing Only. That should do the trick.

It worked. :slight_smile:

Thanks for helping with this issue Eric