COMODO FIREWALL LEAVES MY COMPUTER COMPLETELY UNBOOTABLE

Ever installed an operating system 3 times in 2 days? Well, i just have, and it’s all thanks to the new comodo firewall 3. Did i accidentally download a pre release by mistake? Because as far as i can see, this software should not even be available for testing.

EVERY TIME i have installed my operating system the last few days, and installed comodo firewall 3, i recieve a blue screen of death. I can only use task manager. Firewall does not run on boot, and i cannot access ANYTHING on my computer except press ctrl alt del to bring up task manager, from which i can browse my computer, but cannot open any files, processes etc.

I don’t know whether this is the correct forum. No doubt this is more important than my problem. I’m sorry to sound like a moaner, i really liked the other firewall before, but this one’s driving me COMPLETELY INSANE. I think that comodo’s paranoid mode is preventing essential services from running, including itself.

Please, i know this is the bug report forum, but for the love of santa, tell me how to sort this out without reinstalling windows XP for the fourth time.

Oh, here’s some useful info. Windows XP SP2 3.4Ghz 32bit and i can’t remember anymore because i cant access anything.

Also, everything is “not a valid win 32 application”. And no, i can’t run msconfig or command prompt.

Hi
I had much the same problem as you with the initial release V3.0.13.268 x32 vista XP I only could only uninstall it in safe mode. It this the same version you have used cos it sure sounds like it!
I since downloaded V3.0.14.276. and since then it has worked almost perfectly. (seems to be a few issues with pending lists of files for submission). But from that point it has gone from crippling my computer to working fine.
I think the dev’s here did an amazing job to turn it around. Also a help is having the clean install of MS VC++ runtime distribution. (seen in add remove programs) This may help too.
Best of luck!
Happy Xmas!

Hey Vunox, merry xmas to you too.

Nope, i have 3.0.14.276 as well. Also, i wish i could access add/remove programs, or run in safe mode, or even throw firewalls in the recycle bin. But unfortunately, i can’t. Comodo-related reinstall of windows number four is coming up in about 15 minutes, unless anyone can give me some clue. Even something that could just do a operating system independent deletion of the firewall would probably work. Help, quick, please, before i waste another 12 hours installing, updating etc etc.

Bad news!
Well you should always be able to access safe mode by hitting F8 after a cold boot just as it leaves the bios.
I assume your not formatting the drive which would should work. But certainly I was in the same boat as you until I de installed in safe mode. Maybe an idea to chage the title of your post to include the version number and OS details.
That seems to attract attention of the experts. (which I am not). At this time a ■■■■ may be a better move and wait until a few more people around.:wink:

On the first day of christmas comodo gave to me
A firewall that crippled XP

On the second day of christmas comodo gave to me
Two mutually incompatible computer security policies
And a firewall that crippled XP

On the third day of christmas comodo gave to me
Three reinstalls
Two mutually incompatible computer security policies
And a firewall that crippled XP

On the fourth day of christmas comodo gave to me
Four false positives
Three reinstalls
Two mutally incompatible computer security policies
And a firewall that crippled XP

On the fifth day of christmas comodo gave to me
FIVE BOGON PINGS
Four false positives
Three reinstalls
Two mutually incompatible computer security policies
And a firewall that crippled XP…

Sorry.

F8 huh? Will give a try Vunox. The ■■■■ suggestion sounds good, though.

Woooohoooooooooooo! Firewall is DEAD!!! Differently abled! I bashed some buttons, got to a command prompt or something, and it works again. Cheers for your help Vunox! :BNC :BNC :BNC

Did you see this thread for removing CFP?
https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_3_info-t17220.0.html

As always, it’s unfortunate to hear about a user experiencing this level of difficulty. I also was unable to successfully install v.276 on my laptop, yet it works fine on an old PIII desktop system.

Keep these instructions handy, just in case.

Well, i feel a bit bad actually, because i really like comodo firewall, and the new version has some excellent features. It was my own fault that i was unable to run windows, because i just set everything to paranoid mode straight away, meaning that things like userinit.exe were unable to run, because paranoid mode was yet to encounter them.

Anyway, i notice that there are preset “windows system apps” when comodo is first installed. Why not add more of the critical processes that are needed to run windows properly to this list by default. The fact that some cretin( ie me) can come along, change the settings quite normally and leave the computer stuffed is not good.

I’m still using comodo firewall 3, by the way. Working well, by all accounts.

I think the “out of the box” default settings for Comodo are getting better with each release.

Similarly, as it “takes a village to raise a child,” it takes a broad forum community like ours to contribute files so that CFP’s programmers can add them to the predefined safe list of applications.

Everyone’s system is different, of course, but probably the best thing to do is to let CFP run under default settings for the Firewall and Defense+ for the first 24 hours. Making a backup of the default settings is the first thing that should be done, before making changes and creating custom rules.

I think it must be more than that there must be a conflict on your system with CPF3 somewhere, because I have always set CPF3 to paranoid and delete all presets apart from Comodo processes and had no problems whilst I did not tick the box to stop all processes from starting that did not have a rule when CPF3 was not running.
Dennis

If someone recieves this error again and could post the exact text of the bluescreen this may be of more use to the developers. Don’t forget that by default Windows XP will automatically restart on the event of a bluescreen and not display the error (see: How to Disable Windows Automatic Restart on System Failure)

Also it might be a good idea to run a backup before your Comodo install if you know it’s likely you might do another reinstall :slight_smile:

Matt

Hello again.

Right, here’s how i created the problem. Basically, everything was set to “don’t trust anyone”. I’m pretty sure i didn’t delete any of the preset “safe” applications in defense+settings, but during the setup i didn’t approve anyone certified by comodo or anything like that.

Defense+ security level=Paranoid mode

Image execution control=Aggressive

Trust apps digitally signed by trusted software vendors=false

Block all unknown requests after app is closed=true

This was done literally within 5 seconds of install. On rebooting the computer sometime later, I then got the standard blue “welcome” screen, followed by a blue screen only (not the “blue screen of death” or whatever, just a blue screen with no desktop shortcuts, taskbar, nothing). From this, i was unable to run anything except task manager using ctrl alt del, but task manager was completely unfunctional (could not run, terminate tasks, etc.) Attempting to run apps from task manager produced only a message saying “x is not a valid win32 application”, or “windows could not find the spcified file”. I was unable to shut down directly from task manager, but i was able to “log out”, from where i could shut down.

I solved this problem by using the recovery console to enter the command prompt. From here i just disabled three services- cmdAgent, cmdGuard, and CmdHlp. Not sure if all of these need to be disabled, but after i did this, everything booted normally. I then ran comodo firewall, used the self repair function to get it working again, and changed the settings so that image execution was normal, block requests from closed apps disabled, trust apps by signed vendors on, and defense+ mode learning mode.

Here are some processes which i have added to the computer security policy as windows system apps. I don’t know whether they are all necessary, but with these defined as system apps, everything works fine with the original, ultra-paranoid settings i used in the first place. As far as i know, (assuming i didn’t delete them), these are not included by default.

explorer.exe (surely this should be included as a system process initially, no?)
userinit.exe
logonui.exe
control.exe
sysocmgr
imapi.exe

These are all in system 32.

Hope this is useful.