Comodo firewall is stopping nfsd.exe service(HaneWIN NFS Server 1.1.72) [NBZ]

The bug/issue

  1. What you did: Started nfsd.exe service (HaneWIN NFS Server 1.1.72)
  2. What actually happened or you actually saw: The nfsd.exe service is stopped after one second. No related log entries appear in the Firewall nor the Defence+ modules
  3. What you expected to happen or see: The process keeps running
  4. How you tried to fix it & what happened: Set only the Firewall Module to “Disabled”, the process keeps running then (defence+ mode “safe”, sandbox mode “enabled”
  5. If its an application compatibility problem have you tried the application fixes here?: Yes - set it as Installer or Updater
  6. Details & exact version of any application (execpt CIS) involved with download link: HaneWIN NFS Server 1.1.72
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: It happens every time the Firewall module is set to “Safe”
  8. Any other information (eg your guess regarding the cause, with reasons): My initial guess was it is the Defence+ module that blocks the service. The executable is added as trusted in the Defence+ module. However, turning the defence+ to “disabled” does not help, nor setting the nfsd.exe as installer. It is the firewall module that needs to be disabled for the service to run.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: NO
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: NO
  3. A CIS config report or file. NO
  4. Crash or freeze dump file: NO

Your set-up

  1. CIS version, AV database version & configuration used: Comodo Firewall 5.3.176757.1236
  2. a) Have you updated (without uninstall) from CIS 3 or 4: NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): NO
  5. Defense+, Sandbox, Firewall & AV security levels: D+= SAFE , Sandbox=Enabled , Firewall =SAFE , AV = N/A
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7, 32bit, UAC enabled, admin account
  7. Other security and utility software installed: Avira Antivir
  8. Virtual machine used (Please do NOT use Virtual box): NO

A ticket# #UDH-635091 is opened with Comodo Support Desk

Hey and warm welcome to comodo forums Laserjet6! :slight_smile:

I want to thank you for taking your time to fill in this bug report.


try to add this exe file hereCIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse…

Valentin N

Please read 4. How you tried to fix it & what happened: Set only the Firewall Module to “Disabled”, the process keeps running then (defence+ mode “safe”, sandbox mode “enabled”

Nothing to do with Defense+

@ laserjet6

Thank you for your bug report in the required format.

Moved to verified.

Thank you


Hi Valentin, Dennis,

Thanks for the welcome.
@Valentin, even though this seems to be problem with the Firewall module, I gave your suggestion a try, but it didn’t work.
But I’m happy to try anything if it would allow me to keep both, Comodo and the NFS server.