Comodo Firewall is interfering with internet connection.


I been using comodo for a good while and I am quite pleased with this programme. Unfortunately it seems to be conflicting with my internet connection. Here is my problem: If the modem is already one before the computer or the computer had just restarted, a message comes up saying “limited or no connectivity”; After an hour or so the internet connection would just shut off with no warning what so ever; if I repair the connection the dialogue box opens with the a text talking about doing something with the ip address and still that doesn’t work. The only way to fix these problems is to disable the comodo firewall and then repair the connection. How do I fix this problem? Please be very descriptive, I may be familiar with comdo and its settings, but not completely.

If it helps, I am currently using: WIN XP SP3 with Comodo Internet Security v 3.11.108364.552.

Can you show me screenshots of the firewall logs and your Global Rules? The firewall logs can be found under Firewall → Common Tasks → View Firewall alerts. The Global Rules can be found under Firewall → Advanced → Network Security Policy → Global Rules.

Also let us know what kind of connection you are on. Dial up, ADSL, cable ,satellite…? Are you using a router?

I am currently using an ADSL modem connected via USB.

Logs: Photobucket | Make your memories fun!

Global: Photobucket | Make your memories fun!

There is broadcast traffic being blocked. Your computer is broadcasting to the router to get an IP address. The traffic from your computer from port 68 UDP broadcasting on port 67 UDP. Not shown, but should be in your logs as well, is the traffic from the router’s IP adress broadcasting on

The solutions is to add the addresses and to the Local Area Network #1. Go to Firewall → Common Tasks → My Network Zones → Edit and add the two addresses.

That should do the trick. Let us know how things go.

Just to be sure, I put this in the “Range of IP Address” slot; right?

Unfortunately, the solution you gave me does not work.

You need to add these two addresses one by one as a single IP address.

I see I left out a step in my description. Here is the full description:
The solutions is to add the addresses and to the Local Area Network #1. Go to Firewall → Common Tasks → My Network Zones → Select the network that describes yours → Edit and add the two addresses.

I see you deleted the images you uploaded to photobucket. Can you post a screenshot of your current Firewall logs and Global Rules as well as one of your My Network Zones?

How to post a screenshot at the forums without using a service like Photobucket?

At the forum push the reply button. Or when using the Quick reply type some text and push the preview button.

Underneath the text box click on Additional options. Push the Choose button and navigate to the file and select it. When you want to post more images click on the more attachments link.

When done typing push the Post or Preview button.

Here my configs; sorry about the phtobucket thing. I had to compress the pictures so they could be uploaded properly.

[attachment deleted by admin]

I would say that you should add 2 specific IPs and

Using a range from both of those is like every IP combination you can come up with. I’d say add those as 2 single IPs.

You need to the two IP addresses one by one as a single IP address.

Next please post bigger images. They are a challenge to read…:wink:

I am really sorry about the images. As a single address, you mean like this?

[attachment deleted by admin]

I assumed you would have the Local Area Network #1 in your My Network Zones. So my idea was to add the two addresses to the Local Area Network #1. But since that is not present we are going to define it.

I need one bit of extra information to be able to get it working. Go to Start (start button of Windows) → Run → cmd → push enter → you now come a black box (a DOS lookalike environment) → the the following: ipconfig /all → push enter → you will get a list of information about your network connections; paste all the information about your USB network connection here.

Is it a correct assumption that you are the only person using this connection?

ok, sorry for the late reply, yes I am the only one using the connection. Here is the in for from the ipconfig/all search from cmd.

Ethernet Adapter Local Area Connection 5:

Connection-specific DNS Suffix . : Lan 
Description..............................: Thomson ST Remote NDIS Device	
Dhcp Enabled...........................: Yes 
Autoconfiguration Enabeled........: Yes 
IP Address.......................:.......: 
Subnet Mask......................: 
Default Gaetway..................:	
DHCP Server......................:	
DNS Servers......................: 
Lease Obtained...................: 11 September 2009 15:08:38	
Lease Expires....................: 11 September 2009 17:08:38

Thanks for the additional information. You had already made the Local Area Network #1 now the only thing to do is add to that zone.

Does that do the trick or does the problem persist?

you mean add it to the zone in the firewall?

To be precise. Go to Firewall → Common Tasks -->My Nework Zones → select “Local Area Network #1” → add → a new address → select A single IP address → fill in → Apply → Now check to see that is added → Apply.

That seems to work under certain cases. The problem is, is that it the connection with the internet drops after a certain time. I am sure there is nothing wrong with the connection; in in a previous install of XP and Comodo this problem never affected me. Unfortunately now it’s acting up.

Can you show me screenshots of the Global Rules, My Network Zones and Firewall logs for the current situation? Do the logs of the Speedtouch give any clue? Also post a screenshot of the Speedtouch logs around the time the connection goes haywire.

What Speedtouch modem are you using? Just curious as I have had a 510 and 780 and currently using a 546.

I am using a Speedtouch 536.

Well everything seems to working now. I just did a clean uninstall (used the uninstall wizard then deleted all the files associated with Comodo) then reinstalled the Comodo. Then I waited until Comdo alerted me, asking if I should allow svchost.exe. This time I choose to accept Application, originally I had accidently set it to treat scvhost.exe as Web Browser. Maybe that was the problem after all.

Thanks for all the help EricJH, it felt like I was trying your patience with my lack of understanding on what to do.

PS: How do I take down all the screenshots I had posted?