Comodo firewall is in need of more testing!!

Hey all. In my opinion comodo firewall pro really needs more testing. Yesterday, after using it for roughly 4 weeks, I noticed my add/remove programs, internet options etc were giving me the shell32 error for having incorrect priveleges. Now I knew straight away it was something to do with the defense+ section of the firewall. So I disconnected my net, and uninstalled it. I restarted and all was well. I then proceeded to redownload the firewall after cleaning my reg entries and using ATF to knock out temp residents. Restart required. Fair enough. I restarted, and I was greeted with the message ‘‘Framework.dll cannot be found. reinstalling the application may solve this’’. I checked my folder, and I had to laugh. It was right there, blatantly in the folder. So anyway, I thought ‘‘I’ll get rid of it, and retry’’. Add/remove refused to unload it, even after removing every cfp process. CCleaner refused to unload it too. MSI Uninstaller was uneventful in the removal too. Great stuff. So I thought I’d look on the COMODO page for an uninstall tool similar to the Nero General Cleantool. But wait…my internet was completely down. After one reboot, it still stayed down. I checked EVERYTHING, and after about 20 minutes of pondering, I came to the conclusion it was down to my WinSock. So there I am, clicking diagnose connection problems, following the steps, and windows says '‘Repairs complete, restart computer’. This will fix it I thought. Wrong. I had to restore my system to a previous setting, and even then I had to use WinSock Fix to completely restore connectivity. Now in my opinion, this problem should have been addressed long before now. Comodo is a great firewall, but to be honest, I’m considering changing, because I have used many firewalls, and NEVER has this happened. If someone who knew nothing about systems had this problem, I’m guessing they would be in a fair bit of trouble.

I agree, I feel your problems…

I also agree, I still have errors noted many months ago and they still aren’t fixed.

What you are reporting is NOT something normal. It can not be observed unless one of the utilities you used(registry cleaner, file cleaner rtc) severely messed up the CFP configurations. CFP files are missing etc.

It is probably related to registry/file cleaner you used.

This still happens and nothing was done about it.

so your system was working bad cause of your defense+ settings
so u decided to uninstall comodo then clean your registry with some tool ? or u deleted yourself keys u knew they needed to be deleted ?
then u reinstall comodo and all is fucked…
but if it was a defense+ prob u can put it in training mode that way comodo learns things your system needs to run correctly or even disable it and restart your system to see what would happen.
i got comodo installed for a very long time now and i had those prob with D+ and some progs cause i was set in full paranoid mode and to put it in training mode solved the prob.
don’t u think u killed your registry ?
cause if your system went like that, what can put it down like that ?
who never used those reg cleaner and restart with a system full dead ?
not me, it happened to me a lot of time even, so i stopped using some of those tools i knew the best to mess my system. the only thing i use is youruninstaller and sometimes registry first aid platinum to see wich keys it analyses as sure to delete cause it contains no existent file/path, then keys caution keys and exrem caution.
except this reg tool, i always get troubles with others.
what’s your system ? xp or vista ?
vista is able to work still after a hard cleaning registry than xp.

wich settings u used with D+ when u had your system start running bad ?
wich tool u used to clean your registry ?
can’t tell i it’s comodo is the one that killed your system but u seem sure it is.
maybe some backup app to save your system will help next time u’re in trouble.
it saved me eachtime i made some big errors that killed my sytem.
but i’m not sure u’ll find a better security prog than comodo…
wich solution u’re going to use so ?
hope it will fix your “comodo” problem.

Apologies for the late reply. I receive no notifications when I get a response.

You seem to be implying that it’s my own error which caused this problem. The reason I am 100% sure it is COMODO is because I have been running my system smoothly since I installed my OS, which is well over 2 years or so. I use CCleaner, which is fantastic, and has NEVER given me any problems, (I have had CCleaner on numerous systems, and each one is running smooth as a button). So think of it this way…

System Install>>>period of time working perfectly>>>Using everyday programs and cleaning tools>>>Install COMODO>>>Fatal errors regarding my internet etc.

Now the chain of events here points explicitly to COMODO. I’m not a new comer to computers, I know what Im doing and I can work my way around a system, hence how I repaired it, so again this points to the fact it is actually the firewalls fault. I ran it in training mode to get it used to my habits, and everything else was done correctly.

Other people have commented, saying they have experienced the same as me. So surely this proves that it’s not our fault, but something severely wrong with COMODO?

(And yes, I deleted the keys myself then cleaned up with CCleaner afterward. I find this to be the most efficient way of dealing with these problems. And the firewall I shall use will be Kerio.)

Well, Since you point out that comodo was working for 4 weeks… It would make me think that comodo isn’t the problem…

there’s nothing i can say more,
i uninstalled comodo several times on xp or vista, reinstalled new builds, my systems never failed by uninstalling comodo…
kerio u say ?
well u’ll tell us it’s as good as comodo FW to secure the system.
but for myself, i’m sure i’m not going to change comodo for any other FW cause i have the feeling that this is the best FW if u care about security. Defense+ is the most important part for the security of my system :slight_smile:

Hi ichmonji.

Just at the top of my head:

-If you installed a firewall in the past, and uninstalled THEN used CFP, Make sure ALL FILES of that previously uninstalled Firewall are completely GONE.
-If you used another Defragger apart from Windows, or a Utility (Reg Cleaner, file cleaner, etc), I would take proper caution and trace back your steps if you used those particular tools.
-Make sure your system is virus/spyware clean, By doing some scanning.
-Make sure NOTHING is conflicting on startup (Start>Run & Type “msconfig” (without the quotes), Check your SERVICE and STARTUP tabs but DO NOT disable Microsoft Services!! (Make sure you hide all microsoft services).

Those 4 are your best bet in my opinion… Because as Egemen said it’s not normal.

Goodluck m8.

P.S - The Registry Cleaner in CCleaner is known to have some problems.