Comodo Firewall is Dropping Packets when DISABLED

Update: So, I reinstalled Win8 freshly and installed Comodo Firewall and it still has this issue. When the firewall is enabled everything is fine, but when I disable the firewall I start getting dropped packets.

Original Post:

So, I’ve had this happen a couple times before (in the past like 6 months ago, and maybe a year or two ago). The fix before was to just reinstall windows completely. However, I’d like to ask if anybody’s experienced this and knows of a fix or can suggest things to try, because I really don’t want to reinstall windows right now.

The Problem:

Comodo Firewall, firewall alone because I never install any of the geekbuddy, support, or any of that stuff and always disable defense+ and don’t have the antivirus and don’t use the sandbox, and I always disable the windows firewall; it was working just fine for like the past 2 months I’ve had it installed and was working just fine last night when I went to bed. This morning, I wake up and can’t connect to my vpn because of the amount of packet loss i’m getting. So, I go through troubleshooting everything, looking at another system, using an Ubuntu live cd, switching out ports on my router, etc and determine that it’s a software issue on my windows install causing the packet loss. I finally uninstall comodo firewall and the issue goes away completely. I then reinstall comodo firewall and leave it at default settings and disable the firewall using the tray icon and the issue is back. I make sure to uncheck filter localhost, disable defense+, and all that but the issue is still there. I enable the firewall again, run ping 10 times on google and have zero packet loss… disable the firewall again, back to 30-80% packet loss again.

I’ve tried disabling ipv6, unchecking ipv6 on the network adapter, even unchecking the comodo firewall driver on the network adapter, and even disabling the comodo service in the services list, and this packet loss still occurs as long as comodo is installed and disabled. I can reenable comodo and the packet loss goes away. I have also tried deleting the comodo directory under program files between reinstalls, as well as deleting all related registry entries between reinstalls, and none of this worked.

Now i’m like 99% sure that nothing changed to cause this, other software or system wise, while I was sleeping. There were no windows updates, no software updates, nothing that would have caused this to the best of my knowledge overnight. It just seems like comodo firewall randomly started doing it.

Summary of the issue:

  • Comodo firewall installed and enabled, no packet loss
  • Comodo firewall installed and disabled, packet loss occurs
  • Comodo firewall uninstalled, no packet loss

Anybody got any ideas?

This sounds like a bug to me. It may be worth reporting this as a bug.