Comodo Firewall & IPSEC

Please, solve the conflicts with Safenet IPSEC or I must deinstall all Comodo products !!

“Must deinstall”…huuu…scary threat there :wink:

Just kidding! What problems do you have? What does the logs says?

  1. when I start Remote desktop connection (RDC), normaly, it automaticaly activates IPSEC, which establish VPN connection regarding to IP specified in RDC, but this connection between RDC and IPSEC does not work.
  2. manualy I can start IPSEC, and after that I can connect over RDC to specified IP, but when I restart or shutdown the computer, before shutdown computer reports many memory errors.

please help

Hi, do you get these memory errors with Comodo uninstalled\DE-installed? Could you post one of these errors?

Thanks,

Paul

IreLike.exe An Application error

0xXXXXXX Memory could not be “written”.

Can you be a bit more specific please.
Are you able to manually start the VPN client, connect successfully and then connect using Remote Desktop? With the CPF both enabled and disabled?
Do you know which ports SafeNet VPN use? eg. split-tunneling ports, IKE etc…

Also, have you “allowed” SafeNet to connect in the Application Control Rules?

IreLike.exe An Application error

The instruction at 0xXXXXXXXX referenced memory at 0xXXXXXXX. Memory could not be “written”.

you can download VPN Client software at http://www.sprint.com/business/support/details/hardwareBasedIP-VPN.html
→ download VPN Client software → netscreen vpn client software for…

I’m sorry Zombie, but the error message you’ve copied’n’pasted are generated by your OS.
By looking at what you’ve posted, something tells me you have a corrupted execute or a memory-leak in the same execute. You might wanna uninstall (perhaps maybe both) an reinstall (both, starting woth the firewall).

Mr., I am B.Sc. computer technic, I installing one WIN2003 server per week, reinstalling several Win OS per day, I installed comodo on my own fresh installed notebook, be sure that I know what I talking about.

Zombie, I am sorry your issue isn’t resolved. I don’t think triplejolt is being insulting, he is simply trying to help. :wink: Another note, no one can see your certs for what you do or how much you know so many have to assume basics. Please keep this in mind as others are simply trying to help. Perhaps you should submit a support ticket http://support.comodo.com/ they may be able to solve this for you. Once again I apologize for this happening.

Paul

I am not angry just for information, think these few things (FW, AV, AS) seems promissy and work nice, and I hope that comodo will draw it to the end.

Hi Zombie, understood. :wink: But I still suggest you send a support ticket, the team may know this issue or how to solve it for you. It is free and they are very quick about contacting.

Paul

When I said to reinstall, I didn’t mean your OS. I meant SafeNet VPN client and Comodo Firewall.
The reason for saying this is that VPN sessions blocked by any type of firewall won’t generate an application error like yours. This is typically an internal application stop/error code returned to your OS. As the error message says, it’s being denied access to the memory space it’s trying to write to. Why this is, I can’t say for sure. I didn’t write SafeNet.

But I do know that IPSEC works behind the Comodo Firewall, so does Remote Desktop. And seeing as Remote Desktop is being encryptet (inside the VPN tunnel), the problem must be with the VPN client software itself. So heres a few things to try. Look for or make a rule in the Network Control Rules section:

  1. Allow any inside to connect to any outside on UDP 500 (This is the isakmp protocol/IKE=Internet Key Exchange)
    This rule is to make sure the VPN client will make a successful connection regardles of the settings in your Application Control Rules. You might wanna check the ACR section too just to make sure the VPN client application isn’t being blocked.
  2. If you’re using NAT or private addresses, you must enable IPSEC NAT-T (NAT traversal). Make a firewall rule in the receiving end to Allow [Your IP address or range] on UDP 4500. This is to allow UDP-ESP traffic to pass unhindered.

For the record I had no intentions of being sarcastic or condescending. I mearly wanted to provide you with an answer to a problem that is seemingly generated by the VPN client. All you provided was an application error message, so I asumed you had checked the logs in the firewall and didn’t find anything there.

Here’s some readingmaterial if you’re interested in How IPSec Works. It’s a link to an article on Microsoft techNet and should be interesting.
(:NRD)

Hope this helps

I think here is not the problem if some ports are activated or not, here is some deeper problem (memory usage conflicts or some similar problem).

I beleive so too. Being denied access to a memory space is often a result of bad programming, memory-leak in the application or faulty memory (hardware). Have you tried to replace the memory?

Hardware is ok Triplejolt, but it seems that only you and I are interested to improve comodo firewall.

Hang in there Zombie. You’ll sort it out soon enough :slight_smile:

LOL!
If you look high up to the right, you will see that there is over 30000 post in here…
and you have made…? :wink:

Thanks Triplejolt for helping zombie, and I don’t think that anyone cares that it’s not a problem with a Comodo product, because everyone is welcome here. I think Triplejolt in capable of helping you with this.

It can be a conflict, but if it is, you (zombie) really need to give us some more information. Not just to help you, but to also help others. You haven’t answered questions from people that have tied to help you.

If you think it’s a conflict with the firewall, you should tell us.
What version of the firewall do you use?
Have you tried uninstalled the firewall? Does it work without it?
Have you tried a newer version (beta)?
Have you checked the logs in windows?
Have you tried to reinstall the remote desktop app?
There are more questions, but start to answer these.

Have you submitted a support ticket?
What did they say?

Can i suggest that the OP not jump too far ahead of him/her self, just because of a degree. I myself even though have alot of knowledge am still happy to take the simple steps first. Just remind yourself in a stressful situation not to jump ahead just because of a degree., because most often it is a simple solution that fixes the problem even in computers (-: .

cheers, rotty