Comodo Firewall interferes with Windows 10 Advanced Startup

Comodo Firewall interferes with Windows 10 Advanced Startup. Specifically, Comodo Firewall causes Startup Settings to stop working.

On a clean Windows 10 installation, I confirmed Startup Settings worked. I installed Comodo Firewall, and subsequently, Startup Settings stopped working: The system skipped Startup Settings and booted directly to the operating system and desktop instead of Safe Mode. I uninstalled Comodo Firewall, and Startup Settings worked again. I reinstalled Comodo Firewall, and as expected, Startup Settings stopped working.

Edit: This happens when Comodo Firewall 11 or 12 is installed.

Try adding the executable(s) of Advanced Startup to the exclusions of Disable shellcode injection detection.

Does that make a difference? If it doesn’t help add the installation folder of Avanced Startup to the exclusions.

What are the executables, and where are they located? I can’t find any information about them. The closest thing I could find is this:

But adding those files to exclusions did not work.

What is Windows 10 Advanced Startup? Is it the .lnk file provided by Ten Forums that you linked to?

Make sure bootim.exe is trusted, I had an issue when it was not trusted because I wasn’t online when I first tried advanced startup. Then I tried again after performing an online lookup of the executable, I was able to use advanced startup options.

It is an advanced boot options screen which allows users to start Windows in advanced troubleshooting modes or change startup settings, including entering safe mode, which is what I was trying to do, but the subsequent startup settings screen did not work. The .lnk file is a shortcut to launch Advanced Startup.

This worked. In my case, bootim.exe was not even listed in Comodo Firewall, even after a scan. I manually added the file and set its rating to trusted, which solved the issue.